Subject: [NSIS] NSIS run on MIPL ?

From: "斌斌王" <[email-masked]>
Date: Tue, 23 May 2006 19:17:25 +0800

Hi All:

I am a student of Beijing University of Posts and Telecommunications, China.
I have studied  NSIS for several months. As is knowen to all that NSIS is
run on IP like the figure below.

                                NSLP
            ================================
                                NTLP
            ================================
           +--------------------------------------------------------------+
                               IP v4/v6

For our lab have done some research on MIPL (Mobile IPv6 for Linux.
http://chasey.mobile-ipv6.org/software/). And now I want to combine NSIS and
MIPL ---- run NSIS on MIPL.
                                NSLP
            ================================
                                NTLP
            ================================
            +------------------------------------------------------------+
                                MIPL

I don't know whether this idea is rational and doable .I need some
suggestions. Thank you, everyone who read this mail.

Bestwishes!

                                                       Binbin Wang
                                                       2006-5-23

-- 
*i*memo*ce* journey
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 23 May 2006 20:58:06 +0200

Hi Binbin,

running NSIS in combination of MIPv6 is certainly possible.
http://www.ietf.org/internet-drafts/draft-ietf-nsis-applicability-mobility-signaling-04.txt
talks about the problems and explains how gist/nslps work together with 
MIPv6.

 From layering point of view the MIPv6 stuff runs below NSIS. Hence, 
your figure is correct from this point of view. Is this your question?

Ciao
Hannes

斌斌王 wrote:
> Hi All:
> 
> I am a student of Beijing University of Posts and Telecommunications, 
> China. I have studied  NSIS for several months. As is knowen to all that 
> NSIS is run on IP like the figure below.
> 
>                                 NSLP
>  http://chasey.mobile-ipv6.org/software/). And now I want to combine 
> NSIS and MIPL ---- run NSIS on MIPL.
> 
>                                 NSLP
> ------------------------------------------------------------------------
>

---

From: "Elena Scialpi" <[email-masked]>
Date: Mon, 29 May 2006 11:04:38 +0200

Hi all,

I have proposed a solution to resolve some problems of NSIS/MIP interaction 
.
You can read it at:

http://www.ietf.org/internet-drafts/draft-tommasi-nsis-semipro-00.txt

I'm very happy to answer your questions!
Elena

> From layering point of view the MIPv6 stuff runs below NSIS. Hence, your 
> figure is correct from this point of view. Is this your question?
>
> Ciao
> Hannes
>
>
> 斌斌王 wrote:
>> Hi All:
>>
>>                                IP v4/v6      For our lab have done some 
>> research on MIPL (Mobile IPv6 for Linux. 
>> http://chasey.mobile-ipv6.org/software/). And now I want to combine NSIS 
>> and MIPL ---- run NSIS on MIPL.
>>
>>                                 NSLP
>>                                 MIPL    I don't know whether this idea is 
>> rational and doable .I need some suggestions. Thank you, everyone who 
>> read this mail.
>>    Bestwishes!
>>  Binbin Wang
>>                                                        2006-5-23
>>                                                -- 
>> *i*memo*ce* journey
>>
>>

------------ 
LIIS
Laboratorio per l'Internetworking
e l'Interoperabilita' tra i Sistemi
http://liis.unile.it
http://www.campusdelsalento.it
Office: (+39) 0832-297310
c/o Palazzo di Ingegneria
Via per Monteroni
I-73100 Lecce LE, Italy