Subject: [NSIS] Packet Classifier in QoS NSLP

From: David Palma <[email-masked]>
Date: Wed, 10 May 2006 11:25:03 +0100

Hi all,

In QoS NSLP draft (v10) the Packet Classifier object is described as below:

5.1.3.5.  PACKET_CLASSIFIER

   Type: Packet Classifier

   Length: Variable

   Value: Contains a 2 byte value indicating the MRM being used, and

   then additional variable length MRM-specific data

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |    Message-Routing-Method     |                               |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                               +

   //          Method-specific classifier data (variable)         //

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   For the basic path-coupled routing MRM, the method specific data is

   two bytes long and consists of a set of flags:

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |X|Y|P|T|F|S|A|B|   Reserved    |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

If I am understanding the above text correctly, the Packet Classifier should have a short for Loose End routing and 2 shorts for Path Coupled.

So I assume that will always have Length 1 (1 word) to both routing methods right? The word "variable" to the length confuses me a little bit.

Are my assumptions correct?

Regards,

David Palma

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Andrew McDonald <[email-masked]>
Date: Thu, 11 May 2006 12:48:07 +0100

Hi David,

> In QoS NSLP draft (v10) the Packet Classifier object is described as
[snip]
> If I am understanding the above text correctly, the Packet Classifier
> should have a short for Loose End routing and 2 shorts for Path
> Coupled.
> 
> So I assume that will always have Length 1 (1 word) to both routing
> methods right? The word "variable" to the length confuses me a little
> bit.
> 

The QoS NSLP does not make use of the GIST LE-MRM. It is only defined to 
use the PC-MRM.

I thought I had added a statement about this in draft -10. Having had a 
quick check, I can't see it. This obviously needs clarifying in the draft.

(Added to QoS NSLP issue tracker as issue 59:
http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-qos-nslp-issues/issue59)

regards,

Andrew

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 11 May 2006 15:33:10 +0200

Hi all,

My comment is related to the below email but not directly for the QoS  
NSLP.

Probably it is good to add a paragraph to John's draft on NSLP  
extensibility
saying that future NSLPs need to clarify what message routing methods  
(MRM)
they are going to use.

   Martin

Am 11.05.2006 um 13:48 schrieb Andrew McDonald:

> The QoS NSLP does not make use of the GIST LE-MRM. It is only  
> defined to use the PC-MRM.
>
> I thought I had added a statement about this in draft -10. Having  
> had a quick check, I can't see it. This obviously needs clarifying  
> in the draft.
>