Subject: RE: [NSIS] NATFW NSLP support for NAT-PT (IPv4 to IPv6 translation)

From: "Hancock, Robert" <[email-masked]>
Date: Fri, 12 May 2006 12:08:03 +0100

hi,

i think this is a question of what is the current deployment. 

if NAT-PT is currently seriously deployed to any extent, we 
have to deal with it. however, dealing with it may simply mean 
detecting and returning an error condition.

if NAT-PT is not currently seriously deployed, then we can
probably forget about it.

r.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 12 May 2006 11:49
> To: [email-masked]; [email-masked]
> Subject: RE: [NSIS] NATFW NSLP support for NAT-PT (IPv4 to 
> IPv6 translation)
> 
> 
> 
> >The draft -11 of the NATFW NSLP is somewhat unspecified about 
> >the usage of the IPv4 to IPv6 (and vice versa) transition 
> >mechanism NAT Protocol Translation (NAT-PT, RFC 2766). While 
> >in the past the NSLP had some text specifying how the NSLP 
> >should handle NAT-PT, it has been removed. One of the reasons 
> >is the draft 
> >http://www.ietf.org/internet-drafts/draft-ietf-v6ops-natpt-
> >to-exprmntl-03.txt
> >
> >The question is where to go with NAT-PT. Should the NATFW NSLP 
> >support NAT-PT or not? Probably, this is requires more a 
> >political answer rather than a technical!
> 
> Well, I'd say that we don't need to address NAT-PT, unless anyone in
> the audience (in the mailing list) is specifically interested in it.
> 
> John
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Ali Fessi <[email-masked]>
Date: Fri, 12 May 2006 18:00:27 +0200

Hi,

> i think this is a question of what is the current deployment. 

aren't NAT-PTs deployed to connect 3G PS domains to the Internet?

> detecting and returning an error condition.

that would be one option. The other option is that the NATFW signaling 
can be scoped at the NAT-PT, which acts as NR.
NATFW NSLP does already support this with the proxy mode.

ali

-- 
Ali Fessi
Computer Networks and Internet
Wilhelm Schickard Institute for Computer Science
University of Tuebingen, Germany
Phone: +49 7071 29-70534 / Fax: +49 7071 29-5220
EMail: [email-masked]
Web: http://net.informatik.uni-tuebingen.de/~fessi/

---

From: <[email-masked]>
Date: Sat, 13 May 2006 10:23:39 +0300

Ali,

>aren't NAT-PTs deployed to connect 3G PS domains to the Internet?

NAT-PTs have been discussed as a way to connected 3G IMS deployments to
internet SIP deployments, but in practice, I don't know if anything has
been deployed.  

But this is more of a question to the list - does anyone see any major
NAT-PT
deployments, and would the NATFW NSLP be something do consider in this
type of deployment?

John

>> if NAT-PT is currently seriously deployed to any extent, we have to 
>> deal with it. however, dealing with it may simply mean detecting and 
>> returning an error condition.
>
>that would be one option. The other option is that the NATFW 
>signaling can be scoped at the NAT-PT, which acts as NR.