Subject: [NSIS] Question about " QSPEC Proc."

From: Jukka MJ Manner <[email-masked]>
Date: Mon, 6 Nov 2006 06:08:42 +0200 (EET)

Hi Jerry et al.,

I was reading the QSPEC spec with Roland, and we were both wondering what 
the " QSPEC Proc." field in the QSPEC Common Header is? Isn't this 
something that should be actually in the API between the NSLP and RMF, not 
encoded inside the QSPEC itself?

Jukka

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Kappler, Cornelia" <[email-masked]>
Date: Wed, 8 Nov 2006 11:44:13 +0100

Hi Jukka,  

[Just as a reminder for those not so familiar with the details of the QSPEC:] 
The "QSPEC procedure" ID is included in a QoS NSLP message (currently in the QSPEC header) to identify the expected message sequence (e.g. QUERY-RESERVE-RESPONSE) and the QoS Objects to include in each message (e.g. QoS Available into QUERY, QoS Desired in RESERVE and QoS Reserved in RESPONSE). The QSPEC Procedure ID is included by the QNE initiating a signaling session to inform the receiving QNE about the message it is supposed to generate in reply.

I am not sure where the decision is taken about which QSPEC procedure to use; presumably in the application or the RMF. It must be included in a message, but I am not sure where the best place is (QoS NSLP or QSPEC). It may have to be passed over the (non.standardized) API between QoS NSLP and QSPEC.

Cornelia

> -----Ursprüngliche Nachricht-----
> Von: Jukka MJ Manner [mailto:[email-masked]] 
> Gesendet: Montag, 6. November 2006 05:09
> An: [email-masked]
> Betreff: [NSIS] Question about " QSPEC Proc."
> 
> 
> Hi Jerry et al.,
>

---

From: Roland Bless <[email-masked]>
Date: Wed, 08 Nov 2006 17:57:55 +0100

Hi Cornelia,

Kappler, Cornelia schrieb:
> [Just as a reminder for those not so familiar with the details of the
> QSPEC:] The "QSPEC procedure" ID is included in a QoS NSLP message
> (currently in the QSPEC header) to identify the expected message
> sequence (e.g. QUERY-RESERVE-RESPONSE) and the QoS Objects to include
> in each message (e.g. QoS Available into QUERY, QoS Desired in
> RESERVE and QoS Reserved in RESPONSE). The QSPEC Procedure ID is
> included by the QNE initiating a signaling session to inform the
> receiving QNE about the message it is supposed to generate in reply.
> 
> I am not sure where the decision is taken about which QSPEC procedure
> to use; presumably in the application or the RMF. It must be included
> in a message, but I am not sure where the best place is (QoS NSLP or
> QSPEC). It may have to be passed over the (non.standardized) API
> between QoS NSLP and QSPEC.

Maybe I don't get the point completely, but I would expect
that it is an internal API issue (currently we don't have any
QoS NSLP API), so QoS-NSLP would usually indicate the message type
(QUERY, RESERVE, RESPONSE) to the RMF/Application.

Regards,
 Roland

---

From: Jukka MJ Manner <[email-masked]>
Date: Wed, 8 Nov 2006 19:15:46 +0200 (EET)

Hi,

The NSLP knows what messaging is going on, it doesn't need to be specified 
in some additional tags. Therefore I thought that this information can be 
passed between the RMF through an API. But I guess you could encode that 
into the QSPEC by the QNI/QNR, if there is some good reason.

Jukka