Subject: [NSIS] question about GIST-Query message

From: "斌斌王" <[email-masked]>
Date: Thu, 2 Nov 2006 15:29:25 +0800

Hi all,

I have a question about GIST-Query message. Whether the GIST-Query message
is group sending in networking?
                         +--+
                          |B |
                        .+--+.
                       .        .
                  +-+          . +--+
                  |A |.            | D|
                  +-+.          .+--+
                        .        .
                         .+--+.
                          |C  |
                          +--+
Assume node A, node B, node C, and node D, they all support the same NSLP.
Node A sends a GIST-Query message, namely a UDP datagram addressed to the
node D and include an IP RAO. whether both node B and node C will receive
the Query message? And which node that node A will establishes GIST state
with it? Finally the signaling path is A >> B >> D, or A >> C >> D ?

Bestwishes!

Wang
2006-11-2

-- 
skyWang.bupt
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 2 Nov 2006 17:14:27 -0000

Hi Wang,
 
Let's assume you are talking about signalling for a data flow from A to D; this then uses the path-coupled MRM within GIST.
 
The GIST-Query is then an IP datagram with the destination address D, and the source address A. Which path the datagram takes through the network depends on the normal network routing of IP datagrams with these addresses - GIST doesn't change this routing. In other words, if a normal datagram with a destination address of D is routed A>>C>>D, then the signalling will follow the same route (and these will be the nodes that create signalling state).
 
Does this answer your question?
 
yours,
 
Robert H.

	-----Original Message-----
	From: ±ó±óÍõ [mailto:[email-masked]] 
	Sent: 02 November 2006 07:29
	To: [email-masked]
	Subject: [NSIS] question about GIST-Query message

	Hi all,
	 
	I have a question about GIST-Query message. Whether the GIST-Query message is group sending in networking?
	                         +--+             
	                          |B |
	                        .+--+.             
	                       .        .       
	                  +-+          . +--+
	                  |A |.            | D| 
	                  +-+.          .+--+
	                        .        .      
	                         .+--+.        
	                          |C  |
	                          +--+ 
	Assume node A, node B, node C, and node D, they all support the same NSLP. Node A sends a GIST-Query message, namely a UDP datagram addressed to the node D and include an IP RAO. whether both node B and node C will receive the Query message? And which node that node A will establishes GIST state with it? Finally the signaling path is A >> B >> D, or A >> C >> D ? 
	 
	Bestwishes!
	 
	Wang
	2006-11-2

	-- 
	skyWang.bupt