Subject: [NSIS] An issue related to NOTIFY

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 23 Nov 2006 16:53:59 +0100

Hi Jerry

One of the issues that I have posted some weeks before the IETF meeting in
San Diego
was QSPEC-Issue (GK3), which was independent of the mandatory/optional
parameter 
discussion, see below.

In Section 6.4.5 it is mentioned:
"No QSPEC is carried in the NOTIFY message. The NOTIFY message carries only
the 
Session ID and a INFO_SPEC with the error code as described in [QOS-SIG]."

Note that a NOTIFY is allowed to carry a QSPEC, see QoS-NSLP draft.
Therefore, it should be allowed for QOSMs to specify, also in the case of
preemption, 
to send a QSPEC together with the INFO_SPEC object.

Furthermore please note that a NOTIFY does not carry a Session ID.

Requested change:
Modify text in Section 6.4.5 (Preemption):
From:
"No QSPEC is carried in the NOTIFY message. The NOTIFY message carries only
the 
Session ID and a INFO_SPEC with the error code as described in [QOS-SIG]."

INTO:
"The NOTIFY message carries an  INFO_SPEC with the error code as described 
in [QOS-SIG]. A QOSM specification document may specify wheter a NOTIFY also

carries a QSPEC object."

Could you please make these modifications?

Best regards,
Georgios

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Sat, 25 Nov 2006 06:49:20 -0600

Hi Georgios,

Your proposed change looks OK to me.

Thanks,
Regards,
Jerry 

-----Original Message-----
From: Georgios Karagiannis [mailto:[email-masked]] 
Sent: Thursday, November 23, 2006 10:54 AM
To: Ash, Gerald R (Jerry), ALABS
Cc: 'NSIS Group'
Subject: An issue related to NOTIFY

Hi Jerry

One of the issues that I have posted some weeks before the IETF meeting
in
San Diego
was QSPEC-Issue (GK3), which was independent of the mandatory/optional
parameter 
discussion, see below.

In Section 6.4.5 it is mentioned:
"No QSPEC is carried in the NOTIFY message. The NOTIFY message carries
only
the 
Session ID and a INFO_SPEC with the error code as described in
[QOS-SIG]."

Note that a NOTIFY is allowed to carry a QSPEC, see QoS-NSLP draft.
Therefore, it should be allowed for QOSMs to specify, also in the case
of
preemption, 
to send a QSPEC together with the INFO_SPEC object.

Requested change:
Modify text in Section 6.4.5 (Preemption):
From:
"No QSPEC is carried in the NOTIFY message. The NOTIFY message carries
only
the 
Session ID and a INFO_SPEC with the error code as described in
[QOS-SIG]."

INTO:
"The NOTIFY message carries an  INFO_SPEC with the error code as
described 
in [QOS-SIG]. A QOSM specification document may specify wheter a NOTIFY
also

carries a QSPEC object."

Best regards,
Georgios