Subject: Fwd: [NSIS] Call for consensus draft-loughney-nsis-ext-02.txt as WG document?

From: Martin Stiemerling <[email-masked]>
Date: Mon, 1 Oct 2007 09:25:06 +0200

Hi all,

Just a friendly reminder about the call for consensus.

A short summary of the draft's intention, for people not that  
familiar with this draft:

The intention of this draft is to collect information from the NSIS  
WG about how GIST, QoS NSLP, and NAT NSLP can be extended. This  
information should guide future drafts on how you do a good extension  
to the different protocols and probably even more important to where  
add those extensions. E.g., whether a new feature should go to as a  
GIST extension, as a NSLP extension, or new NSLP.

Thanks,

   Martin

Anfang der weitergeleiteten E-Mail:

> Von: Martin Stiemerling <[email-masked]>
> Datum: 27. September 2007 17:14:45 MESZ
> An: nsis <[email-masked]>
> Betreff: [NSIS] Call for consensus draft-loughney-nsis-ext-02.txt  
> as WG document?
>
> Hi all,
>
> Some time ago, John wrote the draft draft-loughney-nsis-ext-02.txt  
> discussing the extensibility of NSIS.
>
> It has been discussed on the mailing list, plus during the IETF  
> meetings and it seems to be a good shape to become a WG document.
>
> Therefore, I would like to propose draft-loughney-nsis-ext-02.txt  
> becoming a WG draft by now.
>
> This requires consensus of WG to do so.
>
> Please send your opinion on whether you like to see draft-loughney- 
> nsis-ext-02.txt as WG document or not to the NSIS mailing list by  
> no later than Oct 4th 5pm PST.
>
> Thanks,
>
>   Martin
>
> [email-masked]
> NEC Laboratories Europe - Network Research Division
>
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,  
> London W3 6BL | Registered in England 2832014
>
>
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis

[email-masked]
NEC Laboratories Europe - Network Research Division

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,  
London W3 6BL | Registered in England 2832014

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 1 Oct 2007 09:28:25 +0200

[ writing WG chair's hat off]

This draft is extremely useful for people trying to extend parts of  
NSIS in the future. Especially, for people not having participated  
during the times when NSIS has been made.

Therefore, I would like to see this draft as WG document.

   Martin

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 01 Oct 2007 11:52:05 +0200

Hi Martin

I agree that such a document is useful.

There are, however, a few follow-up questions:
a) When do you write such a document?
b) What is the scope of the document?

Regarding (a): In the RADEXT and the DIME working group we are currently 
producing documents that provide sort of design guidelines, see
http://www.ietf.org/internet-drafts/draft-ietf-dime-app-design-guide-02.txt
http://www.ietf.org/internet-drafts/draft-ietf-radext-design-00.txt

 These two documents are written based on the experience that something 
went wrong regarding the way how people extended the protocol. Maybe it 
would have been better to write these documents earlier. Now we 
obviously have much more bad examples to write about.

Regarding (b): Should the document focus only on GIST or should it also 
cover the NSLPs? What happens if you define a new NSLP - do you revise 
the document?

How far can this document go beyond the already described information 
found in GIST, and the NSLPs? I could, for example, imagine that someone 
gives details about the common design aspects where you could 
essentially "steal" text from existing NSLPs.

Ciao
Hannes

Martin Stiemerling wrote:
> Please send your opinion on whether you like to see 
> draft-loughney-nsis-ext-02.txt as WG document or not to the NSIS 
> mailing list by no later than Oct 4th 5pm PST.
>
> Thanks,
>
>   Martin
>
> ------------------------------------------------------------------------
>

---

From: Luís Cordeiro <[email-masked]>
Date: Mon, 01 Oct 2007 10:56:16 +0100

Hi all,

I think that this draft is very important for NSIS. Extensions to
protocols are a part of our work to improve Internet, and so I think
that it is very important to have a document that helps everyone to do
it.

BR,

Luís Cordeiro

Hi all,

Some time ago, John wrote the
draft draft-loughney-nsis-ext-02.txt discussing the extensibility of
NSIS.

Therefore, I would like to
propose draft-loughney-nsis-ext-02.txt becoming a WG draft by now.

Please send your opinion on whether you like to
see draft-loughney-nsis-ext-02.txt as WG document or not to the NSIS
mailing list by no later than Oct 4th 5pm PST.

Thanks,

Martin

NEC Laboratories Europe - Network Research
Division

NEC Europe Limited | Registered Office: NEC
House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: "Hancock, Robert" <[email-masked]>
Date: Mon, 1 Oct 2007 11:00:39 +0100

hi all,

imho the document is needed.

in terms of scope, I believe that the questions to be answered are
- what policies to adopt in extending GIST
- and then, since GIST defines the NSLPID, what policies to adopt
in deciding to create a new NSLP vs. extending an existing one

I believe it's possible to write useful general guidance on the 
second topic, without going into details on the extensibility issues
for specific NSLPs. With respect to the first topic, the GIST spec
already depends on the existence of this document (at the moment
implicitly, since it is so long expired ...)

it would certainly be good to draw on other protocol extensibility
discussions for both of these, such as the AAA documents hannes refers
to below (there is also Brian's extensibility guidelines document, not
sure of its current status).

robert h.

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: 01 October 2007 10:52
> To: Martin Stiemerling
> Cc: nsis
> Subject: Re: [NSIS] Call for consensus 
> draft-loughney-nsis-ext-02.txt as WGdocument?
> 
> Hi Martin
> 
> Regarding (a): In the RADEXT and the DIME working group we 
> are currently producing documents that provide sort of design 
> guidelines, see 
>  These two documents are written based on the experience that 
> something went wrong regarding the way how people extended 
> the protocol. Maybe it would have been better to write these 
> documents earlier. Now we obviously have much more bad 
> examples to write about.
> 
> Regarding (b): Should the document focus only on GIST or 
> should it also cover the NSLPs? What happens if you define a 
> new NSLP - do you revise the document?
> 
> How far can this document go beyond the already described 
> information found in GIST, and the NSLPs? I could, for 
> example, imagine that someone gives details about the common 
> design aspects where you could essentially "steal" text from 
> existing NSLPs.
> 
> Ciao
> Hannes
> 
> 
>

---

From: Jukka MJ Manner <[email-masked]>
Date: Mon, 1 Oct 2007 20:18:58 +0300 (EEST)

I also think the draft is important and it should progress to WG status.

Jukka

---

From: Attila Báder <[email-masked]>
Date: Tue, 2 Oct 2007 13:20:15 +0200

I also support it, 

Best regards, Attila

-----Original Message-----
From: Jukka MJ Manner [mailto:[email-masked]] 
Sent: Monday, October 01, 2007 7:19 PM
To: Martin Stiemerling
Cc: nsis
Subject: Re: [NSIS] Call for consensus draft-loughney-nsis-ext-02.txt as WGdocument?

Jukka

---

From: Takako Sanda <[email-masked]>
Date: Thu, 04 Oct 2007 14:00:37 +0900

Hi,

I also think this draft is useful, and agree to being progressed to WG
draft.

cheers,
Takako

On Thu, 27 Sep 2007 17:14:45 +0200
Martin Stiemerling <[email-masked]> wrote:

> nsis-ext-02.txt as WG document or not to the NSIS mailing list by no  
> later than Oct 4th 5pm PST.
> 
> Thanks,
> 
>    Martin
>

---

From: Roland Bless <[email-masked]>
Date: Thu, 04 Oct 2007 14:55:01 +0200

Hi Martin and all,

Martin Stiemerling wrote:
> It has been discussed on the mailing list, plus during the IETF meetings
> and it seems to be a good shape to become a WG document.
> 
> draft-loughney-nsis-ext-02.txt as WG document or not to the NSIS mailing
> list by no later than Oct 4th 5pm PST.

I guess that it is important to have a document like this,
it is also referred to by other drafts (e.g. GIST) and would
be especially useful for folks in the future who want to
extend NSIS (esp. those from other SDOs etc).
Probably it needs some more discussion within the WG,
but basically it seems to be a good start...

So I'm in favor of WG adoption of this draft.

Regards,
 Roland

---

From: Martin Stiemerling <[email-masked]>
Date: Fri, 5 Oct 2007 13:00:26 +0200

Hi Hannes,

Am 01.10.2007 um 11:52 schrieb Hannes Tschofenig:

> Regarding (a): In the RADEXT and the DIME working group we are  
> currently producing documents that provide sort of design  
> guidelines, see
> something went wrong regarding the way how people extended the  
> protocol. Maybe it would have been better to write these documents  
> earlier. Now we obviously have much more bad examples to write about.

We are in the lucky situation to write such a document before things  
can go wrong. That is a good reasons to start now.

>
> Regarding (b): Should the document focus only on GIST or should it  
> also cover the NSLPs? What happens if you define a new NSLP - do  
> you revise the document?

It should cover the whole NSIS stack, i.e., GIST and the NSLPs. When  
you are tying to extend NSIS as such, you first need to find out the  
right place to do the extension.

> information found in GIST, and the NSLPs? I could, for example,  
> imagine that someone gives details about the common design aspects  
> where you could essentially "steal" text from existing NSLPs.

This is a good point.

   Martin

>> NEC Europe Limited | Registered Office: NEC House, 1 Victoria  
>> Road, London W3 6BL | Registered in England 2832014
>>
>>
>>

---

From: Xiaoming Fu <[email-masked]>
Date: Mon, 08 Oct 2007 12:15:37 +0200

I agree it is really good to have this document to become WG doc.
Xiaoming

Martin Stiemerling wrote:
>> currently producing documents that provide sort of design guidelines, see
>> went wrong regarding the way how people extended the protocol. Maybe 
>> it would have been better to write these documents earlier. Now we 
> We are in the lucky situation to write such a document before things can 
> go wrong. That is a good reasons to start now.
> 
>>
>> also cover the NSLPs? What happens if you define a new NSLP - do you 
>> revise the document?
> 
> It should cover the whole NSIS stack, i.e., GIST and the NSLPs. When you 
> are tying to extend NSIS as such, you first need to find out the right 
> place to do the extension. 
> 
>>
>> found in GIST, and the NSLPs? I could, for example, imagine that 
>> someone gives details about the common design aspects where you could 
>>> [email-masked] <mailto:[email-masked]>
>>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>