Subject: [ntpwg] NTP WG Last Call:draft-ietf-ntp-autokey-03.txt

From: Brian Haberman <[email-masked]>
Date: Wed, 16 Jul 2008 08:43:52 -0400

All,
      This message starts a 2-week NTP Working Group Last Call on advancing:

       Title     : Network Time Protocol Version 4 Autokey Specification
       Author(s) : B. Haberman, D. Mills
       Filename  : draft-ietf-ntp-autokey-03.txt
       Pages     : 52
       Date      : 2008-6-9
	
as an Informational document.  Substantive comments and statements of 
support or opposition for advancing this document should be directed to 
the mailing list.  Editorial suggestions can be sent to the document 
editor.  This last call will end on August 1, 2008.

Regards,
Brian & Karen
NTP co-chairs
_______________________________________________
ntpwg mailing list
[email-masked]
https://lists.ntp.org/mailman/listinfo/ntpwg

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 29 Jul 2008 01:06:36 +0300

No substantive comments (a large number of nits below).

Autokey is an efficient and cryptographically sound
method to authenticate NTP servers.
There is open source software that proves that it works.
The document is well written, and contains all the needed
information to understand and use the protocol.

IMO this document (modulo fixing the nits below) is ready for publication.

Y(J)S

==================================================================
NITS

page 9
---------
For use with IPv4 the Source Address and Dest Address fields contain
should be
For use with IPv4 the Source Address and Destination Address fields contain
or
For use with IPv4 the Src Address and Dst Address fields contain
(the latter is used in the following figure)

page 10
-----------
unterminated sentence :

The first 32 bits of the result in network byte order become the next
The MD5 hash of the autokey is the key value saved in the key cache

page 15
-----------
independent means such as a drivers license are required for a CA to

should be either driver license or driver's license

page 19
-----------

outlyers

I know that this is the way it is spelled in other NTP documents,
but I still think it is "outliers".

page 22
-----------

4 octet boundary  ->  4-octet boundary

the parser increments the pointer by the lengthuses uses
should be
the parser increments the pointer by the length and then uses

page 24
-----------

associaton  -> association

page 25
-----------

A valid responselights the VRFY bit  (add space)

page 29
-----------

from the ASSOC respones. -> from the ASSOC responses.

page 31
-----------

client ssociation  (missing "a")

page 32
-----------

retrive  -> retrieve

using a a cookie exchange  (too many "a"s)

page 33
-----------

broadcasst  -> broadcast

exceeds tha count  -> exceeds the count

page 34
-----------

the the  (one is enough)

page 35
-----------

tempoerarily revers to  ->  temporarily reverts to

page 37
-----------

""Compouter Network Time Synchronization - the Network Time Protocol""

(Computer, and one set of " is enough)

many places
------------------
Figure Figure  and FigureFigure
(probably an xml2rfc error !)

page 45
-----------
descrete -> discrete

12.  IANA Considerations
------------------------------------
   Any IANA registries needed?

Assuming that the answer is no, then please replace with
"This document has no IANA Actions."

13.  Acknowledgements
-----------------------------------
   ...

Well, I guess that no-one needs acknowledging.
Can we either drop this section, or perhaps acknowledge
those who have commented in the past ?

14.1.  Normative References
----------------------------------------
Please change  [I-D.ietf-ntp-ntpv4-proto] to point to version 10.

=========================================================================

From: ntpwg-bounces+yaakov_s=[email-masked] [mailto:ntpwg-bounces+yaakov_s=[email-masked]] On Behalf Of Brian Haberman
Sent: Wednesday, July 16, 2008 3:44 PM
To: NTP Working Group
Subject: [ntpwg] NTP WG Last Call:draft-ietf-ntp-autokey-03.txt

All,

as an Informational document.  Substantive comments and statements of support or opposition for advancing this document should be directed to the mailing list.  Editorial suggestions can be sent to the document editor.  This last call will end on August 1, 2008.

Regards,
Brian & Karen
NTP co-chairs

---

From: "David L. Mills" <[email-masked]>
Date: Tue, 29 Jul 2008 03:30:53 +0000

Guys,

I've made all the changes Yaakov suggested; but, when I run it through 
xml2rfc I get

unable to find external file "reference.I-D.ietf-ntp-ntpv4-proto-10" or "reference.I-D.ietf-ntp-ntpv4-proto-10.xml"

I don't know where that -10 came from; it is not in the xml document itself.

Dave

Yaakov Stein wrote:

> deleted,,,

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 29 Jul 2008 09:33:11 +0300

> I've made all the changes Yaakov suggested; but, when I run it through xml2rfc I get

Dave

You don't have to provide the version number
the tool will find the most recent version.

Just put something like
<!ENTITY I-D.ietf-ntp-ntpv4-proto SYSTEM "http://xml.resource.org/public/rfc/bibxml3/reference.I-D.ietf-ntp-ntpv4-proto.xml">
at the top and everything should work out fine.

Y(J)S

---

From: "Odonoghue, Karen F CIV NSWCDD, W13" <[email-masked]>
Date: Thu, 31 Jul 2008 09:39:08 -0500

Folks,

This is a gentle reminder that the autokey WG Last Call ends tomorrow.
Please 
post comments and an endorsement for the progression of this document
asap.

Regards,
Karen

-----Original Message-----
From: Brian Haberman [mailto:[email-masked]] 
Sent: Wednesday, July 16, 2008 8:44
To: NTP Working Group
Cc: Odonoghue, Karen F CIV NSWCDD, W13
Subject: NTP WG Last Call:draft-ietf-ntp-autokey-03.txt

All,
      This message starts a 2-week NTP Working Group Last Call on
advancing:

Regards,
Brian & Karen
NTP co-chairs

---

From: "David L. Mills" <[email-masked]>
Date: Thu, 31 Jul 2008 17:46:29 +0000

Karen,

I have updated the XML source with all comments received on the NTP 
project page 
http://www.eecis.udel.edu/~mills/draft-ietf-ntp-autokey-05.xml. These 
were very minor typos and XML twerps. I have verified it is there, but 
am unable to convert to text due some wrinkle in xml2rfc. Brian tells me 
not to worry about that.

Dave