Subject: [ntpwg] Question for you dave... http://tools.ietf.org/html/draft-ietf-ntp-autokey-06

From: Todd Glassey <[email-masked]>
Date: Sun, 20 Sep 2009 15:25:06 -0700

In regard to this I-D, its according to the filing obsoletes the RFC1305 
document which doesnt seem possible since it is not a RFC, and thoughts?

Todd
_______________________________________________
ntpwg mailing list
[email-masked]
https://lists.ntp.org/mailman/listinfo/ntpwg

---

From: Danny Mayer <[email-masked]>
Date: Sun, 20 Sep 2009 21:17:03 -0400

> document which doesnt seem possible since it is not a RFC, and thoughts?

Obsoleting an RFC can only happen when the draft becomes an RFC. When
issuing a draft you need to state any RFC that will be obsoleted by the
adoption of the draft. That has nothing to do with Dave, it's standard
IETF process.

Danny

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: Todd Glassey <[email-masked]>
Date: Sun, 20 Sep 2009 18:29:35 -0700

> adoption of the draft. That has nothing to do with Dave, it's standard
Danny my concern was that this document is filed for informational purposes and I am getting underwriting for NTP and the bonding house wants that in place.  So I want to make sure NTPv4 RFC happens as soon as possible since its already in use. 

Todd

> Danny
>
>   
> ------------------------------------------------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com 
> Version: 8.5.409 / Virus Database: 270.13.110/2385 - Release Date: 09/20/09 17:51:00
>
>

---

From: Danny Mayer <[email-masked]>
Date: Sun, 20 Sep 2009 23:53:43 -0400

Todd Glassey wrote:
> Danny Mayer wrote:
>> Todd Glassey wrote:
>>  
>>> In regard to this I-D, its according to the filing obsoletes the
>>> RFC1305 document which doesnt seem possible since it is not a RFC,
>>> and thoughts?
>>>
>>> Todd
>>>     
>>
> Danny my concern was that this document is filed for informational
> purposes and I am getting underwriting for NTP and the bonding house
> wants that in place.  So I want to make sure NTPv4 RFC happens as soon
> as possible since its already in use.
> Todd

The draft is informational so the bonding house will probably be
disappointed that it's not a proposed standard. That of course has
nothing to do with the NTPv4 draft RFC.

Danny

---

From: "Greg Dowd" <[email-masked]>
Date: Sun, 20 Sep 2009 20:49:54 -0700

Actually, I don't think the autokey draft will obsolete 1305 in any
event.  It's not NTPv4.  The NTPv4 protocol draft can obsolete 1305 but
you are citing the autokey draft.  It is an optional security protocol
for use with NTPv4.  It is also only informational so you can use it as
you wish.

-----Original Message-----
From: ntpwg-bounces+gdowd=[email-masked]
[mailto:ntpwg-bounces+gdowd=[email-masked]] On Behalf Of
Todd Glassey
Sent: Sunday, September 20, 2009 6:30 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [ntpwg] Autokey

>> In regard to this I-D, its according to the filing obsoletes the
RFC1305 

Todd

---

From: Todd Glassey <[email-masked]>
Date: Mon, 21 Sep 2009 07:34:09 -0700

Greg Dowd wrote:
> event.  
I totally agree with you - which is why I brought it up. The filing of 
the document and its header are wrong so to fix it I propose it be 
refiled as a Standards Track document rather than a Informational one.

> It's not NTPv4. 
yep.
> The NTPv4 protocol draft can obsolete 1305 but
> you are citing the autokey draft.  
Yes - but what I was doing was 'reading the posted header for the 
AutoKEY extension's Draft' which right at the top of it says "will 
obsolete 1305( when approved)". See for yourself -

http://www.ietf.org/id/draft-ietf-ntp-autokey-06.txt

> It is an optional security protocol
> for use with NTPv4. 
Right -  NTPv4 (as far as the draft is concerned doesnt exist) so this 
is really all catty-wumpus
>  It is also only informational so you can use it as
> you wish.
>   
Thats the point I was making Greg - its an Informational in nature and 
not a Standards Track Filing. This document is more likely a USE MODEL 
TEMPLATE for AutoKEY enhanced NTP so its in the WG's main-line work 
product AFAIK and not informational in nature. So lets fix this!

Todd
>>> document which doesnt seem possible since it is not a RFC, and
>>>       
> thoughts?
>   
>>> Todd
>>>     
>>>       
>> issuing a draft you need to state any RFC that will be obsoleted by
>>     
> the
>   
>> Version: 8.5.409 / Virus Database: 270.13.110/2385 - Release Date:
>>     
> 09/20/09 17:51:00
>   
>>   
>>     
>

---

From: David Mills <[email-masked]>
Date: Mon, 21 Sep 2009 21:13:06 +0000

Todd,

That claim to obsolete is a mistake. The document obsoletes nothing.

Dave

---

From: David Mills <[email-masked]>
Date: Mon, 21 Sep 2009 21:23:25 +0000

Danny,

I have had several jousts with the IESG reviewers, one of which asked me 
why the document was not on the standards track, especially since all 
but one reference to the reference implementation was removed by 
request. I told them my personal preference was that it be on the 
standards track, especially since there apparently is now another 
implementation. The opinion of the WG as a group might be different, in 
which case the IESG should be so advised.

Dave

---

From: Todd Glassey <[email-masked]>
Date: Mon, 21 Sep 2009 15:12:01 -0700

> That claim to obsolete is a mistake. The document obsoletes nothing.
I know David but the filing of it is the issue. So can we correct it?

todd
> Version: 8.5.409 / Virus Database: 270.13.111/2386 - Release Date: 09/21/09 05:51:00
>
>

---

From: David Mills <[email-masked]>
Date: Mon, 21 Sep 2009 23:48:58 +0000

Todd,

That's up to the editor.

Dave

Todd Glassey wrote:

>> Checked by AVG - www.avg.com Version: 8.5.409 / Virus Database: 
>> 270.13.111/2386 - Release Date: 09/21/09 05:51:00
>>
>>   
>
>