Subject: [ntpwg] RFC 5905, page 102, adjusting s.poll

From: "Ulrich Windl" <[email-masked]>
Date: Tue, 07 Sep 2010 08:46:39 +0200

Hello,

I was wondering why the adjustment of s.poll is not symmetric (page 102, "c.count -= s.poll << 1"). NTP has the tendency to prefer increasing the polling interval to decreasing it. Watching the performance I feel that NTP should decrease the polling interval earlier. In many cases NTP had to decrease the polling interval by several steps, when I think an earlier decrease (or a later increase) would have been better. See the attached graphs (which should be self-explaining enough, Reference clock is a Meinberg PFZ-535 (DFC-77 with decoding of the pseudo-phase noise).

Regards,
Ulrich

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "David L. Mills" <[email-masked]>
Date: Wed, 08 Sep 2010 15:01:57 +0000

Ulrich,

As you can see, the intent in the poll-adjust algorithm is to increase 
the interval with caution, but decrease it aggressively. That has been 
the design even in NTPv3. See Chapter 6 in my book. The intent is not to 
use the algorithm for reference clocks, but to use a fixed interval. The 
only exception is the modem clock driver, which normally increases the 
poll interval in steps to 36 h, but quickly yanks it back if somebody 
opens my office window in the dead of winter.

These issues are best studied in the context of the NTP simulator with 
artificial phase and frequency noise.

Dave

Ulrich Windl wrote:

>------------------------------------------------------------------------
>

---

From: "Ulrich Windl" <[email-masked]>
Date: Thu, 09 Sep 2010 09:01:04 +0200

>>> "David L. Mills" <[email-masked]> schrieb am 08.09.2010 um 17:01 in Nachricht
> the design even in NTPv3. See Chapter 6 in my book. The intent is not to 

Dave,

accept my apologies: I had been mixing the direction of the shift. You are right, I was wrong (regarding page 102).

Regards,
Ulrich

> >I was wondering why the adjustment of s.poll is not symmetric (page 102, 
> "c.count -= s.poll << 1"). NTP has the tendency to prefer increasing the polling 
> interval to decreasing it. Watching the performance I feel that NTP should 
> decrease the polling interval earlier. In many cases NTP had to decrease the 
> polling interval by several steps, when I think an earlier decrease (or a 
> later increase) would have been better. See the attached graphs (which should 
> be self-explaining enough, Reference clock is a Meinberg PFZ-535 (DFC-77 with 
> decoding of the pseudo-phase noise).
> >
> >Regards,
> >Ulrich
> >
> >  
> >