Subject: [ntpwg] RFC 5905: Suggested correction, page 62, "SQUARE(x)"

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 06 Sep 2010 10:11:25 +0200

Hi,

a short notice: On page 62 of RFC 5905 (NTPv4) you read:
#define SQUARE(x) (x * x)

By laws of K&R, the right side should read "((x) * (x))" for reliability.

Regards,
Ulrich

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "David L. Mills" <[email-masked]>
Date: Wed, 08 Sep 2010 14:48:44 +0000

Ulrich,

As it clearly states, the pseudo-code is not C and therefore K&R is 
completely irrelevant.

Dave