Subject: Re: [ntpwg] [Technical Errata Reported] RFC5905 (4366)

From: Brian Haberman <[email-masked]>
Date: Wed, 13 May 2015 08:44:50 -0400

All,
     I am looking for feedback on this erratum...

On 5/13/15 7:55 AM, RFC Errata System wrote:
> The following errata report has been submitted for RFC5905,
> "Network Time Protocol Version 4: Protocol and Algorithms Specification".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=5905&eid=4366
> 
> --------------------------------------
> Type: Technical
> Reported by: Vyacheslav <[email-masked]>
> 
> Section: 11.2.1
> 
> Original Text
> -------------
> 5.  Is d = f and l < u?  If yes, then follow step 5A; else, follow
>    step 5B.
> 

Based on a *quick* read of the pseudo code in A.5.5.1, I think the above
corresponds to this code snippet:

                /*
                 * If the number of midpoints is greater than the number
                 * of allowed falsetickers, the intersection contains at
                 * least one truechimer with no midpoint.  If so,
                 * increment the number of allowed falsetickers and go
                 * around again.  If not and the intersection is
                 * non-empty, declare success.
                 */
                if (found > allow)
                        continue;

                if (high > low)
                        break;

> 
> Corrected Text
> --------------
> 5.  Is d <= f and l < u?  If yes, then follow step 5A; else, follow
>    step 5B.

If I got the code snippet right, I think the erratum is wrong.  Other
views from the WG?

Regards,
Brian

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: RFC Errata System <[email-masked]>
Date: Wed, 13 May 2015 04:55:55 -0700 (PDT)

Section: 11.2.1

Original Text
-------------

Corrected Text
--------------

Notes
-----
Original text doesn't correspond to sample implementation at A.5.5.1. And, I suppose, described algorithm may throw out reasonable set of measures.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5905 (draft-ietf-ntp-ntpv4-proto-13)
--------------------------------------
Title               : Network Time Protocol Version 4: Protocol and Algorithms Specification
Publication Date    : June 2010
Author(s)           : D. Mills, J. Martin, Ed., J. Burbank, W. Kasch
Category            : PROPOSED STANDARD
Source              : Network Time Protocol
Area                : Internet
Stream              : IETF
Verifying Party     : IESG