Subject: Re: [ntpwg] Benoit Claise's No Record on draft-ietf-ntp-checksum-trailer-05: (with COMMENT)

From: Tal Mizrahi <[email-masked]>
Date: Wed, 2 Mar 2016 13:08:28 +0000

Hi Benoit,

Thanks for the comments.

>     As described in Section 1, an intermediate entity that updates the
>     timestamp in the NTP packet can use the Checksum Complement in
>     order to maintain the correctness of the UDP checksum field.
>
>I'm wondering about the "can use" here.
>What is the alternative? Correct the UDP checksum field, which is
>incompatible with your use case (hardware timestamping)?

Right. The alternative is to correct the UDP checksum field. While this is significantly more difficult to implement, it is not impossible, and therefore some vendors may choose this approach.

>Isn't more like this?
>     As described in Section 1, an intermediate entity that updates the
>     timestamp with hardware timestamping in the NTP packet MUST use
>     the Checksum Complement in order to maintain the correctness of the
>
>     UDP checksum field.

Since it is possible to perform hardware timestamping without the Checksum Complement (although more difficult to implement), it would be best if we didn't mandate the use of the Checksum Complement.

I would suggest to change the current phrasing from a 'can' (which may be a bit unclear) to a 'MAY'.

Regards,
Tal.

>-----Original Message-----
>From: Benoit Claise [mailto:[email-masked]]
>Sent: Tuesday, March 01, 2016 5:54 PM
>To: The IESG
>Cc: [email-masked]; Karen O'Donoghue; ntp-
>[email-masked]; [email-masked]; [email-masked]
>Subject: Benoit Claise's No Record on draft-ietf-ntp-checksum-trailer-05:
>(with COMMENT)
>
>Benoit Claise has entered the following ballot position for
>draft-ietf-ntp-checksum-trailer-05: No Record
>
>When responding, please keep the subject line intact and reply to all email
>addresses included in the To and CC lines. (Feel free to cut this introductory
>paragraph, however.)
>
>
>Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
>for more information about IESG DISCUSS and COMMENT positions.
>
>
>The document, along with other ballot positions, can be found here:
>https://datatracker.ietf.org/doc/draft-ietf-ntp-checksum-trailer/
>
>
>
>----------------------------------------------------------------------
>COMMENT:
>----------------------------------------------------------------------
>
>Question:
>
>     As described in Section 1, an intermediate entity that updates the
>     timestamp in the NTP packet can use the Checksum Complement in
>     order to maintain the correctness of the UDP checksum field.
>
>I'm wondering about the "can use" here.
>What is the alternative? Correct the UDP checksum field, which is
>incompatible with your use case (hardware timestamping)?
>Or use the zero checksum (not possible for IPv6)?
>
>Isn't more like this?
>     As described in Section 1, an intermediate entity that updates the
>     timestamp with hardware timestamping in the NTP packet MUST use
>     the Checksum Complement in order to maintain the correctness of the
>
>     UDP checksum field.
>
>And, for the record, I agree with Barry's questions.
>

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Benoit Claise" <[email-masked]>
Date: Tue, 01 Mar 2016 07:54:24 -0800

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Question:

Isn't more like this? 

     UDP checksum field.

---

From: Benoit Claise <[email-masked]>
Date: Wed, 2 Mar 2016 14:44:25 +0100

Thanks Tal,

I believe that a few words about the trade-offs of the different 
solutions would be beneficial to the readers.

Regards, Benoit