Subject: [ntpwg] Merge of NTS documents with Franke-NTS - Logistics

From: [email-masked]
Date: Wed, 19 Oct 2016 10:54:11 +0200

Hello Daniel,

we propose to do the merge of the NTS documents on a git repository hosted 
by PTB via GitLab. 
In this repository, I would include (XML files of) the current draft of 
the merge between our NTS-4-NTP draft and your Franke-NTS proposal as well 
as the current version of our "generic" NTS document.
Author's access would be given to Dieter, you and myself (possibly Stephen 
Röttger as well, if he is interested).
Would that arrangement be alright with you?

Best regards,
Kristof

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Daniel Franke <[email-masked]>
Date: Wed, 19 Oct 2016 12:00:25 -0400

Sounds good to me.

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Oct 2016 10:40:18 +0000

Please consider using github and the I-D/RFC markdown module stuff written by Martin Thomson.

For example, see https://github.com/ietf-wg-acme/acme, among others.  Many IETF groups are using github and markdown

--  
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: [email-masked] Twitter: RichSalz

---

From: Kyle Rose <[email-masked]>
Date: Thu, 20 Oct 2016 08:20:19 -0400

I second Rich's recommendation.

On Oct 20, 2016 6:42 AM, "Salz, Rich" <[email-masked]> wrote:

> For example, see https://github.com/ietf-wg-acme/acme, among others.
> Many IETF groups are using github and markdown
>
> --

---

From: [email-masked]
Date: Thu, 20 Oct 2016 16:29:32 +0200

Weather gitlab or github doesn't really matter to us. However we would 
prefer to edit the xml-source of the document instead of learning the 
Markdown syntax. Daniel, would you prefer to use the github account?

Dieter

"ntpwg" <ntpwg-bounces+dieter.sibold=[email-masked]> schrieb am 
20.10.2016 12:40:18:

> Von: "Salz, Rich" <[email-masked]>
> An: Daniel Franke <[email-masked]>, "[email-masked]" 
> <[email-masked]>
> Kopie: "[email-masked]" <[email-masked]>, "Franke, Daniel"
> <[email-masked]>
> Datum: 20.10.2016 12:42
> Betreff: Re: [ntpwg] Merge of NTS documents with Franke-NTS - Logistics
> Gesendet von: "ntpwg" <ntpwg-bounces+dieter.sibold=[email-masked]>
>

---

From: Daniel Franke <[email-masked]>
Date: Thu, 20 Oct 2016 10:35:34 -0400

> Markdown syntax. Daniel, would you prefer to use the github account?

I would slightly prefer GitHub but have no strong feelings on the
matter. I strongly second your preference for XML over Markdown.
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Oct 2016 14:36:41 +0000

You can still use the github infrastructure, just skip the .md->.xml step :)

---

From: Daniel Franke <[email-masked]>
Date: Thu, 20 Oct 2016 10:41:19 -0400

On 10/20/16, Salz, Rich <[email-masked]> wrote:
> You can still use the github infrastructure, just skip the .md->.xml step

Did you see the trick I'm using with link in the README.md at
https://github.com/dfoxfranke/nts? It causes xml2rfc.ietf.org to fetch
and render the current HEAD of the git repo. Handy.
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Oct 2016 14:49:38 +0000

> https://github.com/dfoxfranke/nts? It causes xml2rfc.ietf.org to fetch and
> render the current HEAD of the git repo. Handy.

Yeah.  

Martin's submodule has hooks to auto-gen the "github pages" version every time the editor's doc chanes.
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: [email-masked]
Date: Thu, 20 Oct 2016 16:58:56 +0200

No, I didn't noticed it. But I like it. 
If this is okay with Daniel, I suggest that I will ask Kristof that he 
sends the merged document to Daniel so that he can add them to his github 
repro (using the same trick :-). 

20.10.2016 16:41:19:

> Von: Daniel Franke <[email-masked]>
> An: "Salz, Rich" <[email-masked]>
> Kopie: "[email-masked]" <[email-masked]>
> Datum: 20.10.2016 16:42