Subject: [Ntp] Port randomization (draft-ietf-ntp-port-randomization-04)

From: Fernando Gont <[email-masked]>
Date: Wed, 15 Jul 2020 04:29:27 -0300

Folks,

Based on recent feedback and list discussion, we plan to update this 
text from Section 4 of draft-ietf-ntp-port-randomization-04:

---- OLD ----
       The client SHOULD wait for
       response packets from the server for at least 3 seconds before
       closing the UDP socket/port, even if a successful response is
       received.  This will prevent duplicate or delayed server packets
       from eliciting ICMP port unreachable error messages at the client.
---- OLD ----

to:

---- NEW ----
	After receiving a valid response, the client MAY wait for
	more responses from the server for a specific period of time
         (e.g. 3 seconds) before closing the UDP socket/port, to prevent
	duplicate or delayed server packets from eliciting ICMP port
	unreachable error messages at the client.
---- NEW ----

Please do let us know if you have any further comments. Otherwise we'll 
update the draft as indicated.

Thanks!

Cheers,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: "Ulrich Windl" <[email-masked]>
Date: Wed, 15 Jul 2020 10:17:23 +0200

>>> Fernando Gont <[email-masked]> schrieb am 15.07.2020 um 09:29 in
Nachricht <[email-masked]>:
> text from Section 4 of draft‑ietf‑ntp‑port‑randomization‑04:
> 
> ‑‑‑‑ OLD ‑‑‑‑
> ‑‑‑‑ OLD ‑‑‑‑
> ‑‑‑‑ NEW ‑‑‑‑
> ‑‑‑‑ NEW ‑‑‑‑

Actually I feel changing the ordering (giving reason first, then measure)
would make the sentence easier "to digest":
"To prevent  ICMP port unreachable error messages at the client caused by
duplicate or delayed server packets ... the client MAY wait ..."

> 
> Thanks!
> 
> Cheers,
> ‑‑ 
> Fernando Gont
> SI6 Networks
> e‑mail: [email-masked] 
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp