Subject: [Ntp] Should NTPv5 have QUIC bindings?

From: "Salz, Rich" <[email-masked]>
Date: Thu, 21 Oct 2021 15:45:43 +0000

Curious to hear what people think.

---

From: James <[email-masked]>
Date: Thu, 21 Oct 2021 17:50:03 +0200

I have considered looking at things like reusing elements of the timestamp draft [1]  (really intended for measuring latency and not time sync) and seeing if that along with some other signalling could be useful. However, connection keep alive, congestion control and other details would have to be considered. I’d be happy to help explore this further but for the purposes of synchronisation it may be education, but overall moot.

- J

1: https://datatracker.ietf.org/doc/draft-huitema-quic-ts/

> On 21 Oct 2021, at 17:45, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> _______________________________________________
> ntp mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ntp <https://www.ietf.org/mailman/listinfo/ntp>

---

From: Danny Mayer <[email-masked]>
Date: Thu, 21 Oct 2021 12:14:45 -0400

Can someone explain what QUIC is and what it's used for rather than 
having to go through a draft document?

Danny

On 10/21/21 11:50 AM, James wrote:
> I have considered looking at things like reusing elements of the 
> timestamp draft [1]  (really intended for measuring latency and not 
> time sync) and seeing if that along with some other signalling could 
> be useful. However, connection keep alive, congestion control and 
> other details would have to be considered. I’d be happy to help 
> explore this further but for the purposes of synchronisation it may be 
> education, but overall moot.
>
> - J
>
>> On 21 Oct 2021, at 17:45, Salz, Rich 
>> <rsalz=[email-masked]> wrote:
>>
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ntp
>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 21 Oct 2021 16:20:53 +0000

*   Can someone explain what QUIC is and what it's used for rather than having to go through a draft document?

Quoting RFC 9000 (not a draft any more):

                This document defines the core of the QUIC transport protocol. QUIC provides applications with flow-controlled streams for structured communication, low-latency connection establishment, and network path migration. QUIC includes security measures that ensure confidentiality, integrity, and availability in a range of deployment circumstances. Accompanying documents describe the integration of TLS for key negotiation, loss detection, and an exemplary congestion control algorithm.