Subject: [Ntp] NTPV5 requirements vs draft RFC

From: Doug Arnold <[email-masked]>
Date: Fri, 25 Feb 2022 23:32:41 +0000

I looked at the compatibility between the current ntpv5 draft requirements and draft rfc.  My comments are collected in the attached pdf.

--- Doug

---

From: James <[email-masked]>
Date: Mon, 28 Feb 2022 17:24:02 +0100

Doug,
Thank you for doing this analysis. I haven't yet read through Miroslav's latest version so can't comment on the specifics just yet, but for my own ease I have copied your data into a spreadsheet [1] with some minor editorialisation. At first glance it only appears a few things are not met and a few that are differences in normative language.

- J

1: https://docs.google.com/spreadsheets/d/1Mutawk0XYy_0ab8Ih0yjUCGBim6T2qmsU1nCa4n0rZY/edit

> On 26 Feb 2022, at 00:32, Doug Arnold <doug.arnold=[email-masked]> wrote:
> 
> <NTPv5 req vs draft rfc.pdf>_______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp

---

From: Doug Arnold <[email-masked]>
Date: Mon, 28 Feb 2022 19:03:05 +0000

James,

I agree with your overall assessment.

I have a couple of questions about the requirements draft:
There are some statements in the requirements draft that look like recommendations but use “should” rather than “SHOULD”.  Is there a criteria to decide which to use?

Is there a reference on deployment issues with previous new versions of ntp, that you can site, or can you add a brief summary to the requirements?

Doug

From: James <[email-masked]>
Date: Monday, February 28, 2022 at 11:24 AM
To: Doug Arnold <[email-masked]>
Cc: NTP WG <[email-masked]>
Subject: Re: [Ntp] NTPV5 requirements vs draft RFC
Doug,
Thank you for doing this analysis. I haven't yet read through Miroslav's latest version so can't comment on the specifics just yet, but for my own ease I have copied your data into a spreadsheet [1] with some minor editorialisation. At first glance it only appears a few things are not met and a few that are differences in normative language.

- J