Subject: [Ntp] FW: Expiration impending: <draft-ietf-ntp-update-registries-03.txt>

From: "Salz, Rich" <[email-masked]>
Date: Mon, 18 Apr 2022 13:47:51 +0000

Can we move this forward now?  WGLC was Feb 22.  One person said they were busy and would do a full write-up soon, but that was also during February and we have not heard from them (in spite of multiple pings).

On 4/17/22, 3:03 AM, "IETF Secretariat" <[email-masked]> wrote:

    The following draft will expire soon:

    Name:     draft-ietf-ntp-update-registries
    Title:    Updating the NTP Registries
    State:    I-D Exists
    Expires:  2022-04-18 (in 23 hours, 56 minutes)

---

From: Kyle Rose <[email-masked]>
Date: Mon, 18 Apr 2022 10:02:18 -0400

On Mon, Apr 18, 2022 at 9:48 AM Salz, Rich <rsalz=
[email-masked]> wrote:

> Can we move this forward now?  WGLC was Feb 22.  One person said they were
> busy and would do a full write-up soon, but that was also during February
> and we have not heard from them (in spite of multiple pings).
>

I took a quick look.

* Why isn't most of this document instead a series of errata against the
original documents, where inconsistencies exist?

* Can you change an IANA registration procedure in an informational
document? RFC 8126 says that any document type qualifies for (e.g.)
specification required or RFC required, but that refers to modifying the
content of the registry, not to modifying the registry's procedures, which
seems like it should require a standards track RFC.

Kyle

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 18 Apr 2022 14:07:43 +0000

*   I took a quick look.

Thanks.

  *   * Why isn't most of this document instead a series of errata against the original documents, where inconsistencies exist?

A couple of reasons.  First, a unified document updating the registries and providing history is useful; where would you put the historic information? Second,  do you repeat things in all of the affected RFC errata? Third, there is precedent for this kind of thing; TLS is doing it right now.

  *   * Can you change an IANA registration procedure in an informational document

Sigh. I can’t believe that nobody noticed this before you did.  Dang.  Yes, this must be standards track.  I sense a disturb##### another draft coming.

---

From: Daniel Franke <[email-masked]>
Date: Mon, 18 Apr 2022 10:28:21 -0400

On Mon, Apr 18, 2022 at 10:03 AM Kyle Rose <[email-masked]> wrote:

> * Why isn't most of this document instead a series of errata against the original documents, where inconsistencies exist?

Errata should be reserved for cases where the document fails to
reflect the authors' intent, not for cases where the intent was
regrettable. I can see the argument that the swapped autokey nibbles
fall into the former category, but I would argue not: Section 13 of
RFC 5906 accurately describes what IANA did (rather than what we wish
they'd done / wish we'd told them to do). So I don't see anything in
this document where an erratum seems more appropriate.

---

From: Kyle Rose <[email-masked]>
Date: Mon, 18 Apr 2022 10:30:52 -0400

> this document where an erratum seems more appropriate.

Makes sense. Thanks.

Kyle

---

From: Daniel Franke <[email-masked]>
Date: Mon, 18 Apr 2022 10:51:01 -0400

> Sigh. I can’t believe that nobody noticed this before you did.  Dang.  Yes, this must be standards track.  I sense a disturb##### another draft coming.

Before changing it to standards track I would recommend getting an
opinion from IANA about whether this is really necessary. I vaguely
recall having a conversation about this in Seoul where someone from
IANA (might have been Michelle Cotton?) told me differently. Anyway,
you should ask again and not rely on my memory.

This draft lists five RFCs that it purportedly updates. I think it
only actually updates 5905 (for the registry policy change) and 5906
(for the policy change and the nibble swap). Isn't it merely
recapitulating the other three?