Subject: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Wed, 28 Nov 2012 17:16:18 +0100

This email begins a two week poll to help the chairs judge if there is consensus  to adopt draft-bl-nvo3-dataplane-requirements-03.txt as an NVO3 working group draft.

Please respond to this email on the list with 'support' or 'do not support'.

Please also send any comments on the draft to the NVO3 list.

Coincidentally, we are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor, please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and contributor.

If you are on the NVO3 WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

This poll closes on Wednesday 12th December 2012.

Regards

Matthew and Benson

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Wed, 28 Nov 2012 17:23:34 +0100

As a co-author, I'm not aware of any relevant IPR.

Marc

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Wednesday, November 28, 2012 5:16 PM
To: [email-masked]
Subject: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Regards

Matthew and Benson

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Wed, 28 Nov 2012 18:05:57 +0000

Support.

From: <Bocci>, "Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 28, 2012 8:16 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Regards

Matthew and Benson

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Wed, 28 Nov 2012 19:07:54 +0100

support

From: "Larry Kreeger (kreeger)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 28 November 2012 19:05
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Support.

Regards

Matthew and Benson

---

From: Lucy yong <[email-masked]>
Date: Wed, 28 Nov 2012 23:54:36 +0000

I support the action, but have some comment and suggestions to this version.

*         There is no single word  about tenant system mobility. Suggest adding a section within section 3.9  to address tenant system mobility. For example,  it should point out that, although the data plane learning can be used to learn source MAC addresses as described in section 3.2.1, the mechanism may not meet the tenant system mobility requirements. In this case,  when a tenant system moves, some frames with the destination MAC as the tenant system are forwarded to the old associated NVE.  Other VM mobility and reachbility can be described as well.

*         Suggest to add a sub-section in section 3.3.2 to describe tunneling encapsulation. One requirement is that all the NVEs that are the member of a VNI MUST support a  tunneling encapsulation.  One option requirement is that all the NVEs that are the member of a VNI MAY support more than one tunneling encapsulation. In this case, an ingress NVE MUST use the egress NVE supported encapsulation to encapsulate the frame/packets before sending to the remote NVE.

*         Section 3.6 Hierarchical NVE.  The text is very weak and without any requirement on it. It is not clear which function that hub NVE need to perform and which spoke NVE need to perform. For example, should hub NVE perform the encapsulation or should spoke NVE do it?  Furthermore, the last sentence does not apply to here at all.  Suggest either removing the section or stating out clearly what are the requirements for Hierarchical NVE.

*         Section 3.2.1 states about using data plane learning and point out that multiple overlay tunnels may exist.  But it does not state out any requirement to load balance over multiple overlay tunnels. For example, if there are two overlay tunnels between two NVEs, one NVE learns MAC associated with one overlay tunnel, can the NVE use another overlay tunnel to send the fame with the MAC to remote NVE? Suggest adding related requirement in the section.

*         Section 3.2.2 starts with "L3 VNIs" and Section 3.2.1 starts with "an L2 VNI". is this intentional to illustrate the difference  between L2 overlay and L3 overlay or a typo?

*         Section 3.3, suggest use tenant payload. There is no definition of customer in this document.

*         In section 1.2, some team already defined in the framework document. Should not restate here.

I would like to see these to be addressed in next version.

Cheers,
Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Wednesday, November 28, 2012 10:16 AM
To: [email-masked]
Subject: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Regards

Matthew and Benson

---

From: <[email-masked]>
Date: Thu, 29 Nov 2012 09:22:30 +0000

I'm not aware of any IPR on draft-bl-nvo3-dataplane-requirements, and as 
a co-author would welcome adoption of the document by the working group.

-Thomas

Bocci, Matthew (Matthew) a écrit :
> This email begins a two week poll to help the chairs judge if there is 
> consensus  to adopt draft-bl-nvo3-dataplane-requirements-03.txt as an 
> NVO3 working group draft.
>
> Coincidentally, we are also polling for knowledge of any IPR that 
> applies to this draft, to ensure that IPR has been disclosed in 
> compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for 
> more details).
>
> If you are listed as a document author or contributor, please respond 
> to this email whether or not you are aware of any relevant IPR. The 
> draft will not be adopted until a response has been received from each 
> author and contributor.
>
> If you are on the NVO3 WG email list but are not listed as an author 
> or contributor, then please explicitly respond only if you are aware 
> of any IPR that has not yet been disclosed in conformance with IETF rules.
>
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Andreas Fischer <[email-masked]>
Date: Thu, 29 Nov 2012 14:43:28 +0100

Page 13, second paragraph: "This _is_ problem is attributable": 
superfluous 'is' (grammar nazi, I know ^^).

Apart from that: Support.

Regards,
Andreas Fischer

On 28.11.2012 17:16, Bocci, Matthew (Matthew) wrote:
> If you are listed as a document author or contributor, please respond to
> this email whether or not you are aware of any relevant IPR. The draft
> will not be adopted until a response has been received from each author
> and contributor.
>
> If you are on the NVO3 WG email list but are not listed as an author or
> contributor, then please explicitly respond only if you are aware of any
> IPR that has not yet been disclosed in conformance with IETF rules.
>

---

From: Florin Balus <[email-masked]>
Date: Thu, 29 Nov 2012 08:54:16 -0800

I'm not aware of any IPR on draft-bl-nvo3-dataplane-requirements. As a
co-author I also support the adoption of the draft as a WG document.

Florin

On Wed, Nov 28, 2012 at 8:16 AM, Bocci, Matthew (Matthew) <
[email-masked]> wrote:

> consensus  to adopt draft-bl-nvo3-dataplane-requirements-03.txt as an NVO3
> working group draft.
>
> Coincidentally, we are also polling for knowledge of any IPR that applies
> to this draft, to ensure that IPR has been disclosed in compliance with
> IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>

---

From: Eric Gray <[email-masked]>
Date: Fri, 30 Nov 2012 22:14:54 +0000

Support

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Wednesday, November 28, 2012 11:16 AM
To: [email-masked]
Subject: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Regards

Matthew and Benson

---

From: ง Ping <[email-masked]>
Date: Fri, 30 Nov 2012 14:53:33 -0800

support
Ping Petchged

From: [email-masked]
To: [email-masked]; [email-masked]
Date: Fri, 30 Nov 2012 22:14:54 +0000
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Support

From: [email-masked] [mailto:[email-masked]]
On Behalf Of Bocci, Matthew (Matthew)

To: [email-masked]

 

This email begins a two week poll to help the chairs judge if there is consensus  to adopt draft-bl-nvo3-dataplane-requirements-03.txt as an NVO3 working group
 draft.

 

 

Coincidentally, we are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules
 (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor, please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted
 until a response has been received from each author and contributor.

If you are on the NVO3 WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has
 not yet been disclosed in conformance with IETF rules.

 

Regards

Matthew and Benson

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 30 Nov 2012 14:58:53 -0800

I have read the document and support its adoption as WG doc.

-sam