Subject: [nvo3] comment on the draft-ietf-nvo3-framework-01

From: Lucy yong <[email-masked]>
Date: Wed, 14 Nov 2012 23:00:01 +0000

Hi Marc and other authors,

Here are some comments for this version.

1)  Comment: current document does not mention VM mobility or tenant mobility at all. To me, that the network virtualization overlay support flexible VM placement and mobility is the key requirement for this work. This requirement may lead some additional functions (see my suggestion in #11).

2)      Tenant System Definition:
       Tenant System: A physical or virtual system that can play the role
       of a host, or a forwarding element such as a router, switch,
       firewall, etc. It belongs to a single tenant and connects to one or
       more VNs of that tenant.

Should we state that: A physical or virtual system that can play the role of a host, or network function as  firewall, gateway, nat, etc. I don't know why tenant system play the role of router and switch. We had the tenant end system before. do we still have that assumption under this definition? If yes, how can it play router and switch role?

3)      Figure 2 in Section  1.4 illustrate one example of a tenant networking view. Suggest replacing the last paragraph in section 1.4 with follows:
       For a multi-tenant DC, a virtualized version of this type of service
       connectivity needs to be provided for each tenant by the Network
       Virtualization solution. Furthermore individual tenant networking views
       may be different. For example, tenant 2 may have a pure L2 networking
       view and tenant 3 may have a only L3 networking view.

4)  Replace the text:
       The NVE implements network virtualization functions that allow for
       L2 and/or L3 tenant separation and for hiding tenant addressing
       information (MAC and IP addresses), tenant-related control plane
       activity and service contexts from the Routed Backbone nodes.

   with:
       The NVE implements network virtualization functions that allow for
       L2 and/or L3 tenant separation and for hiding tenant addressing
       information (MAC and IP addresses), tenant-related control plane
       activity, service contexts from the Routed Backbone nodes, and
       tenant system mobility.

5)  Figure 4 is a generic reference model for NVE. Why we need the following text:
       In the latter case we say that the End Device NVE component acts as the NVE
       Spoke, and ToRs act as NVE hubs. Tenant Systems will interface with
       VNIs maintained on the NVE spokes, and VNIs maintained on the NVE
       spokes will interface with VNIs maintained on the NVE hubs.
This leads to a specific solution. suggest removing this text.

6)   Text:

       L2 NVE implements Ethernet LAN emulation (ELAN), an Ethernet based
       multipoint service where the Tenant Systems appear to be
       interconnected by a LAN environment over a set of L3 tunnels. It
       provides per tenant virtual switching instance with MAC addressing

       isolation and L3 tunnel encapsulation across the core.

EVPN is not equivalent to ELAN. Do we want to state that L2 NVE implements EVPN or ELAN? Two are stated in terminology section.

7)  Both figure 4 and 5 show the Tenant Service IF, what does that mean? There is no text to describe it. Is it a functional component or not? Please clarify.

8)  Text in section 3.1.1:
       The VAPs can be physical ports or virtual ports identified through
       logical interface identifiers (VLANs, internal VSwitch Interface ID
       leading to a VM).
   IMO: The description does not cover the case in section 2.3.2

9)  In section 3.1.4, text:
       Different IP tunneling options (GRE/L2TP/IPSec) and tunneling
       options (BGP VPN, PW, VPLS) are available for both Ethernet and IP
       formats.
      it is not right to list BGP VPN and VPLS as a tunneling option. They both may be the solution for NVo3.

10)         Suggest to change 3.1.5 title to control plane function. The component seems an entity to me. But what you describe in this section are the control plane functions.

11)         In Section 3.1.5, suggest adding the following section as 3.1.5.5.

In order to support Tenant system mobility, it is possible to have a control plane between an End Device and an NVE when tenant systems and an NVE are separated remotely. Such control plane function can facilitate the information exchange between an end device and NVE regarding to tenant system mobility.

Editing changes:

Replace "Layer3" with "L3" to make consistent in the doc.

Replace text:
         - locally, by being co-located i.e. resident in the same device
With:
         - locally, by being co-located i.e. resident in the same end device

Replace text:
       External connectivity is handled by to or more nvo3 gateways.
With
       External connectivity is handled by one or more nvo3 gateways.

Replace text:
       The intent of this section is to highlight specific issues that
       proposed overlay solutions need to address.
With:
       The intent of this section is to highlight specific issues that
       the overlay solutions need to address.

Regards & Cheers,
Lucy

---

From: Lucy yong <[email-masked]>
Date: Thu, 15 Nov 2012 16:10:22 +0000

One correction in my previous comments (see below). In #1 comment, I mean "tenant system mobility",  not "tenant mobility". Tenant system is the team defined in the framework.
Lucy

From: Lucy yong
Sent: Wednesday, November 14, 2012 5:00 PM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: comment on the draft-ietf-nvo3-framework-01
Importance: High

4)  Replace the text:

   with:

6)   Text:

Editing changes:

Replace text:

Replace text:

Replace text:

Regards & Cheers,
Lucy