Subject: Re: [nvo3] WG Last Call for draft-ietf-nvo3-overlay-problem-statement-02

From: Linda Dunbar <[email-masked]>
Date: Fri, 1 Mar 2013 23:20:44 +0000

Thomas, et al,

This draft has done a very good job in describing the motivation for overlay and its potential control/data plane.

However, the draft hasn't described the issues introduced by overlay and large DC issues not solved by overlay. For example:

-        Multicast issues introduced by overlay:

o   IP Encapsulation by NVE (or virtual switches on server)  means that any layer 2 multicast  from or to VMs requires Layer 3 Multicast/broadcast support in the core.

o   Majority of  virtual switches  in server won't have attached VMs participating in any Multicast groups. Therefore, it may not be cost effective for them to support Layer 3 multicast protocol, e.g. PIM, etc.

o   For virtual switches that do have attached VMs participating in multicast, there are much more dynamic states due to VM moves.

o   The head end replication will require hypervisor virtual switches to keep up multicast member states,  which  can change frequently. Therefore, those NVEs, if required to support multicast,  have to do more than MPLS (MVPN) multicast supported by PE routers.

o

-        Bottleneck at gateway nodes:

o   The draft has emphasized greatly on the importance of tenant separation. That means two VMs under the same NVE, if they belong to two different virtual network instances, the communication between them have to go all the way to their default gateway.

o   Some end stations even have specific default gateway configured. That require all the inter VNI communication to go through their designated gateway nodes.

o   Many data centers have their FW/LB co- located with GW nodes. That means all the inter VNI communications have to hairpined to those GW nodes.

-        issues that are not solved by overlay:

o   The draft is for environment where VMs can move anywhere, which require the Gateway nodes to be aware of individual VM addresses and their corresponding egress NVEs.

o   Many large Data Centers have small number of gateway nodes interfacing with external network, e.g. 2/4/8/more. Very often, those external facing gateway nodes are the entrance and exit points for all virtual network instances.

o   Very often each of them can receive traffic for all virtual network instances hosted in the data center.

o   That means they all need to be aware of individual VMs and their corresponding egress NVEs in the data center. i.e. they may all need host routing. It is true that many routers can handle millions of routes, but the question is if it is necessary for data center gateway nodes to be those high capacity routers.

-
Therefore, I think that the NV03 problem statement draft should add a new section to describes issues introduced by overlay and issues not solved by overlay.

Linda Dunbar

---

From: Richard Bin liu <[email-masked]>
Date: Tue, 5 Mar 2013 03:09:22 +0800

Hi Marc,

I reviewed the version of the draft, and I found that it lacks feedback and
update on my comments which I had sent to you comments in detail.

Best.

Richard Bin Liu