Subject: [nvo3] draft-quinn-vxlan-gpe

From: Nischal Sheth <[email-masked]>
Date: Tue, 10 Dec 2013 00:20:29 +0000

Hi Authors,

A couple of comments/questions on the draft:

a) It would be useful to have the ability to specify that the forwarding context
for the inner payload is the same as that for the outer header i.e. the VNI is
a don't care.  This could be achieved by reserving a VNI value, say 0xFFFFFF
or 0, or by using an additional bit from the flags field.

b) The current version says that determining capabilities is out of scope. Are
you planning to allocate a Tunnel Type code point in the BGP encapsulation
extended community in later version or via a separate document?

Thanks,
Nischal

---

From: "Yves Hertoghs (yhertogh)" <[email-masked]>
Date: Fri, 13 Dec 2013 10:37:54 +0000

Adding the authors

Yves

On 10/12/13 01:20, "Nischal Sheth" <[email-masked]> wrote:

>_______________________________________________
>nvo3 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Yves Hertoghs (yhertogh)" <[email-masked]>
Date: Fri, 13 Dec 2013 10:57:28 +0000

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 13 Dec 2013 10:06:55 -0800

In LISP, instance-ID 0 is kinda an unwritten rule used for this purpose.

Dino

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Fri, 13 Dec 2013 18:39:03 +0000

Hi Nischal,

> or 0, or by using an additional bit from the flags field.

If we look at a reserved VNI, I don't think it's a -gpe issue, rather a VXLAN draft update.

> extended community in later version or via a separate document?

I see some of my co-authors have documents in that space, I wasn't planning on a BGP draft.

Thanks
Paul

---

From: Nischal Sheth <[email-masked]>
Date: Fri, 13 Dec 2013 21:55:05 +0000

> If we look at a reserved VNI, I don't think it's a -gpe issue, rather a VXLAN draft update.

Fair enough.  I will redirect the question to the authors of the VXLAN draft.
BTW, the VXLAN draft says that the VNI is valid only when the I bit is set.
So, in theory, it might be possible to send packets with the I bit clear to get
the desired behavior.  Anyways, will check with the VXLAN authors.

> I see some of my co-authors have documents in that space, I wasn't planning on a BGP draft.

OK, understood.

Thanks,
Nischal