Subject: [nvo3] Request for comments: draft-jain-nvo3-overlay-oam-01.txt

From: Kanwar Singh <[email-masked]>
Date: Thu, 13 Feb 2014 12:05:06 -0800

Greetings All:

We have submitted the draft that proposes Generic Overlay OAM
framework and Datapath Failures detection mechanisms.

Please review the same update us with your valuable comments/feedback.

Warm Regards,

- Authors

A new version of I-D, draft-jain-nvo3-overlay-oam-01.txt

has been successfully submitted by Kanwar Singh and posted to the
IETF repository.

Name:           draft-jain-nvo3-overlay-oam
Revision:       01
Title:          Generic Overlay OAM and Datapath Failure Detection
Document date:  2014-02-12
Group:          Individual Submission
Pages:          44
URL:
http://www.ietf.org/internet-drafts/draft-jain-nvo3-overlay-oam-01.txt
Status:         https://datatracker.ietf.org/doc/draft-jain-nvo3-overlay-oam/
Htmlized:      http://tools.ietf.org/html/draft-jain-nvo3-overlay-oam-01
Diff:
http://www.ietf.org/rfcdiff?url2=draft-jain-nvo3-overlay-oam-01

Abstract:
   This proposal describes a mechanism that can be used to detect Data
   Path Failures of various overlay technologies as VXLAN, NVGRE,
   MPLSoGRE and MPLSoUDP and verifying/sanity of their Control and Data
   Plane for given Overlay Segment.  This document defines the following
   for each of the above Overlay Technologies:

   o  Encapsulation of OAM Packet, such that it has same Outer and
      Overlay Header as any End-System's data going over the same
      Overlay Segment.

   o  The mechanism to trace the Underlay that is exercised by any
      Overlay Segment.

   o  Procedure to verify presence of any given Tenant VM or End-System
      within a given Overlay Segment at Overlay End-Point.

   Even though the present proposal addresses Overlay OAM for VXLAN,
   NVGRE, MPLSoGRE and MPLSoUDP, but the procedures described are
   generic enough to accommodate OAM for any other Overlay Technology.

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 27 Feb 2014 17:05:43 +0000

Hi Jorge,
I understand the motivation. Please check E-VPN Operations, Administration and Maintenance  Requirements and Framework<http://datatracker.ietf.org/doc/draft-salam-l2vpn-evpn-oam-req-frmwk/?include_text=1> and NVO3 Operations, Administration, and Maintenance Requirements<http://datatracker.ietf.org/doc/draft-ashwood-nvo3-oam-requirements/?include_text=1> respectively from l2vpn and nvo3 WGs.

                Regards,
                                Greg

From: L2vpn [mailto:[email-masked]] On Behalf Of Rabadan, Jorge (Jorge)
Sent: Thursday, February 27, 2014 8:57 AM
To: Greg Mirsky; Kanwar Singh
Cc: [email-masked]; Pradeep Jain; Vinay Bannai; Ravi Shekhar
Subject: Re: Request for comments: draft-jain-nvo3-overlay-oam-01.txt

Hi Greg,

I understand that it might be too early for NVO3, however there are already overlay tunnel implementations deployed and running out there, and the need for OAM extensions for it is undeniable.
So personally I would like to see this being discussed sooner than later so that we don't end up with dozens of non-interoperable OAM tools.

I think that is why the authors want to discuss this in the L2VPN WG as well: it might be too early for NVO3 but there is a real need to discuss this now.

Thank you.
Jorge

From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 27, 2014 at 8:27 AM
To: Kanwar Singh <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Pradeep Jain <[email-masked]<mailto:[email-masked]>>, Vinay Bannai <[email-masked]<mailto:[email-masked]>>, Ravi Shekhar <[email-masked]<mailto:[email-masked]>>
Subject: Re: Request for comments: draft-jain-nvo3-overlay-oam-01.txt

Hi Kanwar, et. al,
the document is certainly interesting and very detailed. But I believe that it is rather too early to discuss applicability of particular OAM tools without agreed upon set of requirements for NVO3 OAM and comprehensive gap analysis.
Regards,
Greg

On Thu, Feb 27, 2014 at 7:46 AM, Kanwar Singh <[email-masked]<mailto:[email-masked]>> wrote:
Dear All,

We have submitted the below draft that proposes Generic OAM and Datapath Failure Detection Mechanism(s) for Overlay Networks.

We would like to solicit inputs from the members of L2VPN WG.

Please review the same and update us with your inputs/feedback.

Warm Regards

- Kanwar

A new version of I-D, draft-jain-nvo3-overlay-oam-01.txt has been successfully submitted by Kanwar Singh and posted to the

IETF repository.

Name:           draft-jain-nvo3-overlay-oam
Revision:       01
Title:          Generic Overlay OAM and Datapath Failure Detection
Document date:  2014-02-12
Group:          Individual Submission
Pages:          44
URL:            http://www.ietf.org/internet-drafts/draft-jain-nvo3-overlay-oam-01.txt
Status:         https://datatracker.ietf.org/doc/draft-jain-nvo3-overlay-oam/
Htmlized:      http://tools.ietf.org/html/draft-jain-nvo3-overlay-oam-01
Diff:              http://www.ietf.org/rfcdiff?url2=draft-jain-nvo3-overlay-oam-01

Abstract: