Subject: [nvo3] NVO3 Arch: proposed text on Multi-homing of NVEs

From: Thomas Narten <[email-masked]>
Date: Mon, 03 Feb 2014 15:00:14 -0500

Here is proposed text on multi-homing of NVEs

<section title="Multi-Homing of NVEs">
  <t>
    NVEs may be multi-homed. That is, an NVE may have more than one IP
    address associated with it on the underlay network.  Multihoming
    happens in two different scenarios. First, an NVE may have
    multiple interfaces connecting it to the underlay. Each of those
    interfaces will typically have a different IP address, resulting
    in a specific Tenant Address (on a specific VN) being reachable
    via more than one underlay IP address.  Second, a specific tenant
    system may be reachable through more than one NVE. In both cases,
    the mapping tables in NVEs need to support one-to-many mappings
    and enable a sending NVE to (at a minimum) be able to fail over
    from one IP address to another, should an NVE become unreachable
    via a specific underlay IP address.
  </t>
  <t>
    Multi-homing is needed to support important use cases.  First, a
    bare metal server may have multiple uplink connections to either
    the same or different NVEs. Having only a single physical path to
    an upstream NVE, or indeed, having all traffic flow through a
    single NVE would be considered unacceptable in highly-resilient
    deployment scenarios that seek to avoid single points of
    failure. Morever, in today's networks, the availability of
    multiple paths would require that they be useable in an
    active-active fashion (e.g., for load balancing).
  </t>
</section>

Comments?

Thomas

---

From: Zu Qiang <[email-masked]>
Date: Mon, 3 Feb 2014 21:06:23 +0000

Hello, Thomas
	Some clarifications questions below.

Have a nice day
Zu Qiang

>-----Original Message-----
>From: nvo3 [mailto:[email-masked]] On Behalf Of Thomas Narten
>Sent: Monday, February 03, 2014 3:00 PM
>To: [email-masked]
>Subject: [nvo3] NVO3 Arch: proposed text on Multi-homing of NVEs
>
>    interfaces will typically have a different IP address, 

[Zu Qiang] I guess MPLS shall not be excluded. 

resulting
>    via a specific underlay IP address.

[Zu Qiang] Is "Multi-Homing" for the purpose of failing over at NVE unreachable only? Do we allow the failing over can be triggered by other parameters, e.g. path priority? Or is it out of the scope? 

[Zu Qiang] " should an NVE become unreachable  via a specific underlay IP address.": Do you mean " should an TS become unreachable  via a specific NVE underlay IP address." or? 

>_______________________________________________
>nvo3 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Black, David" <[email-masked]>
Date: Mon, 3 Feb 2014 16:18:44 -0500

Hello Zu,

For the MPLS comment, could you propose revised text?

> [Zu Qiang] Is "Multi-Homing" for the purpose of failing over at NVE
> unreachable only? Do we allow the failing over can be triggered by other
> parameters, e.g. path priority? Or is it out of the scope?

Should be in scope, "(at a minimum)" was intended to allow this.  What
would make that clearer?

> [Zu Qiang] " should an NVE become unreachable  via a specific underlay IP
> address.": Do you mean " should an TS become unreachable  via a specific NVE
> underlay IP address." or?

No, this is about NVEs sending encapsulated traffic to other NVEs.  TSs cannot
be directly addressed via underlay network addresses, only NVEs can be.

Thanks,
--David

> From: nvo3 [mailto:[email-masked]] On Behalf Of Zu Qiang
> Sent: Monday, February 03, 2014 4:06 PM
> To: Thomas Narten; [email-masked]
> Subject: Re: [nvo3] NVO3 Arch: proposed text on Multi-homing of NVEs
> 
> Hello, Thomas
> [Zu Qiang] Is "Multi-Homing" for the purpose of failing over at NVE
> unreachable only? Do we allow the failing over can be triggered by other
> parameters, e.g. path priority? Or is it out of the scope?
> 
> [Zu Qiang] " should an NVE become unreachable  via a specific underlay IP
> address.": Do you mean " should an TS become unreachable  via a specific NVE
> underlay IP address." or?
> 
> >  </t>
> >  <t>

---

From: Zu Qiang <[email-masked]>
Date: Mon, 3 Feb 2014 21:25:53 +0000

Hello, David
Below.

Have a nice day
Zu Qiang

>From: Black, David [mailto:[email-masked]]
>Sent: Monday, February 03, 2014 4:19 PM
>To: Zu Qiang; [email-masked]
>Subject: RE: [nvo3] NVO3 Arch: proposed text on Multi-homing of NVEs
>
>Hello Zu,
>
[Zu Qiang] sure. I can send some text tomorrow.

>> unreachable only? Do we allow the failing over can be triggered by
>> other parameters, e.g. path priority? Or is it out of the scope?
>
>Should be in scope, "(at a minimum)" was intended to allow this.  What would
>make that clearer?
[Zu Qiang] I propose to remove the text " should an NVE become unreachable via a specific underlay IP address ", or add "e.g." before it.

>> address.": Do you mean " should an TS become unreachable  via a
>> specific NVE underlay IP address." or?
>

[Zu Qiang] There are two different scenarios in the text. In the first case, the NVE has more than one underlay addresses. In this case, any fail-over is transparent to the TS. In the second case, the TS has attached to more than one NVEs. Are we excluding the case where the NVE is reachable but one of the VAP is unreachable?

>> unreachable only? Do we allow the failing over can be triggered by
>> other parameters, e.g. path priority? Or is it out of the scope?
>>
>> address.": Do you mean " should an TS become unreachable  via a
>> specific NVE underlay IP address." or?
>>
>> >  </t>
>> >  <t>

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 4 Feb 2014 08:13:28 +0400

> On Feb 4, 2014, at 12:00 AM, Thomas Narten <[email-masked]> wrote:
> 
> Comments

I think the text is fine as written and putting MPLS into the mix will complicate and make the text much longer. 

Dino