Subject: Re: [nvo3] Questions on using LISP's signal free multicast for draft-ghanwani-nvo3-app-mcast-framework

From: Linda Dunbar <[email-masked]>
Date: Mon, 1 Sep 2014 09:55:06 +0000

Dino,

More questions inserted below:

From: Dino Farinacci [mailto:[email-masked]]
Sent: Sunday, August 31, 2014 11:50 AM

Well if the virtual switch supports LISP, then the app directly tells the xTR which groups it is joining.

[Linda] Many virtual switches today don’t even supports IGMP snooping.  Asking them to support LISP maybe even harder.

And if the LISP xTR is one-hop northbound from the virtual switch, you can bet the virtual switch does IGMP snooping.

 Or “Multicast server” can fake “IGMP query” to all the NVEs, which forwarded down to applications. The reply (IGMP report) can be automatically sent back to “multicast server” without NVE doing anything extra.

What do you think?

You want multicast routers to attach to the overlay. They don't send IGMP packets to each other.

[Linda] the IGMP messages are sent to “Applications” directly, who will send back “IGMP report” back to the node that sends the IGMP query.

IGMP is a host-to-router protocol and has been abused to be a host-to-switch protocol. Let's stop the abuse.  :-)

[Linda] The IGMP messages are still “host to router”  (host to multicast router). The NVEs don’t need to do anything extra for those IGMP messages.  Why you call it “abuse”?

Linda

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 1 Sep 2014 10:14:50 -0700

> [Linda] Many virtual switches today don’t even supports IGMP snooping.  Asking them to support LISP maybe even harder.  

Linda, we are taling about adding multicast capability in an overlay. If you add this functionality in a virtual switch, adding IGMP capability is a small price. 

> [Linda] the IGMP messages are sent to “Applications” directly, who will send back “IGMP report” back to the node that sends the IGMP query.

The kernel of the OS the application runs on.

> [Linda] The IGMP messages are still “host to router”  (host to multicast router). The NVEs don’t need to do anything extra for those IGMP messages.  Why you call it “abuse”?

Nevermind.

Dino