Subject: [nvo3] Comments on NVO3 data plane requirements for OAM

From: Haoweiguo <[email-masked]>
Date: Tue, 11 Nov 2014 08:34:29 +0000

Hi All,
I maybe not clearly said in today’s NVO3 meeting, pls allow me to reiterate the OAM data plane requirements on the mail list.

Currently NVO3 data plane encapsulation only includes one OAM flag, it is used for Ping/Trace similar applications. This kind of OAM application is initiated by operators for network connectivity verification, normally when network failure occurs. There is another OAM requirements of real time OAM or synthesizing OAM. It can be used for packet loss detection in real time. When ingress NVE receives traffic from local TS, it gets packet statistics, and mark(coloring) the OAM flag relying on local policy when it performs NVO3 encapsulation. When egress NVEs receives the traffic, it decapsulates NVO3 encapsulation, and gets packet statistics with the real time OAM flag marking. By comparing the packet number of ingress NVE and the sum of all egress NVEs, packet loss can be deduced. This method can be applicable for both unicast and multicast traffic. Local policy on ingress NVE is configured by operators or automatically acquired from centralized orchestration.

Thanks

weiguo

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 11 Nov 2014 12:07:16 -0800

Hi Weiguo,
marking groups of packets that belong to the particular flow to facilitate
measurement of some performance metric, whether loss or delay/delay
variation, may be viewed as one of passive performance measurement methods.
But such marking should not alter, at least not significantly alter,
treatment of data flow in the network. Because of that, I believe, OAM flag
should not be used for marking as that will force punting marked packets
from fast forwarding path to the control plane. But it might be good to
have a field in NVO3 header that may be used for marking and not affect
forwarding of packets if altered.

Regards,
Greg

On Tue, Nov 11, 2014 at 12:34 AM, Haoweiguo <[email-masked]> wrote:

>  Hi All,
>
> I maybe not clearly said in today’s NVO3 meeting, pls allow me to
> reiterate the OAM data plane requirements on the mail list.
>
> Currently NVO3 data plane encapsulation only includes one OAM flag, it is
> used for Ping/Trace similar applications. This kind of OAM application is
> initiated by operators for network connectivity verification, normally when
> network failure occurs. There is another OAM requirements of real time OAM
> or synthesizing OAM. It can be used for packet loss detection in real time.
> When ingress NVE receives traffic from local TS, it gets packet statistics,
> and mark(coloring) the OAM flag relying on local policy when it performs
> NVO3 encapsulation. When egress NVEs receives the traffic, it decapsulates
> NVO3 encapsulation, and gets packet statistics with the real time OAM flag
> marking. By comparing the packet number of ingress NVE and the sum of all
> egress NVEs, packet loss can be deduced. This method can be applicable for
> both unicast and multicast traffic. Local policy on ingress NVE is
> configured by operators or automatically acquired from centralized
> orchestration.
>
> Thanks
>
> weiguo
>
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>
>

---

From: Haoweiguo <[email-masked]>
Date: Tue, 11 Nov 2014 20:18:18 +0000

Hi Greg,

I fully agree with you.

The real time OAM is passive performance measurement methods. I would like NVO3 data encapsulation has a field for marking and not affect forwarding of packets, the marking field is only used for performance measurement. The NVO3 packet with this marking flag don't need to be sent to control plane, it is different from OAM(ping/Trace) packet processing.

Thanks

weiguo

________________________________
发件人: Greg Mirsky [[email-masked]]
发送时间: 2014年11月12日 4:07
收件人: Haoweiguo
抄送: [email-masked]
主题: Re: [nvo3] Comments on NVO3 data plane requirements for OAM

Hi Weiguo,
marking groups of packets that belong to the particular flow to facilitate measurement of some performance metric, whether loss or delay/delay variation, may be viewed as one of passive performance measurement methods. But such marking should not alter, at least not significantly alter, treatment of data flow in the network. Because of that, I believe, OAM flag should not be used for marking as that will force punting marked packets from fast forwarding path to the control plane. But it might be good to have a field in NVO3 header that may be used for marking and not affect forwarding of packets if altered.

Regards,
Greg

On Tue, Nov 11, 2014 at 12:34 AM, Haoweiguo <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,
I maybe not clearly said in today’s NVO3 meeting, pls allow me to reiterate the OAM data plane requirements on the mail list.

Thanks

weiguo

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3