Subject: [nvo3] Fwd: New Version Notification for draft-herbert-guecsum-00.txt

From: "[email-masked]" <[email-masked]>
Date: Thu, 27 Nov 2014 23:40:17 +0800

Hi Tom,One question that may have been discussed before. What if we directly use UDP-Lite to encapsulate GUE? Then the checksum in UDP-lite could provide similar function as the checksum option you defined.
RegardsLizhong---------- Forwarded message ----------This draft is based on feedback from Honolulu. This adds a checksum
option in GUE that should hopefully be adequate to protect against
address corruption when using zero checksums with UDP over IPv6. Also,
made it UDP-lite like so that some portion of payload can optionally
be checksummed.
Comments are appreciated.
Thanks,
Tom
---------- Forwarded message ----------
From:  <internet-drafts at ietf.org>
Date: Wed, Nov 26, 2014 at 2:42 PM
Subject: New Version Notification for draft-herbert-guecsum-00.txt
To: Tom Herbert <therbert at google.com>
A new version of I-D, draft-herbert-guecsum-00.txt
has been successfully submitted by Tom Herbert and posted to the
IETF repository.
Name:           draft-herbert-guecsum
Revision:       00
Title:          Checksum option for Generic UDP Encapsulation
Document date:  2014-11-26
Group:          Individual Submission
Pages:          8
URL:            http://www.ietf.org/internet-drafts/draft-herbert-guecsum-00.txt
Status:         https://datatracker.ietf.org/doc/draft-herbert-guecsum/
Htmlized:       http://tools.ietf.org/html/draft-herbert-guecsum-00
Abstract:
   This specification defines the Generic UDP Encapsulation (GUE)
   checksum and an associated header option. This checksum covers the
   GUE header, IP addresses, UDP ports, and optionally all or part of
   the encapsulated payload. It provides verification of protocol header
   elements, and is particularly relevant in the case where the UDP
   checksum is set to zero.
Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.
The IETF Secretariat

---

From: Tom Herbert <[email-masked]>
Date: Thu, 27 Nov 2014 09:29:26 -0800

On Thu, Nov 27, 2014 at 7:40 AM, [email-masked]
<[email-masked]> wrote:
> Hi Tom,
>
> One question that may have been discussed before. What if we directly use
> UDP-Lite to encapsulate GUE? Then the checksum in UDP-lite could provide
> similar function as the checksum option you defined.
>
Yes, that would work, but I believe that the general consensus is that
UDP-lite is not widely supported is hardware (switches or NICs) and
might not even be routed in many networks. On the other hand, UDP has
ubiquitous support already so we want to have a solution for UDP
encapsulation.

Tom

> Regards
> Lizhong
> This draft is based on feedback from Honolulu. This adds a checksum
> URL:
> http://www.ietf.org/internet-drafts/draft-herbert-guecsum-00.txt

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 29 Nov 2014 21:52:44 +0800

Hi Tom,
Got it, thanks. Yes, as I know, UDP-Lite is not widely supported by the parser of switch or NIC chip.

Regards
Lizhong
 
From: Tom Herbert
Date: 2014-11-28 01:29
To: [email-masked]
CC: nvo3
Subject: Re: [nvo3] Fwd: New Version Notification for draft-herbert-guecsum-00.txt
On Thu, Nov 27, 2014 at 7:40 AM, [email-masked]
 
Tom