Subject: [nvo3] Routing directorate QA review of draft-ietf-nvo3-geneve-01

From: John E Drake <[email-masked]>
Date: Fri, 17 Jun 2016 13:49:44 +0000

Hi,

I reviewed the draft and I thought it was fine.  The only question I have is whether the authors considered adding the TLV-based capabilities to VXLAN GPE rather than having a similar but different encapsulation header?

Yours Irrespectively,

John

From: Zhangxian (Xian) [mailto:[email-masked]]
Sent: Monday, June 13, 2016 10:14 PM
To: John E Drake
Cc: [email-masked]; Jonathan Hardwick; Jon Hudson
Subject: Routing directorate QA review of draft-ietf-nvo3-geneve-01

Hi, John,

How are you? I hope everything is fine. There were quite a few drafts that need review and we used all of our review experts within less than two months. And we are circulating back to you now.

Please would you be the routing directorate QA reviewer for draft-ietf-nvo3-geneve-01?
​ https://datatracker.ietf.org/doc/draft-ietf-nvo3-geneve/<https://datatracker.ietf.org/doc/draft-ietf-foo-bar-baz/>

Note that this is a “QA review.” The document does not yet have consensus to be forwarded to the IESG. The goal of this review is to provide a new perspective on the work in progress and to improve its quality. Hence, your comments will be provided primarily for the benefit of the NVO3 chairs and the document authors.

Please could you provide your comments by 28th June? You should send your comments to the draft authors and WG chairs, and copy the relevant WG mailing list and the rtg-dir list.

The following web page contains a briefing on the QA process, and guidance for the QA reviewer.
​https://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDirDocQa<https://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDirDocQa>

Please let me know whether you can do it, or not.

Many thanks
Xian

---

From: Jesse Gross <[email-masked]>
Date: Fri, 17 Jun 2016 21:50:15 +0000

John,

Thank you for your review.

In terms of Geneve vs. VXLAN GPE, both of these documents were designed at roughly the same time and have been proceeding through nvo3 in parallel so they are essentially alternatives rather than the situation where one has existed for a while and the other is an extension. The primary difference between the two protocols is point of view when it comes to extensibility and how (or if) it should be done. As a result, the protocol that you are describing (VXLAN-like with TLVs) essentially is Geneve.

Jesse

On 6/17/16, 6:49 AM, "nvo3 on behalf of John E Drake" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi,

Yours Irrespectively,

John

Hi, John,

Many thanks
Xian