Subject: Re: [nvo3] P802.1Qcn VDP extension for NVO3

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Tue, 16 May 2017 03:05:32 +0000

Hi Yizhou,

The change looks straight forward.
Just a suggestion for the new types (0x05 ~ 0x08).

When adding the new IPv4/IPv6 field, it might be better to add at the end, instead of in the middle.

Ex:.

GroupID/VID  ====(draft)  =====> GroupID/IPv4/VID
             ====(better ?)====> GroupID/VID/IPv4

The benefit to preserve the existing order is that,
if the switch software only wants to consume the new types (0x05 ~ 0x08), but not intend to support the new IP field,
it can just cast the existing struct to the field, and can still get the existing info, group_id, and vid without changes.

If the new field is introduced in the middle, then new message struct and code deem needed at the switch software.
Not meaning the switch software cannot change.
Just we are comparing a few lines change in the draft to the potential more code needed in the various switch software(s).

Format

Value

VID (41.2.9.1)

0x01

MAC/VID (41.2.9.2)

0x02

GroupID/VID (41.2.9.3)

0x03

GroupID/MAC/VID (41.2.9.4)

0x04

GroupID/IPv4/VID (41.2.9.5)

0x05

GroupID/IPv4/MAC/VID (41.2.9.6)

0x06

GroupID/IPv6/VID (41.2.9.7)

0x07

GroupID/IPv6/MAC/VID (41.2.9.8)

0x08

Reserved for future standardization

0x00, 0x09 through 0xFF

Thanks,
Deepak

From: Li Yizhou <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 12, 2017 at 6:09 AM
To: dekumar <[email-masked]<mailto:[email-masked]>>
Subject: FW: [nvo3] P802.1Qcn VDP extension for NVO3

Hi Deepak,

If you got time, would you please help to review the document? The modification are mainly in section 40 ad 41.  The purpose is basically to allow the VNI/IP address to be passed through VDP protocol.

I attached the D0.4 draft for your reference.

Thanks a lot,
Yizhou

From: nvo3 [mailto:[email-masked]] On Behalf Of Pat Thaler
Sent: Wednesday, May 10, 2017 2:01 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [nvo3] P802.1Qcn VDP extension for NVO3

Dear colleagues,

The Data Center Bridging Task Group of IEEE 802.1 will be meeting on Wednesday, 17 May. A number of people from NVO3 volunteered to review the draft of P802Qcn VDP extension for NVO3.

To date I haven't received any feedback from those reviews. It would be very helpful to receive feedback before our upcoming meeting. It is difficult to progress this draft without input from NVO3 participants.

Regards,
Pat

---

From: Liyizhou <[email-masked]>
Date: Wed, 17 May 2017 08:26:27 +0000

Thanks, Deepak.

That sounds reasonable to me. Will add it to the next comment resolution for discussion.

Rgds,
Yizhou

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Tuesday, May 16, 2017 11:06 AM
To: Liyizhou; [email-masked]
Subject: Re: [nvo3] P802.1Qcn VDP extension for NVO3

Hi Yizhou,

Ex:.

Format

Value

VID (41.2.9.1)

0x01

MAC/VID (41.2.9.2)

0x02

GroupID/VID (41.2.9.3)

0x03

0x04

0x05

0x06

0x07

0x08

0x00, 0x09 through 0xFF

Thanks,
Deepak

Hi Deepak,

Thanks a lot,
Yizhou

Dear colleagues,

Regards,
Pat