Subject: [nvo3] Genart telechat review of draft-ietf-nvo3-hpvr2nve-cp-req-13

From: Brian Carpenter <[email-masked]>
Date: Tue, 06 Feb 2018 14:32:08 -0800

Reviewer: Brian Carpenter
Review result: Ready with Issues

Gen-ART Last Call review of draft-ietf-pce-pcep-exp-codepoints-04

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-nvo3-hpvr2nve-cp-req-13.txt
Reviewer: Brian Carpenter
Review Date: 2018-02-07
IETF LC End Date: 2018-02-20
IESG Telechat date: 2018-02-22

Summary: Ready (with minor issue)
--------

Comment:
--------

This is a Last Call review despite the subject field.

Minor issue:
------------

   Req-10: The protocol MUST allow an End Device initiating a request to
   add, remove or update address(es) associated with a TSI instance on
   the external NVE. Addresses can be expressed in different formats,
   for example, MAC, IP or pair of IP and MAC.

Here and elsewhere, it seems necessary to specify that an IP address
can be in either IPv4 or IPv6 format. (This is implied in Table 1
and at the end of Appendix A, but that's quite well hidden.)
I suggest clarifying this early, in Section 1.2 "Target Scenarios".

---

From: Liyizhou <[email-masked]>
Date: Wed, 7 Feb 2018 02:46:19 +0000

Thanks Brian.

I will add " An IP address can be in either IPv4 or IPv6 format." to Section 1.2 Target Scenarios as below.

Section 1.2 Target Scenarios
.... In the Split-NVE architecture, the external NVE may be able to reach multiple MAC and IP addresses via a TSI. *An IP address can be in either IPv4 or IPv6 format.* For example, .....

Rgds,
Yizhou

-----Original Message-----
From: Brian Carpenter [mailto:[email-masked]] 
Sent: Wednesday, February 07, 2018 6:32 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Genart telechat review of draft-ietf-nvo3-hpvr2nve-cp-req-13

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Comment:
--------

Minor issue:
------------

Here and elsewhere, it seems necessary to specify that an IP address can be in either IPv4 or IPv6 format. (This is implied in Table 1 and at the end of Appendix A, but that's quite well hidden.) I suggest clarifying this early, in Section 1.2 "Target Scenarios".

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 21 Feb 2018 21:43:48 -0800

Brian, thanks for your review. Yizhou, thanks for your response. I have entered a No Objection ballot.

Alissa

> On Feb 6, 2018, at 6:46 PM, Liyizhou <[email-masked]> wrote:
> 
> Thanks Brian.
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art