Subject: [nvo3] Ben Campbell's No Objection on draft-ietf-nvo3-hpvr2nve-cp-req-15: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Wed, 21 Feb 2018 19:57:29 -0800

Ben Campbell has entered the following ballot position for
draft-ietf-nvo3-hpvr2nve-cp-req-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-nvo3-hpvr2nve-cp-req/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Substantive Comments:

§1.2: It would be helpful to see the TSI labeled in the figures.

§6: Are there requirements for the tenant system to ensure that it is
connecting to the correct nNVE?

Editorial Comments and Nits:

§1: Please expand tNVE and nNVE

§6: "... that any hypervisor wishing to use the services of an NVE are properly
authorized..." plural disagreement (s/ are / is

§7: IANA (weakly) recommends that the IANA section be retained even when empty.
(It's still the authors' call.)

§9: "merger from the drafts"
s/from/of

---

From: Liyizhou <[email-masked]>
Date: Thu, 22 Feb 2018 06:27:26 +0000

Hi Ben,

Thanks for reviewing. Please see inlines with [yz].

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Thursday, February 22, 2018 11:57 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; Matthew Bocci <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Ben Campbell's No Objection on draft-ietf-nvo3-hpvr2nve-cp-req-15: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Substantive Comments:

§1.2: It would be helpful to see the TSI labeled in the figures.
[yz] seems reasonable to have TSI labeled in figure 1 to indicate the overall structure. 

§6: Are there requirements for the tenant system to ensure that it is connecting to the correct nNVE?
[yz] nNVE is mostly located on top of rack switch in data center. Hence in most cases, nNVE are trustworthy entities to authorize/authenticate tNVE. 
In some corner cases, if tNVE could connect to different nNVEs for some purposes like traffic sharing with certain constraints etc, tNVE may take the role to authorize/authenticate a particular nNVE.  It will rely on some non-VDP-extension-based mechanisms to address these corner cases.
I will be adding some text as abovementioned to Security Considerations section.

[yz] I am fine with all the changes below. 
Editorial Comments and Nits:

§6: "... that any hypervisor wishing to use the services of an NVE are properly authorized..." plural disagreement (s/ are / is