Subject: Re: [nwcrg] Fwd: Re.: Impact of Virtualization and SDN on NextGen Network Coding

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Thu, 2 Jan 2014 14:08:59 +0000

Can you give us some context on the applicability of this document? Is it for SDNRG?

Thanks
Senthil

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, December 31, 2013 10:07 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nwcrg] Fwd: Re.: Impact of Virtualization and SDN on NextGen Network Coding

Still working on it, attached PLS find the outline and
some proposed text ..

Comments, suggestions, and inputs are welcome..Thanks.

Best.

Bhumip

================================================

  *   From: "B.Khasnabish at ieee.org<mailto:[email-masked]>" <vumip1 at gmail.com<mailto:[email-masked]>>
  *   To: nwcrg at irtf.org<mailto:[email-masked]>
  *   Date: Wed, 13 Nov 2013 09:06:06 -0500
  *   List-id: Network Coding IRTF proposed research group discussion list <nwcrg.irtf.org<http://nwcrg.irtf.org>>

________________________________
Hi,
I am looking for inputs/discussion/suggestions
in the areas of impact of virtualization (abstraction) and SDN [control/forward separation and
use of open APIs in North-South-East-West of the (logical) controller]
on NextGen Network Coding.
Of particular interest is to explore how abstracted node, route, topology, policy, cache, security, APIs, etc. play in overall
emerging network coding and the services that use
network coding.
Many thanks for kind response.
Best.
Bhumip

Bhumip Khasnabish
+1-781-752-8003<tel:%2B1-781-752-8003> (mobile)
http://tinyurl.com/bhumip
http://tinyurl.com/bhumips-patents
               __o
            _ `\ <, _
.......... ( • ) / ( • ) ......................

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 2 Jan 2014 15:54:41 -0500

Thanks Senthil.

Initially targeting NWCRG, and yes can be shared with
SDNRG as well based on interests.

Pls let me know ASAP if you or anyone from you organization is
interested to contribute to this doc. Thanks.

Best.

Bhumip

                   __o
             _ `\ <, _

On Thu, Jan 2, 2014 at 9:08 AM, Senthil Sivakumar (ssenthil) <
[email-masked]> wrote:

>   From: "[email-masked]" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
>    - *From*: "B.Khasnabish at ieee.org <[email-masked]>" <vumip1
>    at gmail.com <[email-masked]>>
>    - *To*: nwcrg at irtf.org <[email-masked]>
>    - *Date*: Wed, 13 Nov 2013 09:06:06 -0500
>    - *List-id*: Network Coding IRTF proposed research group discussion
>    list <nwcrg.irtf.org>
>
> ------------------------------
>  Hi,
>  Of particular interest is to explore how abstracted node, route,
> topology, policy, cache, security, APIs, etc. play in overall
> +1-781-752-8003 (mobile)

---

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Fri, 3 Jan 2014 00:16:14 +0000

I would be interested in contributing but I am not sure if this is in the nwcrg charter, is it?

Thanks
Senthil

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 2, 2014 3:54 PM
To: Senthil Sivakumar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nwcrg] Fwd: Re.: Impact of Virtualization and SDN on NextGen Network Coding

Thanks Senthil.

Best.

Bhumip

                   __o
             _ `\ <, _

On Thu, Jan 2, 2014 at 9:08 AM, Senthil Sivakumar (ssenthil) <[email-masked]<mailto:[email-masked]>> wrote:
Can you give us some context on the applicability of this document? Is it for SDNRG?

Thanks
Senthil

Best.

Bhumip

Bhumip Khasnabish

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 4 Jan 2014 00:59:40 -0500

Sure it does Senthil, Pls see the revised  charter (slide-5) at
the following URL:

http://www.ietf.org/proceedings/88/slides/slides-88-nwcrg-0.pdf

and of course you can discuss this with Victor and/or Brian

(the NWCRG chairs) to confirm this..

Thanks a lot

Best.
Bhumip

Bhumip Khasnabish

On Thu, Jan 2, 2014 at 7:16 PM, Senthil Sivakumar (ssenthil) <ssenthil@cisco
.com> wrote:

> To: Senthil Sivakumar <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 4 Jan 2014 04:31:40 -0500

I think the idea is interesting but can you explain what you mean by Network Coding controller? I had worked on an concept where services requiring NC could use some kind of 'NC server' amd I think it could be related.

/mjm

Marie-José Montpetit
[email-masked]
[email-masked]

> On Jan 4, 2014, at 0:59, "[email-masked]" <[email-masked]> wrote:
> 
>  
>> On Thu, Jan 2, 2014 at 7:16 PM, Senthil Sivakumar (ssenthil) <[email-masked]> wrote:
>>> On Thu, Jan 2, 2014 at 9:08 AM, Senthil Sivakumar (ssenthil) <[email-masked]> wrote:
>>> From: "B.Khasnabish at ieee.org" <vumip1 at gmail.com>
>>> To: nwcrg at irtf.org
>>> Date: Wed, 13 Nov 2013 09:06:06 -0500
>>> List-id: Network Coding IRTF proposed research group discussion list <nwcrg.irtf.org>
>>> Hi,
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 6 Jan 2014 13:03:59 -0500

Thanks a lot Marie-José.

In general, the Network Coding controller (NCC) would be involved with
controlling virtual/physical instances of all of the elements/entities of
Network Coding architecture (slide-3 of the attachment of my email
on Mon, Dec 23, 2013 at 6:26 PM to [email-masked]) via appropriate
north/south/east/west/etc. interfaces.

Yes, the NC server may offer virtual/physical resources to the
Apps/service,
and additional management/orchestration may be required.

Sure these could be related.

If you can, Pls share more details on the NC server that you worked on
earlier.

Thanks again.

Best.
Bhumip

Smart-Grid-2030:
http://standards.ieee.org/findstds/prod/research/toc_comm2030.pdf
                   __o
             _ `\ <, _
.......... ( • ) / ( • ) ......................

On Sat, Jan 4, 2014 at 4:31 AM, Marie-Jose Montpetit
<[email-masked]>wrote:

> I think the idea is interesting but can you explain what you mean by
> Network Coding controller? I had worked on an concept where services
> requiring NC could use some kind of 'NC server' amd I think it could be
> related.
>
> /mjm
>
> Marie-José Montpetit
> [email-masked]
> [email-masked]
>