Subject: Re: [nwcrg] nwcrg Digest, Vol 41, Issue 5

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 9 Mar 2017 09:14:29 -0500

With all due respect I completely disagree on keeping the current list of reference because it is just a few papers that do not represent the full activiities in the field especially that they are all almost prior to 2008 . I would suggest instead we create independently a list of references that we post on the group site.

Marie-José
> On Mar 9, 2017, at 8:49 AM, [email-masked] wrote:
> 
> Send nwcrg mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.irtf.org/mailman/listinfo/nwcrg
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of nwcrg digest..."
> Today's Topics:
> 
>   1. Re: I-D Action:
>      draft-irtf-nwcrg-network-coding-taxonomy-01.txt
>      ([email-masked])
>   2. Re: I-D Action:
>      draft-irtf-nwcrg-network-coding-taxonomy-01.txt (Emmanuel Lochin)
> 
> From: [email-masked]
> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt
> Date: March 9, 2017 at 7:48:13 AM EST
> To: Vincent Roca <[email-masked]>
> Cc: [email-masked]
> 
> 
> Dear all,
> 
> I suggest that we keep the references, its short list anyways. Having the references will help formalize and acknowledge the schemes we are stating, as a research specialized group. We are then promoting the technology (e.g. RLNC) and the associated schemes (e.g. AD RLNC), with all NWCRG in editors, co-authors, and members as a complete body contributing to this taxonomy.
> 
> Best,
> Samah.
> 
> On Thu, Mar 9, 2017 at 1:35 PM, Vincent Roca <[email-masked] <mailto:[email-masked]>> wrote:
> Hello everybody,
> 
> You'll find attached a preliminary version of our taxonomy I-D.
> It is based on yesterday's discussions (five people joined the audio) and comments made since the previous audio.
> The goal is to finalise a version by tomorrow, Friday 10th, and submit it.
> 
> If you have comments, please send it either directly to me or to the list as soon as possible. Thanks.
> 
> Important comment about references:
> 
> I have removed **all** references to non-IETF documents. The goal is to avoid promoting some works, with the risk of omitting
> other works, or ending up with a very very long list of references to satisfy everybody. This is in some way unfair to seminal
> works. A comment made yesterday is that this is not a tutorial or survey of the domain in which case omitting references would
> be an issue. If ever you disagree (or agree), do not hesitate to say so in the list, it's open to discussions.
> 
> Cheers,
> 
>   Vincent
> 
> 
> NB: do not use the Google Drive version that is now outdated. I have switched to a local XML version.
> 
> 
> 
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
> 
> 
> 
> 
> 
> From: Emmanuel Lochin <[email-masked]>
> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt
> Date: March 9, 2017 at 8:44:47 AM EST
> To: [email-masked]
> 
> 
> Hi Vincent, all,
> 
> Just a slight comment concerning :
> 
> Multi-Path Coding:  Network coding over a route that has multiple
>            disjoint paths from the source to each given destination.  A
>            typical example is multi-path TCP (MPTCP).
> 
> In the text, you talk about multiple disjoint routes. So IMHO it suggests multi-path routing (layer 3). But you give as an example MPTCP which is layer 4 and e2e. So my question is: does multi-path coding refers to encoding at the end-point or inside the network or both? If both, may be RFC2991 or 2992 should be cited and we might ?
> What do you reckon?
> 
> EL
> 
> Le 09/03/2017 à 13:35, Vincent Roca a écrit :
>> Hello everybody,
>> 
>> You'll find attached a preliminary version of our taxonomy I-D.
>> It is based on yesterday's discussions (five people joined the audio) and comments made since the previous audio.
>> The goal is to finalise a version by tomorrow, Friday 10th, and submit it.
>> 
>> If you have comments, please send it either directly to me or to the list as soon as possible. Thanks.
>> 
>> Important comment about references:
>> 
>> I have removed **all** references to non-IETF documents. The goal is to avoid promoting some works, with the risk of omitting
>> other works, or ending up with a very very long list of references to satisfy everybody. This is in some way unfair to seminal
>> works. A comment made yesterday is that this is not a tutorial or survey of the domain in which case omitting references would
>> be an issue. If ever you disagree (or agree), do not hesitate to say so in the list, it's open to discussions.
>> 
>> Cheers,
>> 
>>   Vincent
>> 
>> 
>> NB: do not use the Google Drive version that is now outdated. I have switched to a local XML version.
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> _______________________________________________
>> nwcrg mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
> 
> 
> -- 
> Emmanuel LOCHIN
> Professeur ISAE
> ISAE SUPAERO - Institut Supérieur de l'Aéronautique et de l'Espace
> 10 avenue Edouard Belin - BP 54032 - 31055 TOULOUSE CEDEX 4 FRANCE -
> http://www.isae-supaero.fr <http://www.isae-supaero.fr/>
> Tel +33 5 61 33 84 85 - Fax (+33) 5 61 33 83 45
> Web : http://personnel.isae.fr/emmanuel-lochin/ <http://personnel.isae.fr/emmanuel-lochin/>
> 
>    <https://www.isae.fr/fr/actualites/versez-la-taxe-d-apprentissage-a-l-isae-supaero-c-est-facile>
> 
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: <[email-masked]>
Date: Thu, 9 Mar 2017 14:33:05 +0000

Hi all,

I also to tend to agree that on the one hand including references other than RFCs or I-D is certainly beneficial to better illustrate the concepts, but on the other hand those references must reflect the most recent development or activity. Otherwise, I’m afraid that the I-D will be regarded as not sufficiently updated or timely to be promoted to RFC.

My 0.02 cents,

Tomaso
————————————————————————
Deutsches Zentrum für Luft- und Raumfahrt (DLR)
German Aerospace Center
Institute of Communications and Navigation | Satellite Networks | Oberpfaffenhofen | 82234 Wessling | Germany
Tomaso de Cola, Ph.D.
Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 | [email-masked]<mailto:[email-masked]>
http://www.dlr.de/kn/institut/abteilungen/san

From: nwcrg [mailto:[email-masked]] On Behalf Of Marie-Jose Montpetit
Sent: Thursday, March 09, 2017 3:14 PM
To: [email-masked]
Subject: Re: [nwcrg] nwcrg Digest, Vol 41, Issue 5

Marie-José
On Mar 9, 2017, at 8:49 AM, [email-masked]<mailto:[email-masked]> wrote:

Send nwcrg mailing list submissions to
          [email-masked]<mailto:[email-masked]>

  1. Re: I-D Action:

Dear all,

On Thu, Mar 9, 2017 at 1:35 PM, Vincent Roca <[email-masked]<mailto:[email-masked]>> wrote:
Hello everybody,

Cheers,

  Vincent

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

Hi Vincent, all,

EL

Cheers,

  Vincent

nwcrg mailing list

[email-masked]<mailto:[email-masked]>

--

Emmanuel LOCHIN

Professeur ISAE

http://www.isae-supaero.fr<http://www.isae-supaero.fr/>

Web : http://personnel.isae.fr/emmanuel-lochin/

[Image removed by sender.]<https://www.isae.fr/fr/actualites/versez-la-taxe-d-apprentissage-a-l-isae-supaero-c-est-facile>

---

From: [email-masked]
Date: Thu, 9 Mar 2017 16:05:41 +0100

Dear MarieJosé, Tomaso, all,

Thank you so much for your proposal to put some references online, its very
nice indeed.

Certain schemes are milestone works, starting by T. Ho, M. Médard, RLNC
work, TDD RLNC milestones (2008-2010) surviving until today through its
classical form or via ones that include adaptivity to RLNC for TVC by S.
Ghanem etc (2013-2016-2017) in a more practial granuality when channels are
time variant considering earlier results as well by B. Shrader or M. Xiao.
We can keep the milestone papers as I see no harm to keep them and sell for
them have them well acknowledged.

Best,
Samah

On Thursday, March 9, 2017, <[email-masked]> wrote:

> Hi all,
>
>
>
> I also to tend to agree that on the one hand including references other
> than RFCs or I-D is certainly beneficial to better illustrate the concepts,
> but on the other hand those references must reflect the most recent
> development or activity. Otherwise, I’m afraid that the I-D will be
> regarded as not sufficiently updated or timely to be promoted to RFC.
>
>
>
> My 0.02 cents,
>
>
>
> Tomaso
>
> ————————————————————————
> *Deutsches Zentrum für Luft- und Raumfahrt* (DLR)
> German Aerospace Center
> Institute of Communications and Navigation | Satellite Networks |
> Oberpfaffenhofen | 82234 Wessling | Germany
>
> *Tomaso de Cola, Ph.D.*
> Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 |
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *From:* nwcrg [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>] *On Behalf Of *Marie-Jose
> Montpetit
> *Sent:* Thursday, March 09, 2017 3:14 PM
> *To:* [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *Subject:* Re: [nwcrg] nwcrg Digest, Vol 41, Issue 5
>
>
>
> With all due respect I completely disagree on keeping the current list of
> reference because it is just a few papers that do not represent the full
> activiities in the field especially that they are all almost prior to 2008
> . I would suggest instead we create independently a list of references that
> we post on the group site.
>
>
>
> Marie-José
>
> On Mar 9, 2017, at 8:49 AM, [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');> wrote:
>
>
>
>           [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
>      ([email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>)
>   2. Re: I-D Action:
> *From: [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
> *Subject: Re: [nwcrg] I-D Action:
> draft-irtf-nwcrg-network-coding-taxonomy-01.txt*
>
> *Date: *March 9, 2017 at 7:48:13 AM EST
>
> *To: *Vincent Roca <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>
> *Cc: [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
>
>
> Dear all,
>
> I suggest that we keep the references, its short list anyways. Having the
> references will help formalize and acknowledge the schemes we are stating,
> as a research specialized group. We are then promoting the technology (e.g.
> RLNC) and the associated schemes (e.g. AD RLNC), with all NWCRG in editors,
> co-authors, and members as a complete body contributing to this taxonomy.
>
> Best,
>
> Samah.
>
>
>
> On Thu, Mar 9, 2017 at 1:35 PM, Vincent Roca <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> Hello everybody,
>
>
>
> The goal is to finalise a version by tomorrow, *Friday 10th*, and submit
> it.
>
>
>
> *Important comment about references:*
>
>
>
> I have removed **all** references to non-IETF documents. The goal is to
> avoid promoting some works, with the risk of omitting
>
> other works, or ending up with a very very long list of references to
> satisfy everybody. This is in some way unfair to seminal
>
> works. A comment made yesterday is that this is not a tutorial or survey
> of the domain in which case omitting references would
>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *From: *Emmanuel Lochin <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>
> *Subject: Re: [nwcrg] I-D Action:
> draft-irtf-nwcrg-network-coding-taxonomy-01.txt*
>
> *Date: *March 9, 2017 at 8:44:47 AM EST
>
> *To: [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
>
>
> Hi Vincent, all,
>
> In the text, you talk about multiple disjoint routes. So IMHO it suggests
> multi-path routing (layer 3). But you give as an example MPTCP which is
> layer 4 and e2e. So my question is: does multi-path coding refers to
> encoding at the end-point or inside the network or both? If both, may be
> RFC2991 or 2992 should be cited and we might ?
> What do you reckon?
>
> EL
>
> The goal is to finalise a version by tomorrow, *Friday 10th*, and submit
> it.
>
>
>
> *Important comment about references:*
>
>
>
> I have removed **all** references to non-IETF documents. The goal is to
> avoid promoting some works, with the risk of omitting
>
> other works, or ending up with a very very long list of references to
> satisfy everybody. This is in some way unfair to seminal
>
> works. A comment made yesterday is that this is not a tutorial or survey
> of the domain in which case omitting references would
>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
> http://www.isae-supaero.fr
>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>