Subject: Re: [nwcrg] nwcrg Digest, Vol 41, Issue 11

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 10 Mar 2017 15:07:44 -0500

I am happy to volunteer on creating a list. I propose we have: seminal articles, network codes, network code software, development and commercial implementations. And of course ask to the list for agreement.

mjm
> On Mar 10, 2017, at 3:00 PM, [email-masked] wrote:
> 
> Send nwcrg mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.irtf.org/mailman/listinfo/nwcrg
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of nwcrg digest..."
> Today's Topics:
> 
>   1. Re: I-D Action:
>      draft-irtf-nwcrg-network-coding-taxonomy-01.txt (Vincent Roca)
>   2. Re: I-D Action:
>      draft-irtf-nwcrg-network-coding-taxonomy-01.txt (Vincent Roca)
>   3. I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-02.txt
>      ([email-masked])
> 
> From: Vincent Roca <[email-masked]>
> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt
> Date: March 10, 2017 at 4:16:30 AM EST
> To: Emmanuel Lochin <[email-masked]>
> Cc: [email-masked]
> 
> 
> Hello Emmanuel,
> 
>> Multi-Path Coding:  Network coding over a route that has multiple
>>           disjoint paths from the source to each given destination.  A
>>           typical example is multi-path TCP (MPTCP).
>> 
>> In the text, you talk about multiple disjoint routes. So IMHO it suggests multi-path routing (layer 3). But you give as an example MPTCP which is layer 4 and e2e. So my question is: does multi-path coding refers to encoding at the end-point or inside the network or both? If both, may be RFC2991 or 2992 should be cited and we might ?
>> What do you reckon?
> 
> Good point, it's confusing.
> Network Coding is defined before, and we say E2E coding is a special case. It applies here as well.
> However MTCP does not include any coding mechanism and this example is misleading. I removed it.
> 
> NEW:
> 
> Single-Path Coding:
> Network Coding over a route that has a single path from the source to each destination(s). In case of multicast or broadcast traffic, this route is a tree. Coding may be done end-to-end and/or at intermediate forwarding nodes.
> 
> Multi-Path Coding:
> Network Coding over a route that has multiple (at least partially) disjoint paths from the source to each given destination. Coding may be done end-to-end and/or at intermediate  forwarding nodes.
> 
> 
> Thanks,
> 
>   Vincent
> 
> 
> 
> 
> From: Vincent Roca <[email-masked]>
> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt
> Date: March 10, 2017 at 5:15:04 AM EST
> To: [email-masked]
> 
> 
> Samah, Marie-Jose, Tomaso, et al,
> 
> Thanks a lot for your valuable feedback. Here is my proposal:
> 
> 1- Having a reading list in our Web site (https://irtf.org/nwcrg <https://irtf.org/nwcrg>) seems to gather consensus. I like the idea too.
>   Seminal articles will be in, but where to stop and how to organise this list are tough questions. If we just
>   concatenate all references provided by each of us, then the added value would be limited. If instead we
>   organise references in thematics and limit their number (which means agreeing all together on what to
>   include/exclude), then it would be useful. But it has a cost.
>   The angle is also essential: a goal and challenge for us is to facilitate the transition from theoretical works
>   to practical ones. We need to keep it in mind.
> 
> 2- Having non-IETF references in the taxonomy I-D is not required nor desirable. However  this I-D should
>   refer to the future online list (we anticipate a little bit).
> 
> 
> Question: if you volunteer to work on 1-, please tell me. Depending on answers we'll decide if we have
>   enough critical mass for that.
> 
> Side comment/idea: topic 1- above is not very far from a State of the Art. A **common** academic article
>   could be an additional valuable output. TBC...
> 
> 
> Cheers,
> 
>   Vincent
> 
> 
> 
> 
> From: [email-masked]
> Subject: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-02.txt
> Date: March 10, 2017 at 9:55:49 AM EST
> To: <[email-masked]>
> Cc: [email-masked]
> 
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Network Coding of the IETF.
> 
>        Title           : Network Coding Taxonomy
>        Authors         : Vincent Roca
>                          Victor Firoiu
> 	Filename        : draft-irtf-nwcrg-network-coding-taxonomy-02.txt
> 	Pages           : 13
> 	Date            : 2017-03-10
> 
> Abstract:
>   This document summarizes a recommended terminology for Network Coding
>   concepts and constructs.  It provides a comprehensive set of terms in
>   order to avoid ambiguities in future Network Coding IRTF and IETF
>   documents.  This document is intended to be in-line with the
>   terminology used by the RFCs produced by the Reliable Multicast
>   Transport (RMT) and FEC Framework (FECFRAME) IETF working groups.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-taxonomy/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-irtf-nwcrg-network-coding-taxonomy-02
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-irtf-nwcrg-network-coding-taxonomy-02
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> 
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: [email-masked]
Date: Tue, 14 Mar 2017 16:19:38 +0200

Dear Vincent, Marie-Jose, all,

thank you. I can give a hand in the structure and provide few key
references as well.

Best,
Samah.

On Fri, Mar 10, 2017 at 10:07 PM, Marie-Jose Montpetit <
[email-masked]> wrote:

> I am happy to volunteer on creating a list. I propose we have: seminal
> articles, network codes, network code software, development and commercial
> implementations. And of course ask to the list for agreement.
>
> mjm
>
> *From: *Vincent Roca <[email-masked]>
> *Subject: **Re: [nwcrg] I-D Action:
> draft-irtf-nwcrg-network-coding-taxonomy-01.txt*
> *Date: *March 10, 2017 at 4:16:30 AM EST
> *To: *Emmanuel Lochin <[email-masked]>
> *Cc: [email-masked]
>
>
> Hello Emmanuel,
>
> In the text, you talk about multiple disjoint routes. So IMHO it suggests
> multi-path routing (layer 3). But you give as an example MPTCP which is
> layer 4 and e2e. So my question is: does multi-path coding refers to
> encoding at the end-point or inside the network or both? If both, may be
> RFC2991 or 2992 should be cited and we might ?
> What do you reckon?
>
>
> Network Coding over a route that has a single path from the source to each
> destination(s). In case of multicast or broadcast traffic, this route is a
> tree. Coding may be done end-to-end and/or at intermediate forwarding nodes.
>
> Multi-Path Coding:
> Network Coding over a route that has multiple (at least partially)
> disjoint paths from the source to each given destination. Coding may be
> done end-to-end and/or at intermediate  forwarding nodes.
>
>
> Thanks,
>
>   Vincent
>
>
>
>
> *From: *Vincent Roca <[email-masked]>
> *Subject: **Re: [nwcrg] I-D Action:
> draft-irtf-nwcrg-network-coding-taxonomy-01.txt*
> *Date: *March 10, 2017 at 5:15:04 AM EST
> *To: [email-masked]
>
>
> 1- Having a reading list in our Web site (https://irtf.org/nwcrg) seems
> to gather consensus. I like the idea too.
>   The angle is also essential: a goal and challenge for us is to
> facilitate the transition from theoretical works
> *From: [email-masked]
> *Subject: **[nwcrg] I-D Action:
> draft-irtf-nwcrg-network-coding-taxonomy-02.txt*
> *Date: *March 10, 2017 at 9:55:49 AM EST
> *To: *<[email-masked]>
> *Cc: [email-masked]
>
>
>