Subject: Re: [nwcrg] nwcrg Digest, Vol 41, Issue 3

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 8 Mar 2017 19:47:41 -0500

Great job!!!!

> On Mar 8, 2017, at 3:00 PM, [email-masked] wrote:
> 
> Send nwcrg mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.irtf.org/mailman/listinfo/nwcrg
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of nwcrg digest..."
> Today's Topics:
> 
>   1. Re: I-D Action:
>      draft-irtf-nwcrg-network-coding-taxonomy-01.txt (Vincent Roca)
> 
> From: Vincent Roca <[email-masked]>
> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt
> Date: March 8, 2017 at 8:39:48 AM EST
> To: [email-masked]
> 
> 
> Hello everybody,
> 
> We'll held our 3rd and last audio this Wednesday March 8th (see webex connection details below).
> I have prepared a new version (taking into account most comments) in the Google Drive document.
> 
> Goal is to resolve the remaining open points so that I can prepare the updated I-D and submit it (on
> Friday probably).
> 
> Regards,
> 
>   Vincent
> 
> 
>> ------
>> 
>> Please find below the link to the webex and corresponding password for the next (2017/March/8 at 4:00 PM Paris time) conference call.
>>  
>> Join WebEx meeting <https://ik4.webex.com/ik4-en/j.php?MTID=md61bdabe1f1e67ff37537298ee3d5264>
>> Meeting number: 845 764 429    
>> Meeting password:       nwcrg  
>>  
>> Best regards, 
>> Josu
>> 
>> 
>> 
>>> Hello,
>>> 
>>> I suggest to hold our final Taxonomy audio on Wednesday March 8th, same time
>>> (4pm Paris time, 10am Boston time).
>>> 
>>> Webex connection information will follow (once again thanks to Josu).
>>> 
>>> Cheers,
>>> 
>>>   Vincent
>>> 
>>>> Hello everybody,
>>>> 
>>>> Yesterday's audio gathered 8 people, myself included, and we made a lot of progress.
>>>> 
>>>> This is the last mile... We decided to have a final audio in two weeks, a few days before
>>>> the deadline (2017/03/13). Everybody is welcome to participate, both in the audio and
>>>> (above all) Google Drive document where you can comment and/or suggest definitions.
>>>> (ask me if you don't have access to this document)
>>>> 
>>>> Here is a Doodle to select the best date for next audio:
>>>> 		http://doodle.com/poll/82a4aivnyyxgp626 <http://doodle.com/poll/82a4aivnyyxgp626>
>>>> You have two days, until Friday morning (GMT time). Thanks.
>>>> 
>>>> Cheers,
>>>> 
>>>>   Vincent
> 
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Vincent Roca <[email-masked]>
Date: Thu, 9 Mar 2017 13:35:33 +0100

Hello everybody,

You'll find attached a preliminary version of our taxonomy I-D.
It is based on yesterday's discussions (five people joined the audio) and comments made since the previous audio.
The goal is to finalise a version by tomorrow, Friday 10th, and submit it.

If you have comments, please send it either directly to me or to the list as soon as possible. Thanks.

Important comment about references:

I have removed **all** references to non-IETF documents. The goal is to avoid promoting some works, with the risk of omitting
other works, or ending up with a very very long list of references to satisfy everybody. This is in some way unfair to seminal
works. A comment made yesterday is that this is not a tutorial or survey of the domain in which case omitting references would
be an issue. If ever you disagree (or agree), do not hesitate to say so in the list, it's open to discussions.

Cheers,

  Vincent

NB: do not use the Google Drive version that is now outdated. I have switched to a local XML version.

---

From: [email-masked]
Date: Thu, 9 Mar 2017 13:48:13 +0100

Dear all,

I suggest that we keep the references, its short list anyways. Having the
references will help formalize and acknowledge the schemes we are stating,
as a research specialized group. We are then promoting the technology (e.g.
RLNC) and the associated schemes (e.g. AD RLNC), with all NWCRG in editors,
co-authors, and members as a complete body contributing to this taxonomy.

Best,
Samah.

On Thu, Mar 9, 2017 at 1:35 PM, Vincent Roca <[email-masked]> wrote:

> The goal is to finalise a version by tomorrow, *Friday 10th*, and submit
> it.
>
> *Important comment about references:*
>
> I have removed **all** references to non-IETF documents. The goal is to
> avoid promoting some works, with the risk of omitting
> other works, or ending up with a very very long list of references to
> satisfy everybody. This is in some way unfair to seminal
> works. A comment made yesterday is that this is not a tutorial or survey
> of the domain in which case omitting references would

---

From: Emmanuel Lochin <[email-masked]>
Date: Thu, 9 Mar 2017 14:44:47 +0100

Hi Vincent, all,

Just a slight comment concerning :

Multi-Path Coding:  Network coding over a route that has multiple
            disjoint paths from the source to each given destination.  A
            typical example is multi-path TCP (MPTCP).

In the text, you talk about multiple disjoint routes. So IMHO it 
suggests multi-path routing (layer 3). But you give as an example MPTCP 
which is layer 4 and e2e. So my question is: does multi-path coding 
refers to encoding at the end-point or inside the network or both? If 
both, may be RFC2991 or 2992 should be cited and we might ?
What do you reckon?

EL

Le 09/03/2017 à 13:35, Vincent Roca a écrit :
> It is based on yesterday's discussions (five people joined the audio) 
> and comments made since the previous audio.
> The goal is to finalise a version by tomorrow, *Friday 10th*, and 
> submit it.
>
> I have removed **all** references to non-IETF documents. The goal is 
> to avoid promoting some works, with the risk of omitting
> works. A comment made yesterday is that this is not a tutorial or 
> survey of the domain in which case omitting references would
> be an issue. If ever you disagree (or agree), do not hesitate to say 
> so in the list, it's open to discussions.
>
> Cheers,
>
>   Vincent
>
>

-- 
Emmanuel LOCHIN
Professeur ISAE
ISAE SUPAERO - Institut Supérieur de l'Aéronautique et de l'Espace
10 avenue Edouard Belin - BP 54032 - 31055 TOULOUSE CEDEX 4 FRANCE -
http://www.isae-supaero.fr
Tel +33 5 61 33 84 85 - Fax (+33) 5 61 33 83 45
Web : http://personnel.isae.fr/emmanuel-lochin/

En 2017, donnez du sens Ã  la taxe d'apprentissage, soutenez l'ISAE-SUPAERO !
https://www.isae.fr/fr/actualites/versez-la-taxe-d-apprentissage-a-l-isae-supaero-c-est-facile

---

From: Vincent Roca <[email-masked]>
Date: Fri, 10 Mar 2017 10:16:30 +0100

Hello Emmanuel,

> In the text, you talk about multiple disjoint routes. So IMHO it suggests multi-path routing (layer 3). But you give as an example MPTCP which is layer 4 and e2e. So my question is: does multi-path coding refers to encoding at the end-point or inside the network or both? If both, may be RFC2991 or 2992 should be cited and we might ?
> What do you reckon?

Good point, it's confusing.
Network Coding is defined before, and we say E2E coding is a special case. It applies here as well.
However MTCP does not include any coding mechanism and this example is misleading. I removed it.

NEW:

Single-Path Coding:
Network Coding over a route that has a single path from the source to each destination(s). In case of multicast or broadcast traffic, this route is a tree. Coding may be done end-to-end and/or at intermediate forwarding nodes.

Multi-Path Coding:
Network Coding over a route that has multiple (at least partially) disjoint paths from the source to each given destination. Coding may be done end-to-end and/or at intermediate  forwarding nodes.

Thanks,

   Vincent

---

From: Vincent Roca <[email-masked]>
Date: Fri, 10 Mar 2017 11:15:04 +0100

Samah, Marie-Jose, Tomaso, et al,

Thanks a lot for your valuable feedback. Here is my proposal:

1- Having a reading list in our Web site (https://irtf.org/nwcrg <https://irtf.org/nwcrg>) seems to gather consensus. I like the idea too.
  Seminal articles will be in, but where to stop and how to organise this list are tough questions. If we just
  concatenate all references provided by each of us, then the added value would be limited. If instead we
  organise references in thematics and limit their number (which means agreeing all together on what to
  include/exclude), then it would be useful. But it has a cost.
  The angle is also essential: a goal and challenge for us is to facilitate the transition from theoretical works
  to practical ones. We need to keep it in mind.

2- Having non-IETF references in the taxonomy I-D is not required nor desirable. However  this I-D should
  refer to the future online list (we anticipate a little bit).

Question: if you volunteer to work on 1-, please tell me. Depending on answers we'll decide if we have
  enough critical mass for that.

Side comment/idea: topic 1- above is not very far from a State of the Art. A **common** academic article
  could be an additional valuable output. TBC...

Cheers,

  Vincent