Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-03.txt

From: Vincent Roca <[email-masked]>
Date: Mon, 3 Jul 2017 10:07:25 +0200

Hello Victor,

Thanks for these suggestions. I’ve included them as follows:

** Page.3:
NEW:
   This document IS NOT restricted to constructs that perform re-coding
   within intermediate forwarding nodes.  While this document considers
   Network Coding (i.e., re-coding within the network), it also
   considers End-to-End Coding (i.e., source-only coding).

=> I’ve preferred e2e as it is formally defined later on.

** Page 9:
NEW:
   Rateless Coding can generate an
   unlimited number of Repair Symbols (in practice this number
   is extremely large) […]

Does anybody have any quick comment (I’m not expecting any major change at
this level)? Otherwise I’ll submit this -04 version at the end of the afternoon
(European time) and will continue with IRTF process.

Cheers,

  Vincent

> Le 30 juin 2017 à 19:50, Firoiu, Victor (US) <[email-masked]> a écrit :
> 
>  
> Thanks, Vincent, this looks good.
>  
> A couple of comments and suggestions:
>  
> Page 3: “If network coding (i.e., re-coding within the network) is of course considered, this document has a broader scope.”
>  
> I feel this is awkward phrasing and not clear what it means. How about:
> #1 “While this document considers in-network coding (i.e., re-coding within the network), it has a broader scope.”
>  
> We should then say what that broader scope has in addition to in-network coding. The only thing I would think of is source-coding only. But that is also included, formally speaking, in the in-network coding.
>  
> So how about:
> #2 “While this document considers in-network coding (i.e., re-coding within the network), it also includes source-only coding.”
>  
> Second suggested edit:
>  
> Page 9: “Rateless Coding can potentially generate an infinite number of Repair Symbols (in practice this number is only extremely large)”
>  
> Edit: “Rateless Coding can generate an unlimited number of Repair Symbols (in practice this number can be extremely large)”
>  
> Thanks,
> Victor
>  
>  
> _______________________________________________
> nwcrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>

---

From: <[email-masked]>
Date: Mon, 3 Jul 2017 09:10:07 +0000

Just a minor observation about the first re-phrasing. It can happen, for instance in satellite networks, that network coding is implemented in the network only between two nodes (e.g., satellite terminals and a gateway): in this case we don’t apply recoding and the we cannot either talk about e2e coding. How does this case map to the given definitions?

Tomaso

————————————————————————
Deutsches Zentrum für Luft- und Raumfahrt (DLR)
German Aerospace Center
Institute of Communications and Navigation | Satellite Networks | Oberpfaffenhofen | 82234 Wessling | Germany
Tomaso de Cola, Ph.D.
Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 | [email-masked]<mailto:[email-masked]>
http://www.dlr.de/kn/institut/abteilungen/san

From: nwcrg [mailto:[email-masked]] On Behalf Of Vincent Roca
Sent: Monday, July 03, 2017 10:07 AM
To: Firoiu, Victor (US)
Cc: [email-masked]
Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-03.txt

Hello Victor,

** Page.3:
NEW:

** Page 9:
NEW:

Cheers,

  Vincent

Le 30 juin 2017 à 19:50, Firoiu, Victor (US) <[email-masked]<mailto:[email-masked]>> a écrit :

So how about:

Second suggested edit:

Thanks,
Victor

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Vincent Roca <[email-masked]>
Date: Mon, 3 Jul 2017 13:20:31 +0200

Hi Tomaso,

This is a good point that is already caught by the official definition:

  End-to-End Coding:  A system where coding is performed at the source
           or (coding) middlebox, and decoding at the destination(s) or
           (decoding) middlebox.  There is no re-coding operation at
           intermediate nodes.

You’re right, to avoid confusion let’s drop the parenthesis altogether.

NEW:
   While this document considers
   Network Coding (i.e., re-coding within the network), it also
   considers End-to-End Coding.

Cheers,

  Vincent

> Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 | [email-masked] <mailto:[email-masked]> 
> http://www.dlr.de/kn/institut/abteilungen/san <http://www.dlr.de/kn/institut/abteilungen/san>
>  
> Le 30 juin 2017 à 19:50, Firoiu, Victor (US) <[email-masked] <mailto:[email-masked]>> a écrit :
>  
>