Subject: Re: [nwcrg] nwcrg Digest, Vol 45, Issue 3

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 3 Jul 2017 06:45:35 -0400

Well short would mean in this case lower than the application timeout.

This said I am not a proponent (or not) of rateless. I just want the text to be clear.
> On Jul 3, 2017, at 5:40 AM, [email-masked] wrote:
> 
> Send nwcrg mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.irtf.org/mailman/listinfo/nwcrg
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of nwcrg digest..."
> Today's Topics:
> 
>   1. Re: nwcrg Digest, Vol 45, Issue 1 (Harald Skinnemoen)
> 
> From: Harald Skinnemoen <[email-masked]>
> Subject: Re: [nwcrg] nwcrg Digest, Vol 45, Issue 1
> Date: July 3, 2017 at 5:40:07 AM EDT
> To: Marie-Jose Montpetit <[email-masked]>
> Cc: [email-masked]
> 
> 
> I am not sure about the “short” round trip time as “short” may not always refer to protocol timers, but to when information is needed. Specifically for application layer implementations if we consider that too. 
> 
> What about:
> 
> ".... Hence rateless coding should be limited to use cases where the packet loss rate is low, variable, and the round-trip time is not a problem for requesting repair packets.
> 
> 
> Best Regards
> 
> /Harald 
> 
>> On 3 Jul 2017, at 11:18, Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Well the rateless number of added packets could be large if the packet loss rate is also very large. In general it is not. The problem with rateless is more delay than redundancy. 
>> 
>> I would re-phrase it as:
>> 
>> Rateless Coding can in principle generate an unlimited number of Repair Symbols while theoretically this number can be very large in practice the problem with rateless coding is the added delay. In cases where the packet loss is high enough to trigger un-bounded numbers of redundancy packets applications will most likely time-out. Hence rateless coding should be limited to those use cases where the packet loss while variable is low and the round-trip time in short.
>> 
>> or something like that.
>> 
>>> On Jul 3, 2017, at 5:10 AM, [email-masked] <mailto:[email-masked]> wrote:
>>> 
>>> Send nwcrg mailing list submissions to
>>> 	[email-masked] <mailto:[email-masked]>
>>> 
>>> To subscribe or unsubscribe via the World Wide Web, visit
>>> 	https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>> or, via email, send a message with subject or body 'help' to
>>> 	[email-masked] <mailto:[email-masked]>
>>> 
>>> You can reach the person managing the list at
>>> 	[email-masked] <mailto:[email-masked]>
>>> 
>>> When replying, please edit your Subject line so it is more specific
>>> than "Re: Contents of nwcrg digest..."
>>> Today's Topics:
>>> 
>>>   1. Re: I-D Action:
>>>      draft-irtf-nwcrg-network-coding-taxonomy-03.txt (Vincent Roca)
>>>   2. Re: I-D Action:
>>>      draft-irtf-nwcrg-network-coding-taxonomy-03.txt ([email-masked] <mailto:[email-masked]>)
>>> 
>>> From: Vincent Roca <[email-masked] <mailto:[email-masked]>>
>>> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-03.txt
>>> Date: July 3, 2017 at 4:07:25 AM EDT
>>> To: "Firoiu, Victor (US)" <[email-masked] <mailto:[email-masked]>>
>>> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>>> 
>>> 
>>> Hello Victor,
>>> 
>>> Thanks for these suggestions. I’ve included them as follows:
>>> 
>>> ** Page.3:
>>> NEW:
>>>    This document IS NOT restricted to constructs that perform re-coding
>>>    within intermediate forwarding nodes.  While this document considers
>>>    Network Coding (i.e., re-coding within the network), it also
>>>    considers End-to-End Coding (i.e., source-only coding).
>>> 
>>> => I’ve preferred e2e as it is formally defined later on.
>>> 
>>> ** Page 9:
>>> NEW:
>>>    Rateless Coding can generate an
>>>    unlimited number of Repair Symbols (in practice this number
>>>    is extremely large) […]
>>> 
>>> 
>>> Does anybody have any quick comment (I’m not expecting any major change at
>>> this level)? Otherwise I’ll submit this -04 version at the end of the afternoon
>>> (European time) and will continue with IRTF process.
>>> 
>>> Cheers,
>>> 
>>>   Vincent
>>> 
>>> 
>>>> Le 30 juin 2017 à 19:50, Firoiu, Victor (US) <[email-masked] <mailto:[email-masked]>> a écrit :
>>>> 
>>>>  
>>>> Thanks, Vincent, this looks good.
>>>>  
>>>> A couple of comments and suggestions:
>>>>  
>>>> Page 3: “If network coding (i.e., re-coding within the network) is of course considered, this document has a broader scope.”
>>>>  
>>>> I feel this is awkward phrasing and not clear what it means. How about:
>>>> #1 “While this document considers in-network coding (i.e., re-coding within the network), it has a broader scope.”
>>>>  
>>>> We should then say what that broader scope has in addition to in-network coding. The only thing I would think of is source-coding only. But that is also included, formally speaking, in the in-network coding.
>>>>  
>>>> So how about:
>>>> #2 “While this document considers in-network coding (i.e., re-coding within the network), it also includes source-only coding.”
>>>>  
>>>> Second suggested edit:
>>>>  
>>>> Page 9: “Rateless Coding can potentially generate an infinite number of Repair Symbols (in practice this number is only extremely large)”
>>>>  
>>>> Edit: “Rateless Coding can generate an unlimited number of Repair Symbols (in practice this number can be extremely large)”
>>>>  
>>>> Thanks,
>>>> Victor
>>>>  
>>>>  
>>>> _______________________________________________
>>>> nwcrg mailing list
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>> 
>>> 
>>> 
>>> From: <[email-masked] <mailto:[email-masked]>>
>>> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-03.txt
>>> Date: July 3, 2017 at 5:10:07 AM EDT
>>> To: <[email-masked] <mailto:[email-masked]>>, <[email-masked] <mailto:[email-masked]>>
>>> Cc: <[email-masked] <mailto:[email-masked]>>
>>> 
>>> 
>>> Just a minor observation about the first re-phrasing. It can happen, for instance in satellite networks, that network coding is implemented in the network only between two nodes (e.g., satellite terminals and a gateway): in this case we don’t apply recoding and the we cannot either talk about e2e coding. How does this case map to the given definitions?
>>>  
>>> Tomaso
>>>  
>>> ———————————————————————— 
>>> Deutsches Zentrum für Luft- und Raumfahrt (DLR) 
>>> German Aerospace Center 
>>> Institute of Communications and Navigation | Satellite Networks | Oberpfaffenhofen | 82234 Wessling | Germany
>>> Tomaso de Cola, Ph.D. 
>>> Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 | [email-masked] <mailto:[email-masked]> 
>>> http://www.dlr.de/kn/institut/abteilungen/san <http://www.dlr.de/kn/institut/abteilungen/san>
>>>  
>>> From: nwcrg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Vincent Roca
>>> Sent: Monday, July 03, 2017 10:07 AM
>>> To: Firoiu, Victor (US)
>>> Cc: [email-masked] <mailto:[email-masked]>
>>> Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-03.txt
>>>  
>>> Hello Victor,
>>>  
>>> Thanks for these suggestions. I’ve included them as follows:
>>>  
>>> ** Page.3:
>>> NEW:
>>>    This document IS NOT restricted to constructs that perform re-coding
>>>    within intermediate forwarding nodes.  While this document considers
>>>    Network Coding (i.e., re-coding within the network), it also
>>>    considers End-to-End Coding (i.e., source-only coding).
>>>  
>>> => I’ve preferred e2e as it is formally defined later on.
>>>  
>>> ** Page 9:
>>> NEW:
>>>    Rateless Coding can generate an
>>>    unlimited number of Repair Symbols (in practice this number
>>>    is extremely large) […]
>>>  
>>>  
>>> Does anybody have any quick comment (I’m not expecting any major change at
>>> this level)? Otherwise I’ll submit this -04 version at the end of the afternoon
>>> (European time) and will continue with IRTF process.
>>>  
>>> Cheers,
>>>  
>>>   Vincent
>>>  
>>>  
>>> Le 30 juin 2017 à 19:50, Firoiu, Victor (US) <[email-masked] <mailto:[email-masked]>> a écrit :
>>>  
>>>  
>>> Thanks, Vincent, this looks good.
>>>  
>>> A couple of comments and suggestions:
>>>  
>>> Page 3: “If network coding (i.e., re-coding within the network) is of course considered, this document has a broader scope.”
>>>  
>>> I feel this is awkward phrasing and not clear what it means. How about:
>>> #1 “While this document considers in-network coding (i.e., re-coding within the network), it has a broader scope.”
>>>  
>>> We should then say what that broader scope has in addition to in-network coding. The only thing I would think of is source-coding only. But that is also included, formally speaking, in the in-network coding.
>>>  
>>> So how about:
>>> #2 “While this document considers in-network coding (i.e., re-coding within the network), it also includes source-only coding.”
>>>  
>>> Second suggested edit:
>>>  
>>> Page 9: “Rateless Coding can potentially generate an infinite number of Repair Symbols (in practice this number is only extremely large)”
>>>  
>>> Edit: “Rateless Coding can generate an unlimited number of Repair Symbols (in practice this number can be extremely large)”
>>>  
>>> Thanks,
>>> Victor
>>>  
>>>  
>>> _______________________________________________
>>> nwcrg mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>>  
>>> 
>>> 
>>> _______________________________________________
>>> nwcrg mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>> _______________________________________________
>> nwcrg mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg
> 
> 
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Vincent Roca <[email-masked]>
Date: Mon, 3 Jul 2017 13:29:00 +0200

Harald and Marie-José,

Since the I-D is just about taxonomy/terminology, let’s avoid adding Operations and Management considerations.
Where and how to use those codes will be left to use-case discussions for instance.
 
Cheers,

  Vincent

> Le 3 juil. 2017 à 12:45, Marie-Jose Montpetit <[email-masked]> a écrit :
> 
>> On Jul 3, 2017, at 5:40 AM, [email-masked] <mailto:[email-masked]> wrote:
>>