Subject: [nwcrg] NC architecture

From: Victor Firoiu <[email-masked]>
Date: Fri, 14 Jul 2017 13:34:29 -0400

Dear Netcoders,

Several recent posts have raised the interest in developing some
architecture framework, I would like to add my support to it. As mentioned
recently, it may be useful for some/many efforts (research and development)
to define a common set of principles and a framework, from where practical
protocols can be derived. This could help for example, to understand
behavior and applicability based on some models of common elements.

Some of you may remember our past discussions on architecture, that may
have delved too soon into some specific building blocks, etc.

Rather, I think we should establish first a baseline of interest from the
group:
- Is there interest in using such a common framework?
- Is there interest in researching such a common framework?
- Is practical interest only/mostly in end-to-end coding or is there
interest in in-network coding as well?

My personal opinion/ hypothesis is that we can have a common architecture
framework. But we don't know that yet, so this would be a topic of research:
- Can we have a common framework from which the existing practical protocol
prototypes can be defined?
- Or is there a fundamental difference or mismatch between protocol needs
that precludes such common framework?

Let us know your thoughts. And maybe we get to discuss a bit in the meeting
next week.

Cheers,

Victor

---

From: Hitoshi Asaeda <[email-masked]>
Date: Mon, 17 Jul 2017 08:42:18 +0200

Hello,

NC can be applied to different layers and various networks such as NC for wireless/satellite, NC for ICN/CCN, NC for SDN/NFV, etc. Their solutions can be independent or different. In this situation, discussing a "common framework" for NC may not be so useful or difficult to reach some goal.

I think if we need some common work, clarification of the research challenges for NC in various networks would be good. And then (or in parallel) we can start architectural discussions for each "NC for xxx".
I don’t know the level of this “xxx”; whether it should be the layer of networks or architectures/protocols as stated above, or other semantics such as “end-to-end” and “in-network”, though.

Regards,
--
Hitoshi Asaeda

> 2017/07/14 19:34, Victor Firoiu <[email-masked]> wrote:
> 
> Dear Netcoders,
> 
> Several recent posts have raised the interest in developing some architecture framework, I would like to add my support to it. As mentioned recently, it may be useful for some/many efforts (research and development) to define a common set of principles and a framework, from where practical protocols can be derived. This could help for example, to understand behavior and applicability based on some models of common elements.
> 
> Some of you may remember our past discussions on architecture, that may have delved too soon into some specific building blocks, etc.
> 
> Rather, I think we should establish first a baseline of interest from the group:
> - Is practical interest only/mostly in end-to-end coding or is there interest in in-network coding as well? 
> 
> My personal opinion/ hypothesis is that we can have a common architecture framework. But we don't know that yet, so this would be a topic of research:
> - Can we have a common framework from which the existing practical protocol prototypes can be defined? 
> - Or is there a fundamental difference or mismatch between protocol needs that precludes such common framework?
> 
> Let us know your thoughts. And maybe we get to discuss a bit in the meeting next week.
> 
> Cheers,
> 
> Victor
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Morten Videbæk Pedersen <[email-masked]>
Date: Mon, 17 Jul 2017 09:29:39 +0200

I agree with that assessment.

- M

On Jul 17, 2017, 08:42, at 08:42, Hitoshi Asaeda <[email-masked]> wrote:
>Hello,
>
>NC can be applied to different layers and various networks such as NC
>for wireless/satellite, NC for ICN/CCN, NC for SDN/NFV, etc. Their
>solutions can be independent or different. In this situation,
>discussing a "common framework" for NC may not be so useful or
>difficult to reach some goal.
>
>I think if we need some common work, clarification of the research
>challenges for NC in various networks would be good. And then (or in
>parallel) we can start architectural discussions for each "NC for xxx".
>I don’t know the level of this “xxx”; whether it should be the layer of
>networks or architectures/protocols as stated above, or other semantics
>such as “end-to-end” and “in-network”, though.
>
>Regards,
>--
>Hitoshi Asaeda
>
>
>
>
>
>architecture framework, I would like to add my support to it. As
>mentioned recently, it may be useful for some/many efforts (research
>and development) to define a common set of principles and a framework,
>from where practical protocols can be derived. This could help for
>example, to understand behavior and applicability based on some models
>of common elements.
>> 
>> Some of you may remember our past discussions on architecture, that
>may have delved too soon into some specific building blocks, etc.
>> 
>> My personal opinion/ hypothesis is that we can have a common
>architecture framework. But we don't know that yet, so this would be a
>topic of research:
>> - Or is there a fundamental difference or mismatch between protocol
>needs that precludes such common framework?
>>

---

From: Vincent Roca <[email-masked]>
Date: Mon, 17 Jul 2017 09:52:03 +0200

> Le 17 juil. 2017 à 09:29, Morten Videbæk Pedersen <[email-masked]> a écrit :
> 

… and this is the reason why we are focussing on use-cases for the moment (among other things).
Let’s gather feedbacks and gain knowledge on what is currently possible (and sometimes available),
and let’s talk about where we want to go as a RG.
Cheers,

  Vincent

---

From: "Firoiu, Victor (US)" <[email-masked]>
Date: Mon, 17 Jul 2017 18:38:07 +0000

Thank you. I think all our comments have a common base, let me try to summarize, and also clarify some thoughts.

- There is interest in some kind of common framework/architecture. Possibly several, to be determined/ researched. But the desire is to minimize their number.

- The desired approach is to take existing systems/ protocols that have been built/used and draw a common architecture. We'll also find if there is a fundamental reason that more than one is needed.

- I think we should make a distinction between use cases that mean applications (as in "NC for end-to-end over wireless"), and the protocol design. Given this distinction, the architecture would be drawn from the practical designs. It's likely that some very different uses cases/applications may have common designs. But this is all theoretical, the similarities will appear when we look at existing designs.

- Kernel vs user space should not be a primary concern (maybe not a concern at all).

- Getting feedback and gathering existing experience is the next step. Please let us know your thoughts.

Thanks,

Victor

---

From: Emmanuel Lochin <[email-masked]>
Date: Tue, 18 Jul 2017 10:02:19 +0200

> - There is interest in some kind of common framework/architecture. Possibly several, to be determined/ researched. But the desire is to minimize their number.

Hi Victor,

We have sketched an architecture/framework draft for an on-the-fly 
coding protocol availble here : 
https://datatracker.ietf.org/doc/draft-detchart-nwcrg-tetrys/
One possibility should be to extend it or it could be a good start for 
something a bit more generic.

EL

-- 
Emmanuel LOCHIN
Professeur ISAE
ISAE SUPAERO - Institut Supérieur de l'Aéronautique et de l'Espace
10 avenue Edouard Belin - BP 54032 - 31055 TOULOUSE CEDEX 4 FRANCE -
http://www.isae-supaero.fr
Tel +33 5 61 33 84 85 - Fax (+33) 5 61 33 83 45
Web : http://personnel.isae.fr/emmanuel-lochin/

---

From: Cedric Adjih <[email-masked]>
Date: Tue, 18 Jul 2017 16:14:30 +0200 (CEST)

Hi Victor, Emmanuel, netcoders,

Victor, I like your summary, and BTW, I think that previous efforts of documenting frameworks/architectures, e.g. 
  https://www.ietf.org/proceedings/91/slides/slides-91-nwcrg-0.pdf
can be used directly, and help us look at actual designs, e.g. the current step where "But this is all theoretical, the similarities will appear when we look at existing designs".

For instance, looking at the draft cited with Emmanuel, Tetrys, I see many parts that are common with several proposals (including dragoncast). 
Then we can look at similarities and differences (sometimes the devil is in the details) in functional blocks, in packet formats ( https://www.ietf.org/mail-archive/web/nwcrg/current/msg00295.html ), in signalling.

Sometimes it is sufficient to just cleanly decouple  some parts, to be able to extract a more widely usable building blocks.

best regards,
-- Cedric

----- Mail original -----
> De: "Emmanuel Lochin" <[email-masked]>
> À: [email-masked]
> Envoyé: Mardi 18 Juillet 2017 10:02:19
> Objet: Re: [nwcrg] NC architecture
> 
> > Thank you. I think all our comments have a common base, let me try to
> > summarize, and also clarify some thoughts.
> >
> > - There is interest in some kind of common framework/architecture. Possibly
> > several, to be determined/ researched. But the desire is to minimize their
> > number.
> 
> Hi Victor,
> 
> > - The desired approach is to take existing systems/ protocols that have
> > been built/used and draw a common architecture. We'll also find if there
> > is a fundamental reason that more than one is needed.
> >
> > - I think we should make a distinction between use cases that mean
> > applications (as in "NC for end-to-end over wireless"), and the protocol
> > design. Given this distinction, the architecture would be drawn from the
> > practical designs. It's likely that some very different uses
> > cases/applications may have common designs. But this is all theoretical,
> > the similarities will appear when we look at existing designs.
> >

---

From: "Firoiu, Victor (US)" <[email-masked]>
Date: Tue, 18 Jul 2017 16:21:05 +0000

Hi Cedric,

Thank you for reminding and the pointers. I agree with all you said below.
Concerto/Bravo is another fully designed and implemented protocol published and presented to this group,
http://www.ietf.org/proceedings/86/slides/slides-86-nwcrg-7.pdf

Victor

-----Original Message-----

best regards,
-- Cedric