Subject: [OAUTH-WG] OAuth 2.0 does not require parameter name oauth_token= while passing in authorization header

From: Jitesh Bhate <[email-masked]>
Date: Tue, 14 Dec 2010 16:52:08 -0500

While Integrating our Apis WITH CoTweet library

We found that OAuth 2.0 has changed (from oauth 1.0) the way Oauth token is passed in authorization header.

OAuth 2.0 does not

require the oauth_token= while passing in authorization header

http://tools.ietf.org/html/draft-ietf-oauth-v2-10#section-5.1.1

shouldn't following request 1) is more easy to parse as key value pairs than 2) ???

1)

GET /resource HTTP/1.1

Host: server.example.com

Authorization: OAuth oauth_token=vF9dft4qmT

2)
GET /resource HTTP/1.1
     Host: server.example.com
     Authorization: OAuth vF9dft4qmT

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 14 Dec 2010 13:54:30 -0800

I tend to agree.

Check the archives, there are recent discussions on this subject. The
exact format of the Authorization header is still debated, including
the scheme.

Marius

On Tue, Dec 14, 2010 at 1:52 PM, Jitesh Bhate <[email-masked]> wrote:
> shouldn’t following request 1) is more easy to parse as key value pairs than
> 2) ???
>
>
>
> 1)
>
> GET /resource HTTP/1.1
>
> Host: server.example.com
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>
>

---

From: Jitesh Bhate <[email-masked]>
Date: Tue, 14 Dec 2010 17:11:01 -0500

Thanks for your Response
I think I got one thread in archive 
http://www.ietf.org/mail-archive/web/oauth/current/msg04673.html

-----Original Message-----
From: Marius Scurtescu [mailto:[email-masked]] 
Sent: Tuesday, December 14, 2010 4:55 PM
To: Jitesh Bhate
Cc: [email-masked]
Subject: Re: [OAUTH-WG] OAuth 2.0 does not require parameter name oauth_token= while passing in authorization header

I tend to agree.

Marius

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 14 Dec 2010 14:32:14 -0800

Also look for the thread with subject "OAuth 2.0 Bearer Token
specification draft -01".

Marius