Subject: [OAUTH-WG] Device Flow Implementations

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Thu, 4 Jan 2018 08:27:42 -0500

All,

As part of the write-up for the Device Flow document, we are looking for
information about implementation for this document.
https://datatracker.ietf.org/doc/draft-ietf-oauth-device-flow/

We are aware of 3 implementations for this document by: Google, Facebook,
and Microsoft.

Are people aware of any other implementation?

Regards,
 Rifaat

---

From: Simon Moffatt <[email-masked]>
Date: Thu, 4 Jan 2018 15:53:03 +0000

ForgeRock has implemented this for the last several releases with it's
Access Management / OpenAM product.

Several of our global customers have deployed live with million+ devices
in some projects.

Latest documentation available here -
https://backstage.forgerock.com/docs/am/5.5/oauth2-guide/#rest-api-oauth2-device-flow

Regards Simon

On 04/01/18 13:27, Rifaat Shekh-Yusef wrote:
> All,
>
> As part of the write-up for the Device Flow document, we are looking
> for information about implementation for this document.
> We are aware of 3 implementations for this document by: Google,
> Facebook, and Microsoft.
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

-- 
ForgeRock <http://www.forgerock.com/> 	*Simon Moffatt*
Technical Director | Product Management | ForgeRock
*tel* +44 (0) 7903 347 240  |  *e* [email-masked]
<mailto:[email-masked]>
*skype* simon.moffatt  |  *web* www.forgerock.com
<http://www.forgerock.com/>  |  *twitter* @simonmoffatt

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Thu, 4 Jan 2018 11:03:27 -0500

Thanks Simon!

On Thu, Jan 4, 2018 at 10:53 AM, Simon Moffatt <[email-masked]>
wrote:

> Latest documentation available here - https://backstage.forgerock.
> com/docs/am/5.5/oauth2-guide/#rest-api-oauth2-device-flow
>
> Regards Simon
>
> OAuth mailing [email-masked]://www.ietf.org/mailman/listinfo/oauth
>
>
> --
>  <http://www.forgerock.com/> *Simon Moffatt*
> *tel* +44 (0) 7903 347 240 <+44%207903%20347240>  |  *e*
> [email-masked] <[email-masked]>
> *skype* simon.moffatt  |  *web* www.forgerock.com  |  *twitter*
> @simonmoffatt
>

---

From: Chuck Mortimore <[email-masked]>
Date: Thu, 4 Jan 2018 08:30:29 -0800

Salesforce has an implementation:
https://releasenotes.docs.salesforce.com/en-us/spring17/release-notes/rn_security_auth_device_flow.htm

- cmort

On Jan 4, 2018, at 5:27 AM, Rifaat Shekh-Yusef <[email-masked]>
wrote:

All,

Regards,
 Rifaat

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Thu, 4 Jan 2018 12:45:18 -0500

Thanks Chuck!

On Thu, Jan 4, 2018 at 11:30 AM, Chuck Mortimore <[email-masked]>
wrote:

> Salesforce has an implementation:   https://releasenotes.docs.
> salesforce.com/en-us/spring17/release-notes/rn_security_
> auth_device_flow.htm
>
> - cmort
>

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Thu, 4 Jan 2018 15:03:07 -0500

Thanks Daniel!

On Thu, Jan 4, 2018 at 2:56 PM, Daniel Lindau <[email-masked]>
wrote:

>
> Hi,
>
> The Curity Identity Server has implemented it since the 2.3 release in
> december.
>
> https://www.curity.io/product/
>
>
> Regards,
> *Daniel Lindau*
> Solutions Architect
> Identity Specialist
> Curity AB
> -------------------------------------------------
> Sankt Eriksgatan 46A, Stockholm, Sweden
> <https://maps.google.com/?q=Sankt+Eriksgatan+46A,+Stockholm,+Sweden&entry=gmail&source=g>
> +46 73-8027871 <+46%2073%20802%2078%2071>
> [email-masked]
> https://curity.io
>
> tors 4 jan. 2018 kl 18:06 skrev Daniel Lindau <[email-masked]>:
>
>>
>> ---------- Vidarebefordrat meddelande ---------
>> Från: Rifaat Shekh-Yusef <[email-masked]>
>> Datum: tors 4 jan. 2018 kl. 14:27
>> Ämne: [OAUTH-WG] Device Flow Implementations
>> Till: oauth <[email-masked]>
>>
>>
>> All,
>>
>> Regards
>> *Daniel Lindau*
>> Solutions Architect
>> Twobo Technologies AB
>> ---------------------------------------------
>> Sankt Eriksgatan 46A, Stockholm, Sweden
>> <https://maps.google.com/?q=Sankt+Eriksgatan+46A,+Stockholm,+Sweden&entry=gmail&source=g>
>> +46 73-8027871 <+46%2073%20802%2078%2071>
>> [email-masked]
>> www.twobo.com
>>
>>
>
> --
> Daniel Lindau
> Solutions Architect
> Identity Specialist
> Curity AB
> -------------------------------------------------
> Sankt Eriksgatan 46A, Stockholm, Sweden
> <https://maps.google.com/?q=Sankt+Eriksgatan+46A,+Stockholm,+Sweden&entry=gmail&source=g>
> +46 73-8027871 <+46%2073%20802%2078%2071>
> [email-masked]
> https://curity.io
>

---

From: Justin Richer <[email-masked]>
Date: Fri, 5 Jan 2018 15:58:44 -0500

MITREid Connect (open source) has a server implementation as per version 1.3, released early in 2017. I know of at least one active production deployment that uses this flow with our server.

 — Justin

> On Jan 4, 2018, at 8:27 AM, Rifaat Shekh-Yusef <[email-masked]> wrote:
> 
> All,
> 
> As part of the write-up for the Device Flow document, we are looking for information about implementation for this document.
> https://datatracker.ietf.org/doc/draft-ietf-oauth-device-flow/ <https://datatracker.ietf.org/doc/draft-ietf-oauth-device-flow/>
> 
> 
> We are aware of 3 implementations for this document by: Google, Facebook, and Microsoft.
>

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Fri, 5 Jan 2018 16:45:37 -0500

Thanks Justin!

Do you have links with more details about these implementations?

Regards,
 Rifaat

On Fri, Jan 5, 2018 at 3:58 PM, Justin Richer <[email-masked]> wrote:

> MITREid Connect (open source) has a server implementation as per version
> 1.3, released early in 2017. I know of at least one active production
> deployment that uses this flow with our server.
>
>  — Justin
>

---

From: Justin Richer <[email-masked]>
Date: Fri, 5 Jan 2018 16:58:27 -0500

Just a link to the main project page, we don’t have a separate page for the device flow:

https://github.com/mitreid-connect/OpenID-Connect-Java-Spring-Server <https://github.com/mitreid-connect/OpenID-Connect-Java-Spring-Server>

 — Justin

> On Jan 5, 2018, at 4:45 PM, Rifaat Shekh-Yusef <[email-masked]> wrote:
> 
> Thanks Justin!
> 
> On Fri, Jan 5, 2018 at 3:58 PM, Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jan 4, 2018, at 8:27 AM, Rifaat Shekh-Yusef <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> All,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 8 Jan 2018 09:47:05 +0000

Rifaat, do we have these links already?
https://developers.google.com/identity/protocols/OAuth2ForDevices

Some time ago we were also made aware of the work of the European Broadcasting Union (EBU), see
https://tech.ebu.ch/groups/CPA
https://www.ietf.org/mail-archive/web/oauth/current/msg15969.html
They also use the OAuth Device Flow and have implementations.

Ciao
Hannes

From: OAuth [mailto:[email-masked]] On Behalf Of Rifaat Shekh-Yusef
Sent: 04 January 2018 14:28
To: oauth
Subject: [OAUTH-WG] Device Flow Implementations

All,

Regards,
 Rifaat

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Mon, 8 Jan 2018 10:26:11 -0500

Hi Hannes,

Yes, I have the Google and EBU links.

Regards,
 Rifaat

On Mon, Jan 8, 2018 at 4:47 AM, Hannes Tschofenig <[email-masked]

> *From:* OAuth [mailto:[email-masked]] *On Behalf Of *Rifaat
> Shekh-Yusef
> *Sent:* 04 January 2018 14:28
> *To:* oauth
> *Subject:* [OAUTH-WG] Device Flow Implementations
>
>
>
> All,
>
>
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>