Subject: [OAUTH-WG] [Editorial Errata Reported] RFC6749 (6613)

From: RFC Errata System <[email-masked]>
Date: Thu, 17 Jun 2021 12:04:37 -0700 (PDT)

The following errata report has been submitted for RFC6749,
"The OAuth 2.0 Authorization Framework".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6613

--------------------------------------
Type: Editorial
Reported by: Daniel Barclay <[email-masked]>

Section: 3.3

Original Text
-------------
The value of the scope parameter is expressed as a list of space-delimited, case-sensitive strings

Corrected Text
--------------
The value of the scope parameter is expressed as a space-delimited list of case-sensitive strings

Notes
-----
The original/current seems to be a bit confusing.

The value is not a collection of space-delimited strings (whatever a "space-delimited string" would be), but it a space-delimited (representation of) a collection of strings.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6749 (draft-ietf-oauth-v2-31)
--------------------------------------
Title               : The OAuth 2.0 Authorization Framework
Publication Date    : October 2012
Author(s)           : D. Hardt, Ed.
Category            : PROPOSED STANDARD
Source              : Web Authorization Protocol
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 22 Jun 2021 17:01:24 -0700

This looks correct to me; could the authors/WG please confirm?

Thanks,

Ben

---

From: Justin Richer <[email-masked]>
Date: Fri, 25 Jun 2021 11:38:58 -0400

I personally agree with this report, the new proposed wording is better.

OAuth 2.1 editors, please take note!

 — Justin

> On Jun 22, 2021, at 8:01 PM, Benjamin Kaduk <[email-masked]> wrote:
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth