Subject: [OAUTH-WG] [Editorial Errata Reported] RFC7519 (6622)

From: RFC Errata System <[email-masked]>
Date: Fri, 25 Jun 2021 04:50:46 -0700 (PDT)

The following errata report has been submitted for RFC7519,
"JSON Web Token (JWT)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6622

--------------------------------------
Type: Editorial
Reported by: Padmanarayanan SR <[email-masked]>

Section: 11

Original Text
-------------
All the security considerations in the JWS specification also apply
   to JWT, as do the JWE security considerations when encryption is
   employed.  In particular, Sections <a href="#section-10.12">10.12</a>

Corrected Text
--------------
All the security considerations in the JWS specification also apply
   to JWT, as do the JWE security considerations when encryption is
   employed.  In particular, Sections <a href="/doc/html/rfc7515#section-10.12">10.12</a>

Notes
-----
The link appears to be broken. It is intended to point to rfc7515#section-10.12 whereas it is pointing to the non-existent section of the same document.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7519 (draft-ietf-oauth-json-web-token-32)
--------------------------------------
Title               : JSON Web Token (JWT)
Publication Date    : May 2015
Author(s)           : M. Jones, J. Bradley, N. Sakimura
Category            : PROPOSED STANDARD
Source              : Web Authorization Protocol
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: "John R. Levine" <[email-masked]>
Date: 25 Jun 2021 13:20:03 -0400

Htmlized legacy RFCs are created by a script that uses heuristics to add 
formatting to the canonical text document.  One of the limitations of the
script is that it does not know when a section link is to another 
document.

For RFCs published since we switched to XML v3 two years ago, the HTML is 
created directly from the XML and the links are correct.

Since the underlying RFC is correct and currrent RFCs don't have the 
problem we're not planning to try to fix it.

Regards,
John Levine, temporary RFC series manager

> The following errata report has been submitted for RFC7519,

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly