Subject: [ogpx] OGPX BoF Approved for Stockholm

From: Infinity Linden <[email-masked]>
Date: Thu, 11 Jun 2009 12:03:39 -0700

Hey everyone...

I just wanted to let you all know that the BoF for the OGPX has been
approved. You can even see it on the wiki at
http://trac.tools.ietf.org/bof/trac/wiki .

I do want to remind people that this is the time to suggest charter
modifications. I think we have a pretty good charter right now, but
i've received some suggestions for improvement... mostly how to make
some of the text clearer, so i'll be posting  few updates later today.
Interested readers may wish to review the existing draft charter at
http://www.ietf.org/mail-archive/web/ogpx/current/msg00005.html .

See you all in Stockholm!
Meadhbh Hamrick

---

From: Christian Scholz <[email-masked]>
Date: Fri, 12 Jun 2009 12:39:35 +0200

Hi!

Will there also be an MMOX BoF?

-- Christian

Infinity Linden schrieb:
> _______________________________________________
> ogpx mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ogpx

-- 
COM.lounge GmbH
http://comlounge.net
Hanbrucher Strasse 33, 52064 Aachen
Amtsgericht Aachen HRB 15170
Geschäftsführer: Dr. Ben Scheffler, Christian Scholz

email: [email-masked]
fon: +49-241-4007300
fax: +49-241-97900850

personal email: [email-masked]
personal blog: http://mrtopf.de/blog
personal podcasts: http://openweb-podcast.de, http://datawithoutborders.net

---

From: Infinity Linden <[email-masked]>
Date: Fri, 12 Jun 2009 08:54:25 -0700

i don't think so. or rather, i didn't request one.

having participated in the attempt to get agreement for a working
group with a broad focus and failed, i'm not concentrating my efforts
on ogpx, where it seems there is sufficient agreement to work out the
differences between OGP implementations.

the mmox mailing list remains as a venue to continue the discussion of
the formation of a working group with broader focus, but having
experienced the tumult that is trying to get radically different
approaches to virtual worlds interoperability to agree on a common
basis for discussion, it seems that the person who attempts to do this
will find they have a great amount of work in their future.

-cheers
-meadhbh

---

From: Charles Krinke <[email-masked]>
Date: Fri, 12 Jun 2009 09:03:04 -0700 (PDT)

I would like to see if we concur on a few points, if I may. And I am not trying to stir up controversy, but rather understand some of the feelings of where this will eventually go.

As I understand where ogp *might* go, it will be a protocol that will allow two seperate virtual worlds to eventually, as peers, both run a sete of master servers currently called domain servers, I believe.

In that case, each world will be able, as a peer, to negotiate via packets, the interop from worldA to worldB (or from worldB to worldA).

That is, we are not contemplating that there is only one domain server at SecondLife, but that, say, OSGrid could run its own domain server and have reciprocity?

Charles

---

From: Meadhbh Siobhan <[email-masked]>
Date: Fri, 12 Jun 2009 09:23:36 -0700

essentially yes, you're spot on.
one of the core concepts of OGP is that it separates the "agent domain" from
the "region domain". so if you have a collection of users, you're
essentially an agent domain. if you have a collection of simulators, you're
a region domain. if you have both, you're simultaneously an agent and region
domain. you can be both, but you don't have to be. and if you're writing
software that conforms to OGP, you're supposed to allow agent and region
services to be offered by different organizations.

so yes, some day we hope to see someone whose account is owned by linden lab
teleport over to OSGrid server and conversely an avatar defined on an OSGrid
server teleport over agni (the main Second Life grid.) All without having to
log out of one grid and log back in on another. last summer, our interop
test allowed avatars whose account was defined in our beta grid's agent
domain to teleport to a remote region running a modified instance of
OpenSim. Word from Zha is that IBM has an agent domain whose code will get
published after a legal review.

so right. we envisioning a future where the relationships between service
providers are peer-like (like the peering arrangements of large ISPs.) and
to a large degree, OGP is an attempt to define a protocol that can support
this model.

-cheers
-meadhbh

On Fri, Jun 12, 2009 at 9:03 AM, Charles Krinke <[email-masked]> wrote:

> I would like to see if we concur on a few points, if I may. And I am not
> trying to stir up controversy, but rather understand some of the feelings of
> where this will eventually go.
>
> As I understand where ogp *might* go, it will be a protocol that will allow
> two seperate virtual worlds to eventually, as peers, both run a sete of
> master servers currently called domain servers, I believe.
>
> In that case, each world will be able, as a peer, to negotiate via packets,
> the interop from worldA to worldB (or from worldB to worldA).
>
> That is, we are not contemplating that there is only one domain server at
> SecondLife, but that, say, OSGrid could run its own domain server and have
> reciprocity?
>
> Charles
>

---

From: David W Levine <[email-masked]>
Date: Fri, 12 Jun 2009 12:55:26 -0400

The way I'd describe it is:

OGP  if fully articulated will define

1) A low level distributed computing approach  (Caps, LLSD, X.509, and 
event queue plumbing)
2) A bunch of virtual worlds building bocks (Prim formats,  Inventory, 
Assets, Region description, policy languages) 
3) A set of rules on how to manage services which share, and don't share 
trust (Domains)
4) A set of computational services delivered over 1 and 2 which can be 
used to build out collections of services described by 3
5) A specific structure of 4) which represents Linden Lab's best take on a 
useful way to partition the problem space. This defines regions, which 
live in region domains, and agent services which live in an agent domain. 

Nothing in OGP defines how people's policies between deployments will be 
set (nor should it, that's how you run your service) I expect there will 
be far more regions than agent domains, and I expect we will find
lots of regions that implement some combination of OGP and Hypergrid, or 
similar schemes. 

I would observes, that irrespective of using OGP, Hypergrid, or some other 
scheme, that it would be really quite nice if we could make sure that 1, 
2,  and 3 can be shared.  This would enhance the overall health of the 
ecosystem that is developing around these closely related technologies. 

- David
~ Zha

Charles Krinke <[email-masked]> 
Sent by: [email-masked]
06/12/2009 12:03 PM

To
[email-masked]
cc

Subject
[ogpx] ogpx focus?

I would like to see if we concur on a few points, if I may. And I am not 
trying to stir up controversy, but rather understand some of the feelings 
of where this will eventually go.

As I understand where ogp *might* go, it will be a protocol that will 
allow two seperate virtual worlds to eventually, as peers, both run a sete 
of master servers currently called domain servers, I believe.

In that case, each world will be able, as a peer, to negotiate via 
packets, the interop from worldA to worldB (or from worldB to worldA).

Charles_______________________________________________
ogpx mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ogpx

---

From: Charles Krinke <[email-masked]>
Date: Fri, 12 Jun 2009 10:00:42 -0700 (PDT)

Ok, great. That is what I remembered, so let me go on with my slightly *wild* idea.

OSGrid has been used for OGP testing in the past as we know. It is being used for HyperGrid testing now. And, I have encouraged ModRex testing with the ModRex folks.

So, ... One of my personal visions is to see all of this and more on various regions on OSGrid being tested, used, developed, debugged.

With that said, I would like to encourage any OGP testing of OpenSim regions on OSGrid as we move forward.

Charles

________________________________
From: Meadhbh Siobhan <[email-masked]>
To: Charles Krinke <[email-masked]>
Cc: [email-masked]
Sent: Friday, June 12, 2009 9:23:36 AM
Subject: Re: [ogpx] ogpx focus?

one of the core concepts of OGP is that it separates the "agent domain" from the "region domain". so if you have a collection of users, you're essentially an agent domain. if you have a collection of simulators, you're a region domain. if you have both, you're simultaneously an agent and region domain. you can be both, but you don't have to be. and if you're writing software that conforms to OGP, you're supposed to allow agent and region services to be offered by different organizations.

so yes, some day we hope to see someone whose account is owned by linden lab teleport over to OSGrid server and conversely an avatar defined on an OSGrid server teleport over agni (the main Second Life grid.) All without having to log out of one grid and log back in on another. last summer, our interop test allowed avatars whose account was defined in our beta grid's agent domain to teleport to a remote region running a modified instance of OpenSim. Word from Zha is that IBM has an agent domain whose code will get published after a legal review.

so right. we envisioning a future where the relationships between service providers are peer-like (like the peering arrangements of large ISPs.) and to a large degree, OGP is an attempt to define a protocol that can support this model.

-cheers
-meadhbh

Charles

---

From: Meadhbh Siobhan <[email-masked]>
Date: Fri, 12 Jun 2009 15:50:25 -0700

erg. don't type before you drink your first cup of coffee.
please change the phrase " i'm not concentrating my efforts on ogpx" to " i
am concentrating my efforts on ogpx".
-cheers
-meadhbh

---

From: David W Levine <[email-masked]>
Date: Sat, 13 Jun 2009 10:35:22 -0400

My current focus is also on OGPX.  I'd be perfectly willing to chat about 
broader issues. (Try and stop me!) but.. not during the OGPX bof, or on 
the OGPX mailing list to any great degree. I can't say there are *any* 
hints of a community which is willing to invest in MMOX work at the 
moment. Such a community would have to get together, and talk to the IETF 
area directors, and show real energy on draft specs, etc. 

- David
~ Zha

Meadhbh Siobhan <[email-masked]> 
Sent by: [email-masked]
06/12/2009 06:50 PM

To
Infinity Linden <[email-masked]>
cc
[email-masked]
Subject
Re: [ogpx] OGPX BoF Approved for Stockholm

please change the phrase " i'm not concentrating my efforts on ogpx" to 
" i am concentrating my efforts on ogpx".

-cheers
-meadhbh

On Fri, Jun 12, 2009 at 8:54 AM, Infinity Linden <[email-masked]> 
wrote:
i don't think so. or rather, i didn't request one.

-cheers
-meadhbh

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 14 Jun 2009 10:06:18 +0200

I would suggest that the future WG does not forget the operational
deployment and manageability issues. How are services identified and
observed, how can an operator have a view of what services are dunning
and what resources they are consuming, how congestion of resources and
health status of the applications and services are being presented and
reported?
 
Dan
(OPS co-AD)

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of David W Levine
	Sent: Friday, June 12, 2009 7:55 PM
	To: Charles Krinke
	Cc: [email-masked]; [email-masked]
	Subject: Re: [ogpx] ogpx focus?

	
	1) A low level distributed computing approach  (Caps, LLSD,
X.509, and event queue plumbing) 
	2) A bunch of virtual worlds building bocks (Prim formats,
Inventory, Assets, Region description, policy languages) 
	3) A set of rules on how to manage services which share, and
don't share trust (Domains) 
	4) A set of computational services delivered over 1 and 2 which
can be used to build out collections of services described by 3 
	5) A specific structure of 4) which represents Linden Lab's best
take on a useful way to partition the problem space. This defines
regions, which live in region domains, and agent services which live in
an agent domain. 
	
	Nothing in OGP defines how people's policies between deployments
will be set (nor should it, that's how you run your service) I expect
there will be far more regions than agent domains, and I expect we will
find 
	lots of regions that implement some combination of OGP and
Hypergrid, or similar schemes. 
	
	I would observes, that irrespective of using OGP, Hypergrid, or
some other scheme, that it would be really quite nice if we could make
sure that 1, 2,  and 3 can be shared.  This would enhance the overall
health of the ecosystem that is developing around these closely related
technologies. 
	
	- David 
	~ Zha 

	

06/12/2009 12:03 PM 

To
[email-masked] 
cc
Subject
[ogpx] ogpx focus?

	I would like to see if we concur on a few points, if I may. And
I am not trying to stir up controversy, but rather understand some of
the feelings of where this will eventually go.
	
	As I understand where ogp *might* go, it will be a protocol that
will allow two seperate virtual worlds to eventually, as peers, both run
a sete of master servers currently called domain servers, I believe.
	
	In that case, each world will be able, as a peer, to negotiate
via packets, the interop from worldA to worldB (or from worldB to
worldA).
	
	That is, we are not contemplating that there is only one domain
server at SecondLife, but that, say, OSGrid could run its own domain
server and have reciprocity?
	
	Charles_______________________________________________
	ogpx mailing list
	[email-masked]
	https://www.ietf.org/mailman/listinfo/ogpx
<https://www.ietf.org/mailman/listinfo/ogpx>