Subject: Re: [ogpx] refined idea for documents..

From: Vaughn Deluca <[email-masked]>
Date: Sat, 3 Oct 2009 13:55:11 +0200

In an attempt to add more details in the deployment patterns I started to do
some homework. I found this:
http://wiki.secondlife.com/wiki/OGP_Teleport_Draft_3

Is there a newer version of this document? Is it more or less safe to use
this as an starting point of my thinking about OGP/VWRAP?

-Vaughn

On Mon, Sep 28, 2009 at 3:33 PM, Meadhbh Siobhan
<[email-masked]>wrote:

> okay. discuss away!
>
> On Mon, Sep 28, 2009 at 12:26 AM, Morgaine
> <[email-masked]> wrote:
> > A good way of proceeding would be to discuss David's deployment patterns
> > first, before cranking out a new intro document.  After all, there is a
> lot
> > of good material there, hinting at many useful use cases.  Then any new
> > document would have a chance of reflecting the viewpoints of the group so
> > far, and building on the consensus.
> >
> > Ref:  http://tools.ietf.org/html/draft-levine-ogp-layering-00
> >
> >
> > Morgaine.
> >
> >
> >
> >
> >
> >
> > ======================================
> >
> > On Sun, Sep 27, 2009 at 4:11 PM, Infinity Linden <[email-masked]
> >
> > wrote:
> >>
> >> yup. we're actually in the process of adding the deployment pattern
> >> stuff to the intro doc. great minds think alike!
> >>
> >> On Sun, Sep 27, 2009 at 7:16 AM, Vaughn Deluca <[email-masked]
> >
> >> wrote:
> >> > On Thu, Sep 3, 2009 at 8:49 PM, Infinity
> >> > Linden <[email-masked]> wrote:
> >> >>
> >> >> hey peeps...
> >> >>
> >> >> i was thinking about it, and came up with a slightly different list
> of
> >> >> documents:
> >> >>
> >> >> * intro and goals (used to be called intro and requirements)
> >> >> * abstract type system (used to be called LLSD)
> >> >> * foundations
> >> >> * the VWRAP trust/security model
> >> >> * virtual world description format
> >> >> * client application launch message
> >> >> * agent presence establishment
> >> >> * avatar format
> >> >> * asset format and access
> >> >> * chat/voice establishment
> >> >> * user profile access
> >> >> * time sensitive messages
> >> >>
> >> >> [snip]
> >> >>
> >> >> * intro and goals ( based on
> >> >> http://tools.ietf.org/html/draft-hamrick-ogp-intro-00 )
> >> >>  * social context of virtual worlds - why they're interesting
> >> >>  * very high level description of virtual world characteristics - not
> >> >> what a virtual world "is" as much as features of a virtual world you
> >> >> may not have thought about.
> >> >>  * how VWRAP virtual worlds differ from other virtual worlds - how
> >> >> OpenSim and SecondLife differ on a technology level from WoW
> >> >>  * protocol objectives and goals - specific features of the protocol
> >> >>
> >> >>  * this doc is it's own document because we think there's a need for
> >> >> a lot of background, and it's mostly non-technical.
> >> >
> >> > [snip ]
> >> > I would suggest to add some stuff
> >> > from http://tools.ietf.org/html/draft-levine-ogp-layering
> >> > The use cases given there would come a long way to clarify the current
> >> > confusion over what we can call a virtual world and what the main seat
> >> > of
> >> > policy is in these cases.
> >> > Vaughn
> >> _______________________________________________
> >> ogpx mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/ogpx
> >
> >
> > _______________________________________________
> > ogpx mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ogpx
> >
> >
>

---

From: Infinity Linden <[email-masked]>
Date: Sat, 3 Oct 2009 09:27:53 -0700

yup vaughn. that's the teleport draft we made after the 2008 interop
tests. if i remember correctly, we didn't modify the code on vaak to
follow this draft. and... we found a few things we wanted to change
from this draft over the last year.

but i think that about 99% of what's in the text on the wiki is going
to show up in the teleport internet draft. stuff we've said we want to
add includes discussion on policy and where policy enforcement points
might be, as well as being slightly more clear where region caps for
teleport come from and the relationship between teleport caps (that
are given to agent domains the region trusts) and long lived
information URLs (that may or may not be capabilities) with public
information about the region.

-cheers
-meadhbh

On Sat, Oct 3, 2009 at 4:55 AM, Vaughn Deluca <[email-masked]> wrote:
> On Mon, Sep 28, 2009 at 3:33 PM, Meadhbh Siobhan <[email-masked]>
> wrote:
>>
>> okay. discuss away!
>>
>> > On Sun, Sep 27, 2009 at 4:11 PM, Infinity Linden
>> > <[email-masked]>
>> > wrote:
>> >>
>> >> On Sun, Sep 27, 2009 at 7:16 AM, Vaughn Deluca
>> >> <[email-masked]>
>> >> wrote:

---

From: David W Levine <[email-masked]>
Date: Sat, 3 Oct 2009 12:32:21 -0400

I think you can also expect some updates to that draft based on my group's 
experience with implmenting  an Agent Domain this past year. In 
particular, some feedback on extension patterns. 

- David

Infinity Linden <[email-masked]> 
Sent by: [email-masked]
10/03/2009 12:27 PM

To
Vaughn Deluca <[email-masked]>
cc
Meadhbh Siobhan <[email-masked]>, [email-masked]
Subject
Re: [ogpx] refined idea for documents..

-cheers
-meadhbh

> On Mon, Sep 28, 2009 at 3:33 PM, Meadhbh Siobhan 
<[email-masked]>
>> > document would have a chance of reflecting the viewpoints of the 
group
>> > so

---

From: Infinity Linden <[email-masked]>
Date: Sat, 3 Oct 2009 09:34:28 -0700

ack. totally forgot. some of the refinements i was talking about
above, made it into this draft:

http://secondlifegrid.net.s3.amazonaws.com/docs/specs/OGP-Teleport_Draft_5.html

which also reminds me, i think the following page has references to
the most up to date pre-IETF drafts:

http://wiki.secondlife.com/wiki/Open_Grid_Protocol

and we have some diagrams on this page:

http://wiki.secondlife.com/wiki/OGP_Explained

not all of the diagrams are up to date (especially authentication,
which has changed A LOT) but it should give you some ideas about the
flows.

-cheers
-meadhbh / infinity

---

From: Vaughn Deluca <[email-masked]>
Date: Sat, 3 Oct 2009 19:51:08 +0200

Thanks for the pointers!*starts studying*