Subject: pointers to openpgp-interop knowledge base?

From: John J Kane <[email-masked]>
Date: Sat, 03 Nov 2001 13:06:12 -0500

Are there any sources online for the following?

  * contact info for people involved in interop testing
  * examples of non-conformant output (for testing)
  * examples of conformant output which have been
    documented to break certain implementations

Should a page be set up to host this information?

--
JJK

---

From: Brian Smith <[email-masked]>
Date: Sun, 4 Nov 2001 00:47:51 -0000

http://www.openpgp.org/technical/interoperability/

However, the information there is pretty limited.  If anyone has
contributions of the types described below, send them to me and I'll see
that they're added to the site.

Brian Smith
Hush Communications

>  -----Original Message-----
> From: 	John J Kane [mailto:[email-masked]] 
> Sent:	03 November 2001 18:06
> To:	[email-masked]
> Subject:	pointers to openpgp-interop knowledge base?
> 
> ________________________________________________________
> 
> This message has NOT been ENCRYPTED and has NOT been SIGNED
> ________________________________________________________
> 
>

---

From: [email-masked]
Date: Mon, 05 Nov 2001 11:21:57 +0200

Len Sassamanwrote:
> 
> GnuPG of any version produces messages signed with v3 keys encrypted in v3
> format that PGP cannot decrypt.

except PGP 2.6.3ia-multi05,
I modified it so that it can decrypt/verify these GnuPG produced non OpenPGP compliant messages.

> In the implementation nits, it is noted that PGP 5.x cannot verify v4 sigs
> on non-v4 material. Actually, 6.x cannot either, but 7.x and greater can.

even PGP 7.x have problems with v4 sigs.
it can verify v4 clearsignatures and detached signatures but not one pass signatures.

PGP 6.5.8ckt06 can verify all v4 signatures.

> Then there's the ElGamal signing-keys that GnuPG generates. I don't know
> what else supports them.

PGP 6.5.8ckt06 does.

__
Disastry  http://disastry.dhs.org/
http://disastry.dhs.org/pgp <----PGP plugins for Netscape and MDaemon
 ^--GPG for Win32 (supports loadable modules and IDEA)
 ^----PGP 2.6.3ia-multi05 (supports IDEA, CAST5, BLOWFISH, TWOFISH,
      AES, 3DES ciphers and MD5, SHA1, RIPEMD160, SHA2 hashes)