Subject: Re: ASN.1 OID for TIGER/192

From: [email-masked]
Date: Mon, 30 Sep 2002 10:17:49 +0200

Brian M. Carlson wrote:
>
> On Fri, Sep 27, 2002 at 08:55:50AM -0400, David Shaw wrote:
> >
> > Hello,
> >
> > In 2440 and in all the 2440bis drafts, the TIGER/192 hash is not fully
> > usable as it has no OID.  Werner Koch and I, with the cooperation of
> > TIGER's authors, recently arranged an OID for it:

finally :)

> >       1.3.6.1.4.1.11591.12.2

so the full ASN string is:
  0x30, 0x29, 0x30, 0x0D, 0x06, 0x09, 0x2B, 0x06, 0x01, 0x04,
  0x01, 0xDA, 0x47, 0x0C, 0x02, 0x05, 0x00, 0x04, 0x18
right?

I'm going to change PGP 2.6.3ia-multi06 to support this.

> > It would be good to put this in 2440bis so TIGER will be usable.
>
> I agree. All we have left now is to get one for HAVAL-5-160.

so do I (, and HAVAL-5-256...)

> > I have a sneaking suspicion that this may raise the question whether
> > TIGER should be in the standard at all, as so long as it did not have
> > an OID, the question was moot.  I have no strong feelings on this
> > point, but if we are not going to allow the use of TIGER, then perhaps
> > we should remove it from the standard altogether or explicitly
> > disallow its use as the current halfway state is confusing now that
> > there is an OID available.
>
> I think that we should keep it in, although my opinion may be unpopular.
> Few implementations allow the use of TIGER, and so those people who wish
> to use it can use one of those implementations. It is useful for (gasp!)
> Elgamal signatures,

and RSA signatures!

> because it provides a larger hash algorithm and
> therefore the hash algorithm is no longer the weakest link.

__
Disastry  http://disastry.dhs.org/
http://disastry.dhs.org/pgp
 ^----PGP 2.6.3ia-multi06 (supports IDEA, CAST5, BLOWFISH, TWOFISH,
      AES, 3DES ciphers and MD5, SHA1, RIPEMD160, SHA2 hashes)

---

From: Werner Koch <[email-masked]>
Date: Mon, 30 Sep 2002 13:15:42 +0200

>   0x01, 0xDA, 0x47, 0x0C, 0x02, 0x05, 0x00, 0x04, 0x18

I calculated the same.

Shalom-Salam,

   Werner