Subject: [OPSAWG] powerconsumption mib

From: <[email-masked]>
Date: Mon, 26 Oct 2009 14:12:14 +0900

Hi all,
I have submitted an I-D as follows.

http://www.ietf.org/id/draft-teraoka-powerconsumption-mib-00.txt

The goal of this MIB is the realization of effective reducing power
consumption for the router.  Currently, the router is able to manage
dynamic performance.  This MIB is used to monitor the router traffic
and power consumption to optimize performance.

A new version of I-D, 
draft-teraoka-powerconsumption-mib-00.txt has been 
successfuly submitted by Minoru Teraoka and posted to the 
IETF repository.

Filename:	 draft-teraoka-powerconsumption-mib
Revision:	 00
Title:		 Power Consumption MIB for IP forwarding devices
Creation_date:	 2009-10-18
WG ID:		 Independent Submission
Number_of_pages: 19

Abstract:
This memo defines a portion of the Management Information 
Base (MIB) for use with network management protocols.  In 
particular it defines objects for monitoring power 
consumption with IP network element that has a function of 
dynamic performance control.

Best regards,
Minoru Teraoka

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 26 Oct 2009 08:24:14 +0100

>From a quick look, it seems the MIB module duplicates parts of the
IF-MIB, the ENTITY-MIB and the ENTITY-SENSOR-MIB. I do not see why it
is needed; and if there is something not covered by existing MIB
modules, it should be built on top of the exiting MIB infrastructure.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: <[email-masked]>
Date: Mon, 26 Oct 2009 17:40:46 +0900

Hi,
Thank you for your reply.

To each functions of the router, there is a demand to obtain power
consumption information.  I had wanted to achieve simple MIB intended
for the router, it became this composition.  The point of this
MIB is an information gathering for a plain unit of the router.
To prevent a traffic increase, I wanted to avoid the information
gathering in each detailed entity. 

Minoru Teraoka 

> -----Original Message-----
> From: Juergen Schoenwaelder 
> [mailto:[email-masked]] 
> Sent: Monday, October 26, 2009 4:24 PM
> To: Teraoka, Minoru ([email-masked])
> Cc: [email-masked]
> Subject: Re: [OPSAWG] powerconsumption mib
> 
> From a quick look, it seems the MIB module duplicates parts 
> of the IF-MIB, the ENTITY-MIB and the ENTITY-SENSOR-MIB. I do 
> not see why it is needed; and if there is something not 
> covered by existing MIB modules, it should be built on top of 
> the exiting MIB infrastructure.
> 
> /js
> 
> --

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 26 Oct 2009 09:48:41 +0100

Hi,

Inventing new objects and creating a new MIB module for information that
is already described another standard MIB modules does not simplify in
any way the implementation in the router, and does not reduce the
traffic - on the contrary. It is quite reasonable to assume that routers
already implement basic ifTable objects for traffic counters. The Entity
MIB and Entity Sensor MIB allow for power consumption to be read from a
device with a small number of objects. 

Regards,

Dan
(speaking as a contributor)

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Monday, October 26, 2009 10:41 AM
> To: [email-masked]
> Cc: [email-masked]
> To each functions of the router, there is a demand to obtain 
> power consumption information.  I had wanted to achieve 
> simple MIB intended for the router, it became this 
> composition.  The point of this MIB is an information 
> gathering for a plain unit of the router.
> To prevent a traffic increase, I wanted to avoid the 
> information gathering in each detailed entity. 
> 
> Minoru Teraoka 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: <[email-masked]>
Date: Mon, 26 Oct 2009 20:21:01 +0900

Hi,

Thanks for your comment.
I am reading the I-D
'draft-quittek-power-monitoring-requirements-00.txt' now.
If this scheme can acquire the power consumption and traffic of each module,
it might meet my requirement.  Does this contain the item that becomes
the change factor of the amount of power consumption?
The engine performance is decided by quantity of traffic after all.

Regards,
Minoru Teraoka 

> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: Monday, October 26, 2009 5:49 PM
> To: Teraoka, Minoru ([email-masked]); 
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [OPSAWG] powerconsumption mib
> 
> Hi,
> 
> Inventing new objects and creating a new MIB module for 
> information that is already described another standard MIB 
> modules does not simplify in any way the implementation in 
> the router, and does not reduce the traffic - on the 
> contrary. It is quite reasonable to assume that routers 
> already implement basic ifTable objects for traffic counters. 
> The Entity MIB and Entity Sensor MIB allow for power 
> consumption to be read from a device with a small number of objects. 
> 
> Regards,
> 
> Dan
> > for the router, it became this composition.  The point of 
> this MIB is 
> > an information gathering for a plain unit of the router.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 26 Oct 2009 12:35:03 +0100

Hi,

See in-line. 

Regards,

Dan

> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Monday, October 26, 2009 1:21 PM
> To: Romascanu, Dan (Dan); [email-masked]
> Cc: [email-masked]

This is a good start for requirements and description of already
existing standards. 

> If this scheme can acquire the power consumption and traffic 
> of each module, it might meet my requirement.  Does this 
> contain the item that becomes the change factor of the amount 
> of power consumption?

I am not sure what is the 'this' that you are referring to, and what is
exactly the 'change factor of the amount of power consumption'. That you
refer to. If there are objects that are not defined in the existing
standards MIB modules they could certainly be considered, but I did not
see such an object in
http://www.ietf.org/id/draft-teraoka-powerconsumption-mib-00.txt - maybe
I missed it.

---

From: <[email-masked]>
Date: Mon, 26 Oct 2009 23:39:51 +0900

Hi,

Sorry for confusion occurred by my remark. 
Please see in-line.

> ________________________________________
> From: Romascanu, Dan (Dan) [[email-masked]]
> Sent: Monday, October 26, 2009 20:35
> To: Teraoka, Minoru ([email-masked]); [email-masked]
> Cc: [email-masked]

The 'this' in my comment aimed at
'draft-quittek-power-monitoring-requirements-00.txt',
not at my I-D and I wanted to say that there was a cause-and-effect
relationship between power consumption and traffic.

I thought that I had to know a surplus ability of the entity about the
effect of the power saving for the evaluation. 
Therefore, in my I-D
http://www.ietf.org/id/draft-teraoka-powerconsumption-mib-00.txt ,
I defined the following contents.
  * PconMaxTransferCapacity is a meaning of the maximum transfer
    performance of the entity. 
  * PconTotalTransferCapacity is a meaning of the transfer performance
    in a current state. 

Regards,
Minoru Teraoka

---

From: "Juergen Quittek" <[email-masked]>
Date: Mon, 26 Oct 2009 22:28:12 +0100

Dear Minoru,

Thank you for contributing to the effort of developing power monitoring
standards. There are already several existing MIB modules. Besides the
one you describe in your draft there is a prototype implementation
(http://www.csee.usf.edu/~christen/energy/lcn08_2_proceedings.pdf)
and least two proprietary industrial MIB modules.

Instead of contributing all of them as individual Internet drafts
and then trying to merge them, we started collecting requirements
from all existing approaches first and collected them in
draft-quittek-power-monitoring-requirements. I would appreciate to
receive your comments, suggestions and contributions.

After agreeing on a set of requirements, we can jointly look at what
is already available, such as the entity MIB module, and what would
still be needed to meet the requirements.

Best regards,

    Juergen

---

From: <[email-masked]>
Date: Tue, 27 Oct 2009 11:16:23 +0900

Dear Juergen,

I thought that your approach about the power monitoring is appropriate.
http://www.ietf.org/id/draft-quittek-power-monitoring-requirements-00.txt
I also have some requirements such as related to the traffic for
power monitoring.  If possible, I would like to cooperate with you.

Best regards,

Minoru

> From: Juergen Quittek [mailto:[email-masked]] 
> Sent: Tuesday, October 27, 2009 6:28 AM
> To: Teraoka, Minoru ([email-masked]); Dan 
> Romascanu; Juergen Schoenwaelder
> Cc: [email-masked]
> Thank you for contributing to the effort of developing power 
> monitoring standards. There are already several existing MIB 
> modules. Besides the one you describe in your draft there is 
> a prototype implementation
> Instead of contributing all of them as individual Internet 
> drafts and then trying to merge them, we started collecting 
> requirements from all existing approaches first and collected 
> them in draft-quittek-power-monitoring-requirements. I would 
> appreciate to receive your comments, suggestions and contributions.
> 
> After agreeing on a set of requirements, we can jointly look 
> at what is already available, such as the entity MIB module, 
> and what would still be needed to meet the requirements.
> 
> Best regards,
> 
>     Juergen  
>