Subject: [OPSAWG] Proposed draft for Energy, Efficiency and Carbon Emission

From: sreekanthss <[email-masked]>
Date: Wed, 20 Jan 2010 15:18:10 +0530

Hi All,

   I and two of my collegues had submitted the below draft (dated 6th Jan, 2010).

   https://datatracker.ietf.org/idst/status.cgi?submission_id=20434

  This draft proposes the MIB structures for power (energy), efficiency and utilization complying to the carbon footprint calculation logic  for data network elements.

  Please provide comments.

Thanks,
Sreekanth

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 20 Jan 2010 13:01:26 +0100

> This draft proposes the MIB structures for power (energy), efficiency and utilization complying to the carbon footprint calculation logic  for data network elements.

The MIB modules has a number of flaws. For example, you do not
represent numbers using OCTET STRING (SIZE(1..8)). It is unclear why
some objects are read-write and some read-only. The MIB ignores
existing MIB modules and reinvents part of the ENTITY-MIB. Usage of
DisplayString is pretty much outdated (and why the length limit of
80?) or the tabe index limit of 200? The duplication of scalars and
the table looks strange. And finally, I doubt that hardware pieces can
report CO2 emission because that depends how the energy consumed by
the hardware was generated. The classification into idle, half, and
full also seems to be way to simplistic given today's power management
schemes.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>