Subject: [OPSAWG] WG adoption poll for In-Situ OAM drafts

From: "S.V.R.Anand" <[email-masked]>
Date: Fri, 23 Dec 2016 13:03:12 +0530

Hi,

I support the adoption of all the drafts.

The In-situ OAM Edge-to-Edge option, in particular, is very useful to our
work [1] as it allows us to carry packet expiration time that helps intermediate routers
to make routing and forwarding scheduling decisions to support latency
sensitive application flows, thereby realising deterministic networking.
In this context, there has been an interesting discussion [2] on this topic on the 6tisch
mailing list few months back.

Refs :

[1] https://tools.ietf.org/html/draft-lijo-6lo-expiration-time-00
[2] https://www.ietf.org/mail-archive/web/6tisch/current/msg04742.html

Anand

On 12/7/16 01:36, Zhoutianran wrote:

    Hi All,

    In Seoul, we got enough interest on the In Situ OAM work and positive
    response on related drafts.
    So this email starts a formal poll for adoption the following I-Ds.

    https://tools.ietf.org/html/draft-brockners-inband-oam-requirements-02.txt
    https://tools.ietf.org/html/draft-brockners-inband-oam-data-02.txt
    https://tools.ietf.org/html/draft-brockners-proof-of-transit-02.txt

    To be efficient, we have the poll for three I-Ds in one thread. But you
    can give your opinion on each of them. And the result is per I-D.

    The question is:
    Do you think that the WG should adopt all or some of these drafts?

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: "ram krishnan" <[email-masked]>
Date: Sat, 24 Dec 2016 16:38:44 +0530

I support adoption of these drafts. 

In addition, I would like bring a closely related draft to your attention --  <https://datatracker.ietf.org/doc/draft-krishnan-opsawg-in-band-pro-sla/?include_text=1> https://datatracker.ietf.org/doc/draft-krishnan-opsawg-in-band-pro-sla/?include_text=1

This draft brings some important contributions in the area of requirements and data formats for

-          IPSEC tunneling 

-          Pre-construction/minimizing of Telemetry header

-          Service chaining – benefits beyond the network interconnect

I was hoping to get this draft out by Seoul timeframe and make it in person, unfortunately couldn’t. Looking forward to discussions and collaboration on this interesting topic.

Thanks,

Ramki

---------- Forwarded message ----------
From: ram krishnan <[email-masked] <mailto:[email-masked]> >
Date: Fri, Dec 23, 2016 at 1:59 PM
Subject: FW: [OPSAWG] WG adoption poll for In-Situ OAM drafts
To: Ram Krishnan <[email-masked] <mailto:[email-masked]> >

Hi All,

 
 <https://tools.ietf.org/html/draft-brockners-inband-oam-requirements-02.txt> ​​
https://tools.ietf.org/html/draft-brockners-inband-oam-requirements-02.txt
https://tools.ietf.org/html/draft-brockners-inband-oam-data-02.txt
https://tools.ietf.org/html/draft-brockners-proof-of-transit-02.txt

 
The question is:

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 
believed to be clean. 

-- 

Thanks, 

Ramki

---

From: Zhoutianran <[email-masked]>
Date: Mon, 26 Dec 2016 06:57:07 +0000

Hi Ramki,

Thanks for bringing a new I-D to this WG.
Could you please state the relationship or potential overlay with the In Situ OAM serial I-Ds and also (https://tools.ietf.org/html/draft-lapukhov-dataplane-probe-01)?

Best,
Tianran

From: OPSAWG [mailto:[email-masked]] On Behalf Of ram krishnan
Sent: Saturday, December 24, 2016 7:09 PM
To: [email-masked]
Subject: [OPSAWG] FW: FW: WG adoption poll for In-Situ OAM drafts

In addition, I would like bring a closely related draft to your attention -- https://datatracker.ietf.org/doc/draft-krishnan-opsawg-in-band-pro-sla/?include_text=1

-          IPSEC tunneling

Thanks,
Ramki

---------- Forwarded message ----------
From: ram krishnan <[email-masked]<mailto:[email-masked]>>
Date: Fri, Dec 23, 2016 at 1:59 PM
Subject: FW: [OPSAWG] WG adoption poll for In-Situ OAM drafts
To: Ram Krishnan <[email-masked]<mailto:[email-masked]>>

Hi All,

​​<https://tools.ietf.org/html/draft-brockners-inband-oam-requirements-02.txt>

The question is:

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

--
Thanks,
Ramki

---

From: "Lijo Thomas" <[email-masked]>
Date: Wed, 28 Dec 2016 17:48:26 +0530

Hi,

This would be useful in our work also, where we are trying to build algorithms for LLNs based on the delay incurred during the transit of a packet from the sender to receiver. 

Thanks & Regards,

Lijo Thomas 

Hi All,

 

 
The question is:

-------------------------------------------------------------------------------------------------------------------------------
[ C-DAC is on Social-Media too. Kindly follow us at:
Facebook: https://www.facebook.com/CDACINDIA & Twitter: @cdacindia ]

This e-mail is for the sole use of the intended recipient(s) and may
contain confidential and privileged information. If you are not the
intended recipient, please contact the sender by reply e-mail and destroy
all copies and the original message. Any unauthorized review, use,
disclosure, dissemination, forwarding, printing or copying of this email
is strictly prohibited and appropriate legal action will be taken.
-------------------------------------------------------------------------------------------------------------------------------

---

From: "Ram Krishnan" <[email-masked]>
Date: Fri, 30 Dec 2016 04:40:57 -0800

Hi Tianran,

I can see the new draft playing predominantly a complementary role. I have summarized some of the key areas and also added comments, please see below.

1)      https://tools.ietf.org/html/draft-brockners-inband-oam-requirements-02.txt 

*	Complementary role of new draft:

*	Minimizing of In-band Telemetry Header for a specific use case such as latency measurement
*	Data export options 

*	Summarizing monitoring information to build a scalable solution – for example, alert the central management system only when 99th percentile queue depth exceeds a high threshold for a flow
*	Flow mirroring

*	Service chaining use case (independent and coupled with underlay/overlay) – describes how network monitoring can help in identifying server side issues and pave the way to dynamic resource orchestration to remedy the issue 

2)      https://tools.ietf.org/html/draft-brockners-inband-oam-data-02.txt

*	Complementary role of new draft: 

*	Minimizing of In-band Telemetry Header format 
*	Data export options format

-   Comments on above draft: 
o   I am surprised to see http://p4.org/wp-content/uploads/fixed/INT/INT-current-spec.pdf not being referenced.
 
3)      https://tools.ietf.org/html/draft-lapukhov-dataplane-probe-01
 
-   Comments on above draft: 
o   The above id focusses on injected probe packets. The new draft is applicable to all packets including injected probe packets.
 
4)      Mapping in-band telemetry to different transport protocols – new contribution (this could be a separate draft or might be input to be above drafts)

*	Complementary role of new draft:  

*	IPSEC use case for WAN and DC (beyond internet connectivity) and mapping  
*	VXLAN-GPE/Geneve/NSH mapping

5)      https://tools.ietf.org/html/draft-brockners-proof-of-transit-02.txt
 
-   Comments on above draft: 
o   One of the key reasons for packets following a path different from a traffic engineered/service chain path is misconfiguration. With that background,
*  With an administrative domain, practical service verification scheme(s) (https://datatracker.ietf.org/doc/draft-irtf-nfvrg-service-verification/?include_text=) could suffice
*  The elaborate proof of transit scheme suggested in this draft is possibly applicable across administrative domains where it may not be possible to mandate service verification. Additionally, when the path is changed dynamically based on intermediate node state it is not clear how this scheme will work.

Thanks,

Ramki

From: Zhoutianran [mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Sunday, December 25, 2016 10:57 PM
To: ram krishnan <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: RE: [OPSAWG] FW: FW: WG adoption poll for In-Situ OAM drafts

Hi Ramki,

Could you please state the relationship or potential overlay with the In Situ OAM serial I-Ds and also ( <https://tools.ietf.org/html/draft-lapukhov-dataplane-probe-01> https://tools.ietf.org/html/draft-lapukhov-dataplane-probe-01)?

Best,

Tianran

From: OPSAWG [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of ram krishnan
Sent: Saturday, December 24, 2016 7:09 PM
To:  <mailto:[email-masked]> [email-masked]
Subject: [OPSAWG] FW: FW: WG adoption poll for In-Situ OAM drafts

-          IPSEC tunneling 

Thanks,

Ramki

---------- Forwarded message ----------
From: ram krishnan <[email-masked] <mailto:[email-masked]> >
Date: Fri, Dec 23, 2016 at 1:59 PM
Subject: FW: [OPSAWG] WG adoption poll for In-Situ OAM drafts
To: Ram Krishnan <[email-masked] <mailto:[email-masked]> >

Hi All,

 

 
The question is:

 

-- 

Thanks, 

Ramki