Subject: [OPSAWG] Serious concerns with draft-ietf-opsawg-tacacs-06

From: Alan DeKok <[email-masked]>
Date: Tue, 9 May 2017 13:41:43 -0400

I've taken a look at the latest draft, and have some serious concerns.

  Specifically, large chunks of the Security Considerations sections appear to have been lifted from my post to the list:

https://mailarchive.ietf.org/arch/msg/opsawg/tU2wBFIV4MkpKChWn6EvrqeZtXU

  There are minor edits, but multiple sentences are copied word for word.  Sentences which don't occur in the -05 draft, but do appear in my review, and subsequently are copied to the -06 draft with minor edits.

  Multiple paragraphs are copied with only minor edits.  The total amounts to about a page of text.

  While I appreciate that the document is improving, blatant copying of my text without attribution is entirely inappropriate.

  What are the chairs recommendations?

  Alan DeKok.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 9 May 2017 14:07:02 -0400

> On May 9, 2017, at 1:41 PM, Alan DeKok <[email-masked]> wrote:
> 

using the text that was contributed is legit but not acknowledging the source in the acknowledgements section violates IETF requirement to acknowledge all significant contributions

Scott

> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Warren Kumari <[email-masked]>
Date: Tue, 09 May 2017 18:41:09 +0000

On Tue, May 9, 2017 at 8:07 PM Scott O. Bradner <[email-masked]> wrote:

> >  Specifically, large chunks of the Security Considerations sections
> appear to have been lifted from my post to the list:
> >
> >  There are minor edits, but multiple sentences are copied word for
> word.  Sentences which don't occur in the -05 draft, but do appear in my
> review, and subsequently are copied to the -06 draft with minor edits.
> >
> >  While I appreciate that the document is improving, blatant copying of
> my text without attribution is entirely inappropriate.
>
> using the text that was contributed is legit but not acknowledging the
> source in the acknowledgements section violates IETF requirement to
> acknowledge all significant contributions
>

Yes.
This document was resurrected from a really old document (1998) which did
not have an Acknowledgement section. The authors have already said
"Certainly, that was an oversight on our part" and that they would add an
acknowledgement section and acknowledge Alan's contribution.

W

[ Monkey typed on a small screen, apologies for typos ]

---

From: Ignas Bagdonas <[email-masked]>
Date: Tue, 9 May 2017 19:43:30 +0100

Hi Alan,

Based on the information received from authors while tracking the 
progress of the draft, they intend to publish a revised version covering 
the comments received during the previous WGLC timeframe.

WG chairs are not for waving a stick at the WG in trying to tell what a 
document needs to do to progress. While the WG document is formally 
owned by the WG, it is for the authors to do the actual text editing 
work and track and credit the changes in the text. Please initiate a 
discussion with authors, ideally on the list, on how your comments were 
or were not resolved. Quite many of past instances of such discussions 
were happening before, and they eventually have moved the document 
forward. Continuing with that discussion would be the right approach to 
take.

Please also discuss the aspects of lack of credit for the text that you 
have proposed. Contributed changes need to be credited, on what level - 
that is for the document authors and editors to agree and decide.

Looking further, there will be a new WG last call coming out after the 
revised version is posted. Usual WG LC discussion and commenting 
procedures will be followed.

Thank you again for reviewing and improving the document.

Ignas

---

From: Alan DeKok <[email-masked]>
Date: Tue, 9 May 2017 15:10:10 -0400

On May 9, 2017, at 2:43 PM, Ignas Bagdonas <[email-masked]> wrote:,
> 
> 
> Based on the information received from authors while tracking the progress of the draft, they intend to publish a revised version covering the comments received during the previous WGLC timeframe.

  I made no statements about my comments and their inclusion in the draft.

  But since you brought it up, I think the document is still nowhere near ready for publication.  Many comments have been addressed, but many have not been addressed.

  I question the utility of having a WGLC when the draft *still* doesn't adequately describe the protocol.

> WG chairs are not for waving a stick at the WG in trying to tell what a document needs to do to progress.

  The draft must document the protocol.

> While the WG document is formally owned by the WG, it is for the authors to do the actual text editing work and track and credit the changes in the text.

  I find it surprising that text was copied without attribution.  This just shouldn't happen.

> Please initiate a discussion with authors, ideally on the list, on how your comments were or were not resolved.

  As the list archive shows, I've done that.  It also shows little in the way of responses.

  The last response to my review was "Many thanks Alan for the thorough review.  We¹ll collate all your comments and respond shortly."

  That was six months ago, and there has been no further response.

  Given the extensive nature of my reviews, I would suggest it's not *my* responsibility to double-check each rev of the document to see if my comments are addressed.

  What I've seen in other WGs is that the authors respond to comments with clarifications, suggested replacement text, etc.  That pretty much hasn't happened here.

> Quite many of past instances of such discussions were happening before, and they eventually have moved the document forward. Continuing with that discussion would be the right approach to take.

  That's what I'm asking for.  That's not what's happening.

  Instead, new revs of the draft come out, with minimal interaction with the WG.

> Looking further, there will be a new WG last call coming out after the revised version is posted. Usual WG LC discussion and commenting procedures will be followed.

  I would suggest that it's too early to have a WGLC, as the authors simply haven't responded to reviews of the draft.

  i.e. I have no idea what state the draft is in.  After doing multiple detailed reviews that largely get ignored, I'm not inclined to do more.  It's up to the authors to demonstrate that the comments have been addressed.

  Alan DeKok.

---

From: Ignas Bagdonas <[email-masked]>
Date: Tue, 9 May 2017 23:37:34 +0100

>    I question the utility of having a WGLC when the draft *still* doesn't adequately describe the protocol.

WGLC is for bringing the attention for finalizing the outstanding 
issues. If there are too many issues or they are too deep - that is 
fine, it is always possible to go back and do another WGLC later if needed.

The version that will go into WGLC is still not published therefore at 
this time it is just a speculation whether that particular version will 
or will not describe the protocol adequately. We need to wait for the 
authors to do their part and then it will be visible.

>    I find it surprising that text was copied without attribution.  This just shouldn't happen.

That is correct. Authors are aware of this and it is under their 
decision and responsibility to resolve this.

>    What I've seen in other WGs is that the authors respond to comments with clarifications, suggested replacement text, etc.  That pretty much hasn't happened here.

I agree with the facts and indeed the communication could have been 
better, and I understand the negative sentiments from your side. However 
it does not seem to be practical to try to escalate this in the rush at 
the timescale of days given that it already took half a year. Authors 
are aware of this discussion, it is their turn now to produce the new 
revision (which by the word of authors should be coming within a few 
weeks), and then if the new revision still does not address your 
concerns we would need to revisit this discussion again. Your reviews 
are definitely appreciated and valuable, it is the following up with 
them still has room for improvement.

>    i.e. I have no idea what state the draft is in.  After doing multiple detailed reviews that largely get ignored, I'm not inclined to do more.  It's up to the authors to demonstrate that the comm…

Authors have the next step to do at this time. Let's wait for the new 
revision first.

Ignas

---

From: Alan DeKok <[email-masked]>
Date: Tue, 9 May 2017 21:26:48 -0400

On May 9, 2017, at 6:37 PM, Ignas Bagdonas <[email-masked]> wrote:
> WGLC is for bringing the attention for finalizing the outstanding issues. If there are too many issues or they are too deep - that is fine, it is always possible to go back and do another WGLC later if needed.

  I've already brought attention to issues.  From my cursory reading of the draft, many haven't been addressed.

  WGLC is also a signal that a draft is close to being ready for publication.  I don't think we're anywhere near a WGLC for this draft.

> I agree with the facts and indeed the communication could have been better, and I understand the negative sentiments from your side. However it does not seem to be practical to try to escalate this in the rush at the timescale of days given that it already took half a year.

  Using text without attribute is the problem.  Insinuating that I'm trying to "rush" an escalation is just not appropriate.  Especially because the "timescale of days" is something I never mentioned.

> Authors are aware of this discussion, it is their turn now to produce the new revision (which by the word of authors should be coming within a few weeks),

  If only there was a public mailing list where people could discuss these issues...

> Authors have the next step to do at this time. Let's wait for the new revision first.

  It's also possible to respond publicly to my review.

  Alan DeKok.

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Wed, 10 May 2017 10:39:01 +0200

Let me express my support for Alan's statement below.
If a WG participant makes comments and posts them to the list, then it
is most appropriate that the authors (anyone in fact) respond and discuss
them on the list with suggestions for how to fix or improve the text.

Public discussion is preferred, but not mandatory (sometimes private discussion
between authors and the person(s) who see issues/concern can help resolve things too).
But then when the private discussion comes to resolution/agreement, then it seems best
to me to then also post that to the mailing list.

my 2 cents, Bert

Bert