Subject: Re: [OPSAWG] [Idr] FW: WG LC for draft-ietf-opsawg-ipfix-bgp-community

From: Jeffrey Haas <[email-masked]>
Date: Sun, 11 Feb 2018 10:50:57 -0500

Authors,

Thanks for accommodating my prior comments on this draft.

I have one final issue to raise with the draft.  The information elements
for extended community and large community by nature of their size are of
type octetArray.  The draft correctly notes the expected size of each of
these elements; 8 and 12 respectively.

The draft provides no guidance for when each of these elements is NOT of the
expected size.

My recommendation is a small paragraph to the Operational Considerations
section:
"In the event that the bgpExtendedCommunity or bgpLargeCommunity Elements
are not of their expected sizes (8 and 12 octets, respectively), the
receiver SHOULD ignore them."

I'm not savvy with the general language wrapped around receiver procedure
for IPFIX these days, so a bit of additional verbiage might be expected for
appropriate draft boilerplate.  However, this is intended to protect
implementations using BGP logic from calling their parsing routines with
invalid lengths.

-- Jeff

On Mon, Jan 22, 2018 at 08:26:52AM +0000, Dongjie (Jimmy) wrote:
> Hi, 
> 
> Currently this BGP related draft is in WG LC in OPSAWG, their chairs suggest IDR to take a look at it, please send comments (if any) to OPSAWG mailing list.
> 
> Best regards,
> Jie
> 
> -----Original Message-----
> From: Tianran Zhou 
> Sent: Thursday, January 18, 2018 11:31 AM
> To: [email-masked]'
> Cc: [email-masked]'
> Subject: FW: WG LC for draft-ietf-opsawg-ipfix-bgp-community
> 
> Dear IDR Chairs,
> 
> The OPSAWG started a 2 week WG LC for the following draft:
> https://tools.ietf.org/html/draft-ietf-opsawg-ipfix-bgp-community-04
> 
> We got many comments and suggestions from IDR when this work is adopted. Now the authors believe the document is ready.
> We really appreciate more comments from this working group.
> 
> Could you please help to forward this information to the IDR mailing list?
> 
> Thanks,
> Tianran, as OPSAWG co-chair 
> 
> 
> -----Original Message-----
> From: OPSAWG [mailto:[email-masked]] On Behalf Of Tianran Zhou
> Sent: Thursday, January 18, 2018 11:07 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [OPSAWG] WG LC for draft-ietf-opsawg-ipfix-bgp-community
> 
> Hi WG,
> 
> The authors of draft-ietf-opsawg-ipfix-bgp-community have posted the latest drafts to the mailing list, and believe that the document is ready for LC.
> 
> This starts a 2 week WG LC on
> https://tools.ietf.org/html/draft-ietf-opsawg-ipfix-bgp-community-04
> 
> Please read the above draft and send any issues, comments, or corrections to this mailing list. 
> All supports and concerns are welcome and helpful for the authors.
> 
> We are also looking for a document shepherd, best with operator background, to help the following procedures.  
> 
> The WG LC will close on Feb 1, 2018.
> Authors please indicate whether you are aware of any IPR for the draft.
> 
> Thanks,
> Tianran, as OPSAWG co-chair
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 13 Feb 2018 06:48:53 +0000

Hi Jeff, 

Thanks a lot for your comments and recommendation, which will be reflected in next revision of this document. 

Best regards,
Jie

> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: Sunday, February 11, 2018 11:51 PM
> To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Idr] FW: WG LC for draft-ietf-opsawg-ipfix-bgp-community
> 
> Authors,
> 
> I have one final issue to raise with the draft.  The information elements for
> extended community and large community by nature of their size are of type
> octetArray.  The draft correctly notes the expected size of each of these
> elements; 8 and 12 respectively.
> 
> "In the event that the bgpExtendedCommunity or bgpLargeCommunity
> Elements are not of their expected sizes (8 and 12 octets, respectively), the
> implementations using BGP logic from calling their parsing routines with invalid
> lengths.
> 
> -- Jeff
> 
> > Currently this BGP related draft is in WG LC in OPSAWG, their chairs suggest
> IDR to take a look at it, please send comments (if any) to OPSAWG mailing list.
> >
> > Best regards,
> > Jie
> >
> > We got many comments and suggestions from IDR when this work is adopted.
> Now the authors believe the document is ready.
> > The authors of draft-ietf-opsawg-ipfix-bgp-community have posted the latest
> drafts to the mailing list, and believe that the document is ready for LC.
> >