Subject: [OPSAWG] Suresh Krishnan's No Objection on draft-ietf-opsawg-nat-yang-16: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Tue, 25 Sep 2018 20:48:42 -0700

Suresh Krishnan has entered the following ballot position for
draft-ietf-opsawg-nat-yang-16: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-opsawg-nat-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Shouldn't the "psid-offset" have a default value of 6 for the 'a' bits in MAP-E?

---

From: <[email-masked]>
Date: Wed, 26 Sep 2018 04:47:51 +0000

Hi Suresh, 

Adding that default value would make sense if port restriction is only reserved to NATs deployed in combination with MAP-E BRs. The document does not make that assumption.

Thank you.

Cheers,
Med

> -----Message d'origine-----
> De : OPSAWG [mailto:[email-masked]] De la part de Suresh Krishnan
> Envoyé : mercredi 26 septembre 2018 05:49
> À : The IESG
> Cc : [email-masked]; [email-masked]; opsawg-
> [email-masked]
> Objet : [OPSAWG] Suresh Krishnan's No Objection on draft-ietf-opsawg-nat-
> yang-16: (with COMMENT)
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 26 Sep 2018 13:26:29 +0000

Hi Med,

> On Sep 26, 2018, at 12:47 AM, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Suresh, 
> 

Are there any other expected consumers for this feature (other than MAP-E)? An example would be great. I would think the offset bits (for the system port exclusion) and the PSID are fairly specific for MAP-E. If there are other consumers, how do you ensure that  the value of the ‘a’ bits (i.e. A) needs to be greater than zero since I assumed the A>0 check will be done by the MAP-E implementation.

Thanks
Suresh

---

From: <[email-masked]>
Date: Thu, 27 Sep 2018 05:58:09 +0000

Hi Suresh, 

Please see inline. 

Cheers,
Med

> De : Suresh Krishnan [mailto:[email-masked]]
> Envoyé : mercredi 26 septembre 2018 15:26
> À : BOUCADAIR Mohamed IMT/OLN
> Cc : The IESG; [email-masked]; [email-masked]; opsawg-
> [email-masked]
> Objet : Re: [OPSAWG] Suresh Krishnan's No Objection on draft-ietf-opsawg-nat-
> yang-16: (with COMMENT)
> 
> Hi Med,
> 
> > Adding that default value would make sense if port restriction is only
> reserved to NATs deployed in combination with MAP-E BRs. The document does
> not make that assumption.
> 
> Are there any other expected consumers for this feature (other than MAP-E)?
> An example would be great.

[Med] Without citing other examples such as closed infrastructures in which only a subset of ports are allowed, let's focus on the A+P flavors.

The algorithm approach for identifying port sets is not specific to MAP-E, but is used by other mechanisms such as lightweight 4over6. RFC 7596 says the following:

"For lw4o6, the number of
   a-bits SHOULD be 0, thus allocating a single contiguous port set to
   each lwB4."

 I would think the offset bits (for the system port
> exclusion) and the PSID are fairly specific for MAP-E.

[Med] see above.  

 If there are other
> consumers, how do you ensure that  the value of the ‘a’ bits (i.e. A) needs
> to be greater than zero since I assumed the A>0 check will be done by the
> MAP-E implementation.

[Med] The range of allowed values is clear about this:

          type uint8 {
            range 0..15;
          }

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 27 Sep 2018 13:32:14 +0000

Hi Med,
  Thanks for the clarification. The lw4over6 use case clarifies both the lack of a default and the psid-offset not being mandatory.

Regards
Suresh

> On Sep 27, 2018, at 1:58 AM, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Suresh, 
> 
> Please see inline. 
> 
> Cheers,
> Med
>