Subject: Re: [OPSAWG] Review of draft-ietf-opsawg-ipfix-bgp-community-07

From: li zhenqiang <[email-masked]>
Date: Thu, 20 Sep 2018 10:31:28 +0000

Dear Shawn M. Emery,

Thank you for your review and nits. I have corrected all the nits and uploaded a new version -08. Please check and thanks again.

Zhenqiang Li
________________________________
[email-masked]

From: Shawn Emery<mailto:[email-masked]>
Date: 2018-09-19 15:03
To: secdir<mailto:[email-masked]>; draft-ietf-opsawg-ipfix-bgp-community.all<mailto:[email-masked]>
CC: Shawn Emery<mailto:[email-masked]>
Subject: Review of draft-ietf-opsawg-ipfix-bgp-community-07

Reviewer: Shawn M. Emery
Review result: Ready with numerous nits

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security
area directors. Document editors and WG chairs should treat these
comments just like any other last call comments.

This draft specifies new Information Elements (IEs) in order to support BGP community
information for the IP Flow Information eXport (IPFIX) protocol.

The security considerations section does exist and states that the draft just defines
new IEs and does not introduce any new security considerations.  The section then
goes on to state that the same security issues that apply to the IPFIX protocol and
the corresponding Information Model applies to this specification.  I agree with these
assertions.

General comments:

None.

Editorial comments:

s/differnt/different/g

s/Netwok/Network/

s/statistic/statistics/

s/mediator needs/the mediator needs/

s/Mediator is/The mediator is/

s/figure up/determine/g

s/mechanisum/mechanism/

s/generted/generated/

s/Please refer/Please refer to/g

s/originated from AS A and destinated/originating from AS A and destined/

s/becuse it will cause the congestion/because it will cause congestion/

s/togecher/together/

s/source IP and destination IP/source and destination IP address/g

s/both the source IP and the destination IP related/relating to both the source and destination IP addresses/

s/length one IPFIX/length of one IPFIX/

s/to the information about the networks in the field/to information about networks in the field/

OLD:

configure export policy of BGP communities on the exporter to limit the BGP communities to be exported, so as to only export some specific communities,or not to export some specific communities.

NEW:

configure the export policy of BGP communities to limit the BGP communities by including or excluding specific communities.

s/The detailed mechanism is out of the scope of this document./The details of increasing IPFIX message length is out of scope for this document./

s/refer Appendix A/refer to Appendix A/

s/source or destination IP/source or destination IP address/

Shawn.

--

---

From: Shawn Emery <[email-masked]>
Date: Thu, 20 Sep 2018 23:48:47 -0600

On Thu, Sep 20, 2018 at 4:31 AM li zhenqiang <[email-masked]>
wrote:

> Dear Shawn M. Emery,
>
> Thank you for your review and nits. I have corrected all the nits and
> uploaded a new version -08. Please check and thanks again.
>

The updates look fine to me.  Thanks for your quick response.

Shawn.
-- 

> ------------------------------
> [email-masked]
>
>
> *From:* Shawn Emery <[email-masked]>
> *Date:* 2018-09-19 15:03
> *To:* secdir <[email-masked]>; draft-ietf-opsawg-ipfix-bgp-community.all
> <[email-masked]>
> *CC:* Shawn Emery <[email-masked]>
> *Subject:* Review of draft-ietf-opsawg-ipfix-bgp-community-07
>
> Reviewer: Shawn M. Emery