Subject: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

From: Erez Segev <[email-masked]>
Date: Thu, 31 Oct 2019 09:59:22 +0000

Dear Authors of draft-ietf-opsawg-l3sm-l3nm

Question regarding eBGP ,
what if I'd like several eBGP sessions to

-          Multiple destinations

-          Different AS  .

How do I set several eBGP sessions per site?
Where does the AS of the other side defined?

                     |     +--rw bgp {rtg-bgp}?
                     |     |  +--rw autonomous-system    uint32
                     |     |  +--rw address-family*      address-family
                     |     |  +--rw neighbor?            inet:ip-address
                     |     |  +--rw multihop?            uint8
                     |     |  +--rw security
                     |     |     +--rw auth-key?   string

Thanks,
Erez

Erez Segev
NFV&SDN System Engineer

T:
+972.3.9287393
M:
+972.50.7057393
E:
[email-masked]<mailto:[email-masked]>

www.ecitele.com<http://www.ecitele.com/>

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Thu, 31 Oct 2019 10:59:54 +0000

Hi Erez,

We have defined the routing protocols inside the Network Access as a List. So you can have several routing protocols enabled at the same time, including two or more eBGP sesions or BGP+ OSPF or OSPF+ Static Route.

In fact we have added the multihop count to be able to support BGP connections with not directly connected peers. So in this case an static route + BGP connection is enabled.

Reagards

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: OPSAWG <[email-masked]> en nombre de Erez Segev <[email-masked]>
Enviado: jueves, 31 de octubre de 2019 4:59
Para: [email-masked] <[email-masked]>; Oscar González de Dios <[email-masked]>; Victor Lopez <[email-masked]>; [email-masked] <[email-masked]>
Asunto: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

what if I’d like several eBGP sessions to

-          Multiple destinations

-          Different AS  .

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Erez Segev <[email-masked]>
Date: Thu, 31 Oct 2019 11:21:57 +0000

Hi Samier ,

Thank you for the quick response.
The routing-protocols container key is 'type' so you practically cannot repeat several BRP session per site / or site-network-access. Since bgp type can appear once.

grouping site-routing {
  container routing-protocols {
   list routing-protocol {
    key type;

Maybe I didn't understand something here.

Thanks allot,
Erez

From: SAMIER BARGUIL GIRALDO [mailto:[email-masked]]
Sent: Thursday, October 31, 2019 1:00 PM
To: Erez Segev <[email-masked]>; [email-masked]; Oscar González de Dios <[email-masked]>; Victor Lopez <[email-masked]>; [email-masked]
Subject: RE: draft-ietf-opsawg-l3sm-l3nm

Hi Erez,

Reagards

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked]<mailto:[email-masked]>

E-mail [email-masked]<mailto:[email-masked]>

________________________________
De: OPSAWG <[email-masked]<mailto:[email-masked]>> en nombre de Erez Segev <[email-masked]<mailto:[email-masked]>>
Enviado: jueves, 31 de octubre de 2019 4:59
Para: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Oscar González de Dios <[email-masked]<mailto:[email-masked]>>; Victor Lopez <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Asunto: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

-          Multiple destinations

-          Different AS  .

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

---

From: Erez Segev <[email-masked]>
Date: Thu, 31 Oct 2019 13:34:38 +0000

Hi Samier,

In addition to my previous mail, is there's an ability to determine the provider's autonomous-system, in order to initiate eBPG from the customer premises to the L2VPN , I believe ths attribute should be added to vpn-node container.

Thanks,
Erez

Hi Erez,

Reagards

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

-          Multiple destinations

-          Different AS  .

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Thu, 31 Oct 2019 14:23:09 +0000

Hi Erez,

After checking the model, you are right this key does not allow the configuration of several BGP sessions on the Same VPN.

Regarding the AS; We have already discussed and the idea is to include it in the New Version. Thanks for your feedback.

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

________________________________
De: Erez Segev <[email-masked]>
Enviado: jueves, 31 de octubre de 2019 8:34
Para: SAMIER BARGUIL GIRALDO <[email-masked]>; [email-masked] <[email-masked]>; Oscar González de Dios <[email-masked]>; Victor Lopez <[email-masked]>; [email-masked] <[email-masked]>
Asunto: RE: draft-ietf-opsawg-l3sm-l3nm

Hi Samier,

In addition to my previous mail, is there’s an ability to determine the provider’s autonomous-system, in order to initiate eBPG from the customer premises to the L2VPN , I believe ths attribute should be added to vpn-node container.

Thanks,

Erez

Hi Erez,

Reagards

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

-          Multiple destinations

-          Different AS  .

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

---

From: <[email-masked]>
Date: Thu, 31 Oct 2019 16:21:33 +0100

Hi Erez,

What is the exact setup that you want to achieve ?

Currently the BGP is linked to the site-network-access. If a site has multiple site-network-access on the same PE, there is no issue to get multiple BGP sessions with the current model.

What is your use case for having multiple BGP sessions on the same access ? There are two that I could think of but I prefer to hear from you first, so you are not influenced 😉

regarding the AS, why do you need the SP AS in the model (I guess you mean the ASN of the PE) ? SP knows which ASN the PE is belonging to.

Brgds,

Stephane

From: OPSAWG <[email-masked]> On Behalf Of SAMIER BARGUIL GIRALDO
Sent: jeudi 31 octobre 2019 15:23
To: Erez Segev <[email-masked]>; [email-masked]; Oscar González de Dios <[email-masked]>; Victor Lopez <[email-masked]>; [email-masked]
Subject: Re: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm

Hi Erez, 

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked] <mailto:[email-masked]> 

E-mail [email-masked] <mailto:[email-masked]> 

  _____  

De: Erez Segev <[email-masked] <mailto:[email-masked]> >
Enviado: jueves, 31 de octubre de 2019 8:34
Para: SAMIER BARGUIL GIRALDO <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >; Oscar González de Dios <[email-masked] <mailto:[email-masked]> >; Victor Lopez <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >
Asunto: RE: draft-ietf-opsawg-l3sm-l3nm 

Hi Samier,

Thanks,

Erez

From: SAMIER BARGUIL GIRALDO [mailto:[email-masked]] 
Sent: Thursday, October 31, 2019 1:00 PM
To: Erez Segev <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; Oscar González de Dios <[email-masked] <mailto:[email-masked]> >; Victor Lopez <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: RE: draft-ietf-opsawg-l3sm-l3nm

Hi Erez, 

 

Reagards

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked] <mailto:[email-masked]> 

E-mail [email-masked] <mailto:[email-masked]> 

  _____  

De: OPSAWG <[email-masked] <mailto:[email-masked]> > en nombre de Erez Segev <[email-masked] <mailto:[email-masked]> >
Enviado: jueves, 31 de octubre de 2019 4:59
Para: [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >; Oscar González de Dios <[email-masked] <mailto:[email-masked]> >; Victor Lopez <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >
Asunto: [OPSAWG] draft-ietf-opsawg-l3sm-l3nm 

 

-          Multiple destinations 

-          Different AS  . 

 

                     |     +--rw bgp {rtg-bgp}?

                     |     |  +--rw security

 

Thanks,

Erez

Erez Segev

NFV&SDN System Engineer

T:

+972.3.9287393

M:

+972.50.7057393

E:

 <mailto:[email-masked]> [email-masked]

 <http://www.ecitele.com/> www.ecitele.com

  _____  

  _____