Subject: Re: [OPSAWG] New Version Notification for draft-shytyi-opsawg-vysm-02.txt

From: Tianran Zhou <[email-masked]>
Date: Fri, 18 Oct 2019 15:10:59 +0000

Hi Dmytro,

Thanks for your update.
Now the agenda is not published. So we have not open the CFP.
But I will record your request.

Cheers,
Tianran

发件人: OPSAWG [mailto:[email-masked]] 代表 Dmytro Shytyi
发送时间: 2019年10月18日 22:30
收件人: Dmytro Shytyi <[email-masked]>
抄送: opsawg <[email-masked]>
主题: Re: [OPSAWG] New Version Notification for draft-shytyi-opsawg-vysm-02.txt

Hello all,

We updated the draft to version draft-shytyi-opsawg-vysm-03.txt with the new information.

We added a section that describes what could be done with uCPE, precisely the advantages that uCPE introduces.
Tehre are sevaral nice figures that describe how we could take an advantage of uCPE.

If needed, we also can introduce the layered architecture of the YANG models that are in stacked orchestrators.

Dear chairs of the wg, I will attend the next IETF meeting and I would like to have a 'brief' slot to present the draft.

A new version of I-D, draft-shytyi-opsawg-vysm-03.txt
has been successfully submitted by Dmytro Shytyi and posted to the
IETF repository.

Name:        draft-shytyi-opsawg-vysm
Revision:    03
Title:        A YANG Module for uCPE management.
Document date:    2019-10-18
Group:        Individual Submission
Pages:        41
URL: https://www.ietf.org/internet-drafts/draft-shytyi-opsawg-vysm-03.txt
Status: https://datatracker.ietf.org/doc/draft-shytyi-opsawg-vysm/
Htmlized: https://tools.ietf.org/html/draft-shytyi-opsawg-vysm-03
Htmlized: https://datatracker.ietf.org/doc/html/draft-shytyi-opsawg-vysm
Diff: https://www.ietf.org/rfcdiff?url2=draft-shytyi-opsawg-vysm-03<https://www.ietf..org/rfcdiff?url2=draft-shytyi-opsawg-vysm-03>

Abstract:
This document provides a YANG data model for uCPE management (VYSM)
and definition of the uCPE equipment. The YANG Service Model serves
as a base framework for managing an universal Customer-Premises
Equipment (uCPE) subsystem. The model can be used by a Network
Service Orchestrator.

______________
Dmytro SHYTYI,
SFR.

---- On Tue, 08 Oct 2019 18:33:13 +0200 Dmytro Shytyi <[email-masked]<mailto:[email-masked]>> wrote ----

Hello Joe,
Thank you for your comment.

In the new version:
We updated the existing yang model according to your suggestions(now the nits and validation logs seem to be clear).
We expanded the uCPE management yang model with interface model from RFC 8343( A YANG Data Model for Interface Management)
Now there are 3 yang files that you may strip from I-D:

  *   vsym-service.yang
  *   modified ietf-interfaces.yang (augments vsym-service.yang)
  *   ietf-vsym-interfaces.yang (augments vsum-service.yang and has ref to "vLinks" from vsym-service).

A new version of I-D, draft-shytyi-opsawg-vysm-02.txt
has been successfully submitted by Dmytro Shytyi and posted to the
IETF repository.

Name:        draft-shytyi-opsawg-vysm
Revision:    02
Title:        A YANG Module for uCPE management.
Document date:    2019-10-08
Group:        Individual Submission
Pages:        40
URL: https://www.ietf.org/internet-drafts/draft-shytyi-opsawg-vysm-02.txt
Status: https://datatracker.ietf.org/doc/draft-shytyi-opsawg-vysm/
Htmlized: https://tools.ietf.org/html/draft-shytyi-opsawg-vysm-02
Htmlized: https://datatracker.ietf.org/doc/html/draft-shytyi-opsawg-vysm
Diff: https://www.ietf.org/rfcdiff?url2=draft-shytyi-opsawg-vysm-02

Abstract:
This document provides a YANG data model for uCPE management (VYSM)
and definition of the uCPE equipment. The YANG Service Model serves
as a base framework for managing an universal Customer-Premises
Equipment (uCPE) subsystem. The model can be used by a Network
Service Orchestrator.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---- On Mon, 07 Oct 2019 15:50:40 +0200 Joe Clarke (jclarke) <[email-masked]<mailto:[email-masked]>> wrote ----

_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/opsawg

On Sep 30, 2019, at 17:17, Dmytro Shytyi <[email-masked]<mailto:[email-masked]>> wrote:

Dear members of opsawg,

Recently we uploaded a draft about uCPE management.

You are invited to answer few questions regarding the draft https://www.ietf.org/internet-drafts/draft-shytyi-opsawg-vysm-01.txt.

One thing that would help with reviews is if you cleaned up this YANG module.  Consider using pyang -f yang --keep-comments to generate something well-formatted, and —canonical to check ordering.  In particular, your revisions are out of order.

Question1: Do you find a difinition of uCPE is well explained? If no what could be improved?

I think it is, but as a vendor that makes such a device, I may not be the right person to ask.  What I mean is that I inherently understand the concept.

It would be good if others perhaps that use such devices could weigh in.

Joe

      You may answer: I agree with definition. OR I think it could be modified...
Question2: Do you think there is enough examples of internal uCPE service and usecases that are well depicted.
      You may answer: The examples and usecases are well explained. OR The usecases need improvements.
Question3: Do you find that yang model should stay unchanged regarding the phy interfaces. Maybe one may think about "ietf interface" instead of  "phyInterface".
      You may answer: The yang model looks good for me. OR The yang model needs more improvements(which improvements).
______________
Best Regards,
Dmytro SHYTYI

---- On Thu, 26 Sep 2019 18:01:14 +0200 <[email-masked]<mailto:[email-masked]>> wrote ----

A new version of I-D, draft-shytyi-opsawg-vysm-01.txt
has been successfully submitted by Dmytro Shytyi and posted to the
IETF repository.

Name:        draft-shytyi-opsawg-vysm
Revision:    01
Title:        A YANG Module for uCPE management.
Document date:    2019-09-26
Group:        Individual Submission
Pages:        15
URL: https://www.ietf.org/internet-drafts/draft-shytyi-opsawg-vysm-01.txt
Status: https://datatracker.ietf.org/doc/draft-shytyi-opsawg-vysm/
Htmlized: https://tools.ietf..org/html/draft-shytyi-opsawg-vysm-01
Htmlized: https://datatracker.ietf.org/doc/html/draft-shytyi-opsawg-vysm
Diff: https://www.ietf.org/rfcdiff?url2=draft-shytyi-opsawg-vysm-01

Abstract:
This document provides a YANG data model for uCPE management (VYSM)
and definition of the uCPE equipment. The YANG Service Model serves
as a base framework for managing an universal Customer-Premises
Equipment (uCPE) subsystem. The model can be used by a Network
Service Orchestrator.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:OPSAWG@ietf..org>
https://www.ietf.org/mailman/listinfo/opsawg

---

From: Dmytro Shytyi <[email-masked]>
Date: Fri, 18 Oct 2019 17:28:51 +0200

Hello Tianran,

Thank you for your response.

May I ask when approximately the agenda is going to be pubhished ?

______________
Dmytro SHYTYI

SFR

---- On Fri, 18 Oct 2019 17:10:59 +0200 Tianran Zhou <[email-masked]> wrote ----

Hi Dmytro,

Thanks for your update.

Cheers,

Tianran

发件人: OPSAWG [mailto:mailto:[email-masked]] 代表  Dmytro Shytyi
 发送时间: 2019年10月18日 22:30
 收件人: Dmytro Shytyi <mailto:[email-masked]>
 抄送: opsawg <mailto:[email-masked]>
 主题: Re: [OPSAWG] New Version Notification for draft-shytyi-opsawg-vysm-02.txt

Hello all,

 

 

 

 

 

 

IETF repository.

Revision:    03

Pages:        41

Diff: https://www.ietf..org/rfcdiff?url2=draft-shytyi-opsawg-vysm-03

Abstract:

Service Orchestrator.

______________
 Dmytro SHYTYI,

SFR.

 

---- On Tue, 08 Oct 2019 18:33:13 +0200 Dmytro Shytyi <mailto:[email-masked]> wrote ----

Hello Joe,

 

In the new version:

vsym-service.yang

modified ietf-interfaces.yang (augments vsym-service.yang)

ietf-vsym-interfaces.yang (augments vsum-service.yang and has ref to "vLinks" from vsym-service).

 

IETF repository.

Revision:    02

Pages:        40

 

Abstract:

Service Orchestrator.

 

 

 

The IETF Secretariat

---- On Mon, 07 Oct 2019 15:50:40 +0200 Joe Clarke (jclarke) <mailto:[email-masked]> wrote ----

 

 

OPSAWG mailing list

mailto:[email-masked]

 

On Sep 30, 2019, at 17:17, Dmytro Shytyi <mailto:[email-masked]> wrote:

Dear members of opsawg,

 

One thing that would help with reviews is if you cleaned up this YANG module.  Consider using pyang -f yang --keep-comments to generate something well-formatted,
 and —canonical to check ordering.  In particular, your revisions are out of order.

 

 

 

 

Joe

______________

Best Regards,

Dmytro SHYTYI

 

---- On Thu, 26 Sep 2019 18:01:14 +0200 <mailto:[email-masked]> wrote ----

 
 
 Abstract: 

 
 Please note that it may take a couple of minutes from the time of submission 
 until the htmlized version and diff are available at http://tools.ietf.org. 
 
 The IETF Secretariat

 

OPSAWG mailing list

mailto:OPSAWG@ietf..org