Subject: [OPSAWG] Conclusion//RE: WG adoption call for draft-aguado-opsawg-l3sm-l3nm-02

From: Tianran Zhou <[email-masked]>
Date: Thu, 17 Oct 2019 01:40:35 +0000

Hi WG,

Now we conclude the poll and adopt this document as WG draft.
There are reasonable supports that can help the document evolution.
A group of people are now implementing this, bringing in operational experience.

Authors,
Please republish draft-aguado-opsawg-l3sm-l3nm-02 as draft-ietf-opsawg-l3sm-l3nm-00 with only the date and file name changed.

Cheers,
Tianran
> -----Original Message-----
> From: OPSAWG [mailto:[email-masked]] On Behalf Of Tianran Zhou
> Sent: Sunday, September 29, 2019 2:29 PM
> To: [email-masked]
> Subject: [OPSAWG] WG adoption call for draft-aguado-opsawg-l3sm-l3nm-02
> 
> Hi WG,
> 
> This email starts a 2 weeks working group adoption call for
> draft-aguado-opsawg-l3sm-l3nm-02.
> https://datatracker.ietf.org/doc/draft-aguado-opsawg-l3sm-l3nm/
> 
> This document proposes a L3VPN Network Yang Model (L3NM) to facilitate
> communication between a service orchestrator and a network
> controller/orchestrator.
> 
> If you support adopting this document please say so, and please give an
> indication of why you think it is important. Also please say if you will be
> willing to review and help the draft.
> If you do not support adopting this document as a starting point for work
> on this topic, please say why.
> This poll will run until Oct 14.
> 
> Thanks,
> Tianran and Joe
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Oscar González de Dios <[email-masked]>
Date: Fri, 18 Oct 2019 12:25:08 +0000

Hi Tianran,

draft-ietf-opsawg-l3sm-l3nm-00 has been submitted (only title and date changed as indicated).

Best Regards and looking forward to advance in the draft and report implementation, as well as lessons learnts in the interoperability.

Oscar

-----Mensaje original-----
De: Tianran Zhou <[email-masked]>
Enviado el: jueves, 17 de octubre de 2019 3:41
Para: [email-masked]; [email-masked]
CC: OpsAWG Chairs <[email-masked]>
Asunto: Conclusion//RE: WG adoption call for draft-aguado-opsawg-l3sm-l3nm-02

Hi WG,

Authors,

Cheers,
Tianran
> If you support adopting this document please say so, and please give
> an indication of why you think it is important. Also please say if you
> will be willing to review and help the draft.
> If you do not support adopting this document as a starting point for
> work on this topic, please say why.

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: tom petch <[email-masked]>
Date: Fri, 18 Oct 2019 16:19:07 +0000

----- Original Message -----
From: "Oscar González de Dios" <[email-masked]>
Cc: "OpsAWG Chairs" <[email-masked]>
Sent: Friday, October 18, 2019 1:25 PM

Hi Tianran,

draft-ietf-opsawg-l3sm-l3nm-00 has been submitted (only title and date
changed as indicated).

<tp>

There are a number of admin type issues that make it harder for me to
follow and to review.

Formatting
- some lines are far too long for an RFC and so do not display sensibly
on my screen
- the indentation of the tree diagram is considerable making it hard to
read
- the indentation of the YANG module is too small for an RFC making it
hard to read
- the SECTION TITLES are mostly capitalised making it ....
- YANG module must have CODE BEGINS CODE ENDS

            |-------------------- EXAMPLE --------------------|
not sure what this is doing (but I can guess:-)

organisation should not be   "Individual draft";

contact needs WG details

I-D has five editors, YANG module only one - is this correct?

import statements need reference clauses

  reference
    "RFC 8049.";
not sure why this is where it is

Many if not most of the features would be better for reference clauses;
well, make that require AFAICT; better done sooner than later

IANA considerations must be present else no YANG module as per RFC8407

Security Considerations must include the boiler plate as per RFC8407 (in
fact, most of the above stems from RFC8407)

I reckon that you will need some 30 or so Normative References by the
time you are done

Tom Petch

Best Regards and looking forward to advance in the draft and report
implementation, as well as lessons learnts in the interoperability.

Oscar

-----Mensaje original-----
De: Tianran Zhou <[email-masked]>
Enviado el: jueves, 17 de octubre de 2019 3:41
Para: [email-masked]; [email-masked]
CC: OpsAWG Chairs <[email-masked]>
Asunto: Conclusion//RE: WG adoption call for
draft-aguado-opsawg-l3sm-l3nm-02

Hi WG,

Now we conclude the poll and adopt this document as WG draft.
There are reasonable supports that can help the document evolution.
A group of people are now implementing this, bringing in operational
experience.

Authors,
Please republish draft-aguado-opsawg-l3sm-l3nm-02 as
draft-ietf-opsawg-l3sm-l3nm-00 with only the date and file name changed.

Cheers,
Tianran

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
puede contener información privilegiada o confidencial y es para uso
exclusivo de la persona o entidad de destino. Si no es usted. el
destinatario indicado, queda notificado de que la lectura, utilización,
divulgación y/o copia sin autorización puede estar prohibida en virtud
de la legislación vigente. Si ha recibido este mensaje por error, le
rogamos que nos lo comunique inmediatamente por esta misma vía y proceda
a su destrucción.

The information contained in this transmission is privileged and
confidential information intended only for the use of the individual or
entity named above. If the reader of this message is not the intended
recipient, you are hereby notified that any dissemination, distribution
or copying of this communication is strictly prohibited. If you have
received this transmission in error, do not read it. Please immediately
reply to the sender that you have received this communication in error
and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu
destinatário, pode conter informação privilegiada ou confidencial e é
para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
senhoria o destinatário indicado, fica notificado de que a leitura,
utilização, divulgação e/ou cópia sem autorização pode estar proibida em
virtude da legislação vigente. Se recebeu esta mensagem por erro,
rogamos-lhe que nos o comunique imediatamente por esta mesma via e
proceda a sua destruição

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Mon, 28 Oct 2019 11:36:46 +0000

Hello all,

We have discussed with the Authors two big changes in the L3NM model:

  *   Modify hierarchy to create a Network Centric Model.
     *   Remove Site.
     *   Move the Site Network Access as part of the VPN Node
  *   Prune the set of unused set of parameters of the L3SM from the L3NM.
     *   Location info: PE election is already done
     *   Site-diversity related parameters: PE election is already done
     *   Devices: Useless except for IP address in case of management of CPE config
     *   Bearer requested-type / always-on…: Interface is already allocated
     *   Site-vpn-flavor: The RT policy will dictacte this (depends on this level of abstraction of the network model) as well as the attachment of site-network-access to vpn-nodes
     *   Vpn-service-topology: RTs are already allocated
     *   Site-network-access-type: This is known through the type of bearer (only ethernet supported)

I'm attaching the New Tree of the L3NM based on this modifications.

Regards,

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: OPSAWG <[email-masked]> en nombre de Oscar González de Dios <[email-masked]>
Enviado: viernes, 18 de octubre de 2019 7:25
Para: Tianran Zhou <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc: OpsAWG Chairs <[email-masked]>
Asunto: Re: [OPSAWG] Conclusion//RE: WG adoption call for draft-aguado-opsawg-l3sm-l3nm-02

Hi Tianran,

Oscar

-----Mensaje original-----
De: Tianran Zhou <[email-masked]>
Enviado el: jueves, 17 de octubre de 2019 3:41
Para: [email-masked]; [email-masked]
CC: OpsAWG Chairs <[email-masked]>
Asunto: Conclusion//RE: WG adoption call for draft-aguado-opsawg-l3sm-l3nm-02

Hi WG,

Authors,

Cheers,
Tianran