Subject: Re: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

From: Qin Wu <[email-masked]>
Date: Thu, 4 Jun 2020 07:24:30 +0000

Common features, yes, factoring out some reusable groupings from other documents, I am not sure 100% sure, there is some gray area, e.g., ietf-packet-fields has already been defined in RFC8519, it is separated document, when needed, why not just import and reuse it.
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2020年6月4日 13:42
收件人: Qin Wu <[email-masked]>; Joe Clarke (jclarke) <jclarke=[email-masked]>; SAMIER BARGUIL GIRALDO <[email-masked]>
抄送: [email-masked]
主题: RE: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

Hi Qin, all,

The idea is to have a common module listing items that can be reused by other VPN modules than L3NM. This “common” module does not have to be called “common types”.

As such, it is OK to have reusable groupings (e.g., ietf-packet-fields in RFC8519) or even common features (e.g., ietf-softwire-common in RFC8676).

Cheers,
Med

De : OPSAWG [mailto:[email-masked]] De la part de Qin Wu
Envoyé : jeudi 4 juin 2020 06:09
À : Joe Clarke (jclarke); SAMIER BARGUIL GIRALDO
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

发件人: OPSAWG [mailto:[email-masked]] 代表 Joe Clarke (jclarke)
发送时间: 2020年6月4日 0:16
收件人: SAMIER BARGUIL GIRALDO <[email-masked]<mailto:[email-masked]>>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

The module is available in the following PULL REQUEST: https://github.com/IETF-OPSAWG-WG/l3nm/pull/118

I know other *types module have included groupings, but to add groupings in a types module seems wrong to me.  I would just expect typedefs and identities.

[Qin]: We lack a good usage guidance on which kind of groupings should be included in types module,
section 4.3 of RFC8407 said:
“
4.13<https://tools.ietf.org/html/rfc8407#section-4.13>.  Reusable Groupings

   A reusable grouping is a YANG grouping that can be imported by
   another module and is intended for use by other modules.
”
But it didn’t tell us whether the reusable grouping should be in the separate module or in the same type modules as identity and typedef.
Following some published type module examples,e.g.,RFC8294 and draft-ietf-teas-yang-te-types-13 in the RFC queue, it did add some of reusable grouping in the type modules, my impression is grouping that contain newly defined typedef and identities can be added into type modules, grouping in grouping, we need to be very carefully,
There are some guidance on reusable grouping in section 4.3 of RFC8407

---

From: <[email-masked]>
Date: Thu, 4 Jun 2020 07:31:15 +0000

Hi Qin,

I cited ietf-packet-fields as an example if a common module with groupings. Apologies for the confusion.

As you know, we already import ietf-packet-fields and reuse it as much we can in the l3nm current version. We don’t plan to change that.

Cheers,
Med

De : Qin Wu [mailto:[email-masked]]
Envoyé : jeudi 4 juin 2020 09:24
À : BOUCADAIR Mohamed TGI/OLN; Joe Clarke (jclarke); SAMIER BARGUIL GIRALDO
Cc : [email-masked]
Objet : RE: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

Hi Qin, all,

Cheers,
Med