Subject: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

From: Oscar González de Dios <[email-masked]>
Date: Tue, 2 Jun 2020 17:13:38 +0000

Dear OPSAWG colleagues,

                Thanks for participating in the call last week in the L3NM and L2NM module discussions.

Please find bellow the minutes. The presented material is available in https://github.com/IETF-OPSAWG-WG/l3nm/blob/master/Meetings/20200528/l3nm_20200428.pptx

* Date: 27th-May-2020

3NM and L2NM module discussions
* Date: 28-May-2020
* Participants

- Oscar Gonzalez de Dios (Telefonica)
- Samier Barguil (Telefonica)
- Italo Busi (Huawei)
- Adrian Farrel (Old Dog Consulting)
- Med Boucadair (Orange)
- Luis Muñoz (Vodafone)
- Haomian Zheng (Huawei)

1. Agenda

L3NM
   - Service Types common module discussions: Proposal of groupings/containers/identities subject to be part of these common types to evaluate if it makes sense. issue https://github.com/IETF-OPSAWG-WG/l3nm/issues/110 It is related to https://github.com/IETF-OPSAWG-WG/l3nm/issues/32
   - RT / RD autoasignment https://github.com/IETF-OPSAWG-WG/l3nm/issues/114 and https://github.com/IETF-OPSAWG-WG/l3nm/issues/20 and mailing list dicussions
   - New issue: differentiate routing vs forwarding policy https://github.com/IETF-OPSAWG-WG/l3nm/issues/113 Related to https://github.com/IETF-OPSAWG-WG/l3nm/issues/18
   - New issue: poionter to ietf routing policy? https://github.com/IETF-OPSAWG-WG/l3nm/issues/117
   - Cleaned issues solved in github long time ago but that had not been closed.
   - Open issues to discuss for the June call

L2NM
   - L2NM. Basic  EVPN support. Need of expert reviewer.
   - L2NM issues https://github.com/oscargdd/l2nm/issues

2. L3NM discussions

1. Service Types common module discussions: Proposal of groupings/containers/identities subject to be part of these common types to evaluate if it makes sense. issue https://github.com/IETF-OPSAWG-WG/l3nm/issues/110 It is related to https://github.com/IETF-OPSAWG-WG/l3nm/issues/32
- Oscar presents the common structures used between L3SM, L3NM and L2NM.
- Oscar Presents 1st proposal for common structures. To generate the vpn-types modules.
- [ITALO]: Reconciliation with the CCAMP and the client SIgnal model and the L2NM is still pending. Differences/similarities must be arisen.
- In ccamp the types are progressing in parallel with at least one draft
- [Med]: It will not remove complexity creating the common types. But it is good to avoid the dependencies.
- [Med] If we go that path, we could have in addition to types, structures?
- [Med] In L2NM we started with similar structures. It is better not to duplicate
- [Italo] In ccamp it is common types, but there are also groupings.
- [Med] Even for reviewing the documents, the split is good.

2.  RT / RD autoasignment (not discussed, invite Roque to next call and follow discussions in mailing list)
3. Discussion on policies.
[Oscar] Issue https://github.com/IETF-OPSAWG-WG/l3nm/issues/113 proposes to diffentiate forwarding policy (that is, policies aimed at the packets coming to the interface) vs routing policies (aimed at the routing protocols, either CE-PE or interally via MP-BGP)
[Oscar] Issue https://github.com/IETF-OPSAWG-WG/l3nm/issues/117 asks if it is ok to have just an id of the profile or add a leafref to where the actual policy is defined.
[Oscar] Is forwarding profile useful?
[Med]. Separating forwarding from routing policy is fine.
[Oscar] Do we need to add a leafref to the profile itself?
[Med]. Having just an id is fine. If we need to add more, we need to be consistent.
[Qin]. SUPA working group tried to abstract policies but failed. We understand the use cases. The confusion is why is it called "forwarding policy".
[Adrian]. Caution about opening rattle. Have a simple in hook in the module (if someone has implemented a policy module, go there). Just put a hook. Then, tell the working groups working in policies.
[Med]: for the extension to ACL, go to Netmod. Or extend it (be specific)
[Luis]: avoid extending it here. If there is consensus on forwarding and routing, ok, just add the hooks.

3 L2NM discussions

  - L2NM. Basic  EVPN support. Need of expert reviewer.
[Oscar] Presented issue https://github.com/oscargdd/l2nm/issues/1
[Qin] Will find internally EVPN experts.
[Oscar] Presented issue https://github.com/oscargdd/l2nm/issues/6
[Italo] There was a similar issue in TEAS. Check with Tarek and Igor.

                Looking forward for the call on Thursday.

                Oscar

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Wed, 3 Jun 2020 15:35:53 +0000

Dear OPSAWG colleagues,

As we discuss in the last meeting. An initial proposal for the ietf-vpn-types.yang has been developed.

Currently, the module includes the following elements:

The module is available in the following PULL REQUEST: https://github.com/IETF-OPSAWG-WG/l3nm/pull/118

Regards,

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 3017026430

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: OPSAWG <[email-masked]> en nombre de Oscar González de Dios <[email-masked]>
Enviado: martes, 2 de junio de 2020 12:13
Para: [email-masked] <[email-masked]>
Asunto: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

AVISO/WARNING: Este mail se ha originado fuera de la organización y no se pudo verificar al remitente / This mail was originated outside the organization and the sender could not be verified

Dear OPSAWG colleagues,

* Date: 27th-May-2020

* Date: 28-May-2020

* Participants

- Italo Busi (Huawei)

- Med Boucadair (Orange)

- Luis Muñoz (Vodafone)

- Haomian Zheng (Huawei)

1. Agenda

L3NM

L2NM

2. L3NM discussions

- [Med]: It will not remove complexity creating the common types. But it is good to avoid the dependencies..

[Luis]: avoid extending it here.. If there is consensus on forwarding and routing, ok, just add the hooks.

3 L2NM discussions

                Oscar

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Wed, 3 Jun 2020 16:15:51 +0000

On Jun 3, 2020, at 11:35, SAMIER BARGUIL GIRALDO <[email-masked]<mailto:[email-masked]>> wrote:

Dear OPSAWG colleagues,

I know other *types module have included groupings, but to add groupings in a types module seems wrong to me.  I would just expect typedefs and identities.

And on that topic, your operational-type is used for both admin and oper status.  It seems to me that admin status would either be up or down (or maybe something like testing such as in the ietf-interfaces module).  The oper-status may be richer.

And in your grouping for service-status, you have a timestamp tied to admin that should indicate the _actual_ date and time of the service being up or down.  This won’t necessarily be the case for an admin status.

Joe

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Fri, 5 Jun 2020 10:12:08 +0000

Dear OPSAWG colleagues,

I've updated the pull request https://github.com/IETF-OPSAWG-WG/l3nm/pull/118 according to the last discussion.

The main changes includes:

  *   Common grouping for status at VPN-Service, VPN-Node and VPN-Network-Access-Level.

                 +--rw status

                 |  +--rw admin-status?   identityref

                 |  +--ro oper-status

                 |     +--ro status?      identityref

                 |     +--ro timestamp?   yang:date-and-time

  *   Set of identities for:
     *   Operational and Administrative status.
  *   Time-Stamp just for Operational status.

Regards,

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

________________________________
De: SAMIER BARGUIL GIRALDO <[email-masked]>
Enviado: miércoles, 3 de junio de 2020 10:35
Para: [email-masked] <[email-masked]>
Cc: Oscar González de Dios <[email-masked]>
Asunto: RE: Minutes of L3NM/L2NM module discussions (27th-May-2020)

Dear OPSAWG colleagues,

Regards,

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

Dear OPSAWG colleagues,

* Date: 27th-May-2020

* Date: 28-May-2020

* Participants

- Italo Busi (Huawei)

- Med Boucadair (Orange)

- Luis Muñoz (Vodafone)

- Haomian Zheng (Huawei)

1. Agenda

L3NM

L2NM

2. L3NM discussions

3 L2NM discussions

                Oscar

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 5 Jun 2020 13:25:30 +0000

On Jun 5, 2020, at 06:12, SAMIER BARGUIL GIRALDO <[email-masked]<mailto:[email-masked]>> wrote:

Dear OPSAWG colleagues,

                 +--rw status

  *   Set of identities for:

Not sure you needed testing per se (I was just citing it as an example).  Plus, your description for it still points to UNKNOWN.  That said, I think this works better overall.

As for the module itself, I personally think a “common” name suits it better than “types” because of the additional groupings.

Joe

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Fri, 5 Jun 2020 14:09:47 +0000

Thanks for your feedback Joe,

I thinks is a good approach. The model has been renamed to "common" instead of "types".

Regards

Samier Barguil

Móvil +57 3017026430

Móvil +34 665416074

________________________________
De: Joe Clarke (jclarke) <[email-masked]>
Enviado: viernes, 5 de junio de 2020 8:25
Para: SAMIER BARGUIL GIRALDO <[email-masked]>
Cc: [email-masked] <[email-masked]>
Asunto: Re: [OPSAWG] Minutes of L3NM/L2NM module discussions (27th-May-2020)

Dear OPSAWG colleagues,

                 +--rw status

  *   Set of identities for:

Joe