Subject: Re: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Tue, 16 Jun 2020 21:16:52 +0000

Hi Joe,

I support adding an L2NM model to our WG. I would recommend changing the name to simply "draft-ietf-opsawg-l2nm".

Here are my initial comments that I wish the author to address as we move into WG item:

1) I believe L2NM should not have dependencies on other service definitions just to import types and instance definitions (L2SM and L3NM in particular for this draft), as discussed for L3NM, it is best to either write a common type module or define them locally in every module.

2) I found a difference on how we work in L3NM and consistency between the two modules would be desired (although not mandatory):
	list vpn-node {
		  key "vpn-node-id ne-id";   <--- In L3NM we only use ne-id

I will be happy to continue providing feedback.

Best regards,
Roque

On 16.06.20, 16:18, "OPSAWG on behalf of Joe Clarke (jclarke)" <[email-masked] on behalf of jclarke=[email-masked]> wrote:

    Hello, opsawg.  I hope everyone is doing well.

    This starts a two-week poll for adoption of the L2 network module document.  There does seem to be interest in this work, and it is progressing nicely in GitHub with side meetings.  There appears to be questions on what will be broken out into commonality between this module and the L3NM (work which is also underway).  So while we anticipate changes to this draft, the chairs think it’s reached a point where we’d like to see if the WG wants to formally adopt the work.

    Please reply on-list with your comments on the draft and whether or not you support its WG adoption.  We will conclude this call on June 30, 2020.

    Thanks.

    Joe
    _______________________________________________
    OPSAWG mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/opsawg

---

From: Qin Wu <[email-masked]>
Date: Wed, 17 Jun 2020 01:19:44 +0000

Joe:
I support adoption, I think the model proposed in this draft is a good starting point. We need to see how this model can be extended to support various different flavor of L2VPN, EVPN is one of important flavor.
I also believe factoring out common model is a good approach. Reviewing the latest version of common VPN model, I think referencing data outside the grouping in any "path" statements should be avoided.

-Qin
-----邮件原件-----
发件人: OPSAWG [mailto:[email-masked]] 代表 Joe Clarke (jclarke)
发送时间: 2020年6月16日 22:18
收件人: opsawg <[email-masked]>
主题: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

Thanks.

Joe

---

From: [email-masked]
Date: Tue, 23 Jun 2020 16:22:12 +0000

I support this work and WG adoption

Thanks,
Luay

From: Luay Jalil <[email-masked]>
Date: Tuesday, June 23, 2020 at 11:08 AM
To: Luay <[email-masked]>
Subject: [E] Fwd: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

Luay

-----Original Message-----
From: Joe Clarke (jclarke) [mailto:[email-masked]]
To: opsawg <[email-masked]>
Subject: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm
 Hello, opsawg.  I hope everyone is doing well.
 This starts a two-week poll for adoption of the L2 network module document.
There does seem to be interest in this work, and it is progressing nicely in
GitHub with side meetings.  There appears to be questions on what will be
broken out into commonality between this module and the L3NM (work which
is also underway).  So while we anticipate changes to this draft, the chairs
think it’s reached a point where we’d like to see if the WG wants to formally
adopt the work.
 Please reply on-list with your comments on the draft and whether or not you
support its WG adoption.  We will conclude this call on June 30, 2020.
 Thanks.

Joe

---

From: MUÑOZ, LUIS ANGEL, Vodafone Spain <[email-masked]>
Date: Tue, 23 Jun 2020 17:05:16 +0000

Hello

I support this work as a complement to other pieces we intend to use for network driven model management.
It is planned to push the adoption as an operator as soon as it's ready.

Thanks and regards
Luis
________________________________
De: OPSAWG <[email-masked]> en nombre de Joe Clarke (jclarke) <jclarke=[email-masked]>
Enviado: martes, 16 de junio de 2020 9:17
Para: opsawg <[email-masked]>
Asunto: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

This starts a two-week poll for adoption of the L2 network module document.  There does seem to be interest in this work, and it is progressing nicely in GitHub with side meetings.  There appears to be questions on what will be broken out into commonality between this module and the L3NM (work which is also underway).  So while we anticipate changes to this draft, the chairs think it?s reached a point where we?d like to see if the WG wants to formally adopt the work.

Thanks.

Joe

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener informaci?n privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilizaci?n, divulgaci?n y/o copia sin autorizaci?n puede estar prohibida en virtud de la legislaci?n vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma v?a y proceda a su destrucci?n.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinat?rio, pode conter informa??o privilegiada ou confidencial e ? para uso exclusivo da pessoa ou entidade de destino. Se n?o ? vossa senhoria o destinat?rio indicado, fica notificado de que a leitura, utiliza??o, divulga??o e/ou c?pia sem autoriza??o pode estar proibida em virtude da legisla??o vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destrui??o
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/opsawg/attachments/20200616/a04dfb11/attachment.htm>

------------------------------

Message: 7
Date: Tue, 16 Jun 2020 15:50:53 +0000
From: SAMIER BARGUIL GIRALDO
        <[email-masked]>
To: Oscar Gonz?lez de Dios  <[email-masked]>,
        Italo Busi <[email-masked]>, tom petch <[email-masked]>,
        "[email-masked]" <[email-masked]>,  "'Joe Clarke (jclarke)'"
        <jclarke=[email-masked]>
Cc: 'opsawg' <[email-masked]>
Subject: Re: [OPSAWG] Common service models types yang ?
Message-ID:
        <[email-masked]>

Content-Type: text/plain; charset="iso-8859-1"

Hello all,

Based on the previous discussion, I have updated a proposal of the vpn-common yang file (https://github.com/IETF-OPSAWG-WG/l3nm/pull/122).
[https://avatars1.githubusercontent.com/u/60149792?s=400&v=4]<https://github.com/IETF-OPSAWG-WG/l3nm/pull/122>
vpn-common extended proposal and l3vn-ntw whiout gruopings. by sbarguil ? Pull Request #122 ? IETF-OPSAWG-WG/l3nm<https://github.com/IETF-OPSAWG-WG/l3nm/pull/122>
L3NM no groupings VPN common updates with features, typedef and identityes.
github.com

Additionally, I have removed all the un-reused groupings of the L3NM as the yang-doctor suggested (https://github.com/IETF-OPSAWG-WG/l3nm/issues/111) to consolidadete the whole structure directly.
[https://avatars1.githubusercontent.com/u/60149792?s=400&v=4]<https://github.com/IETF-OPSAWG-WG/l3nm/issues/111>
Fix issues from Yang doctor review ? Issue #111 ? IETF-OPSAWG-WG/l3nm<https://github.com/IETF-OPSAWG-WG/l3nm/issues/111>
Yang doctor review in: https://datatracker.ietf.org/doc/draft-ietf-opsawg-l3sm-l3nm/reviewrequest/13293/ https://mailarchive.ietf.org/arch/msg/yang-doctors/dO9I3gdwFL7wL-cm-fpXSUhOlzY Reviewer: Rad...
github.com
Currently, I have created a parallel file for revsion. Once the revision is complete I can copy as the last yang-file.

The diff file and the trees are attached, so you can see the differences.

Reagards,

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

M?vil +57 3017026430

M?vil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: OPSAWG <[email-masked]> en nombre de Oscar Gonz?lez de Dios <[email-masked]>
Enviado: martes, 2 de junio de 2020 12:36
Para: Italo Busi <[email-masked]>; tom petch <[email-masked]>; [email-masked] <[email-masked]>; 'Joe Clarke (jclarke)' <jclarke=[email-masked]>
Cc: 'opsawg' <[email-masked]>
Asunto: [OPSAWG] Common service models types yang ?

AVISO/WARNING: Este mail se ha originado fuera de la organizaci?n y no se pudo verificar al remitente / This mail was originated outside the organization and the sender could not be verified

Hi guys,

    Thanks for all your advices. It seems that having a service models common types can be positive and on the other hand, we have all a lot of warnings to do it with care, (not just extracting everything that seems common, types, groupings, containers.. which can be a bad outcome).

    Hence, Joe, WG chairs, will it make sense that within the working group, with the guidance of people that have been involved in similar common types experiences, we work to define what would make sense, because it is something applicable to VPN services in general, make a first proposal, discuss it, and then decide if it is worth as a service types common module?

    My 2 cents to start is the proposal in slide #4 in https://github.com/IETF-OPSAWG-WG/l3nm/blob/master/Meetings/20200528/l3nm_20200428.pptx Reproducing it here, part of this common types module definitions could be:

* Service status (operative and administrative status, up & down)
* Underlay transport (all VPNs require a transport, which could be based on traffic engineering such as SR-TE or RSVP-TE, based on LDP, etc)
*  Encapsulation type (in the CE-PE interface the encapsulation options can be Dot1q, QinQ,...etc)
* RTs/RDs (while this is mainly for L3 VPNs, for L2 we have also the case of BGP-VPLS )
* Service profiles (routing profiles, QoS profiles, etc..)
* Service topology (example hub & spoke, custom...)

    Comments? More suggestions?

   Best Regards,

Oscar

C2 General

-----Mensaje original-----
De: Italo Busi <[email-masked]>
Enviado el: viernes, 29 de mayo de 2020 15:05
Para: tom petch <[email-masked]>; [email-masked]; 'Joe Clarke (jclarke)' <jclarke=[email-masked]>; Oscar Gonz?lez de Dios <[email-masked]>
CC: 'opsawg' <[email-masked]>
Asunto: RE: [OPSAWG] Minutes of L3NM/L2NM module discussions

Tom,

The difficulties with layer0-types were due to the complexity of the technology we were trying to model.

Having a common layer0-types has actually helped a lot since only one module (the layer0-types) had to go through "several revolutions" instead of the six modules which depends on it.

There were also some technical issues in one draft which were discovered by people working on other draft only after the code was moved to the layer0-types. This helped at least to discover the issues earlier in the process.

Italo

> From: tom petch [mailto:[email-masked]]
> Sent: venerd? 29 maggio 2020 12:48
> To: Italo Busi <[email-masked]>; [email-masked]; 'Joe
> Clarke (jclarke)' <jclarke=[email-masked]>; 'Oscar Gonz?lez de Dios'
> <[email-masked]>
> Cc: 'opsawg' <[email-masked]>
> Subject: Re: [OPSAWG] Minutes of L3NM/L2NM module discussions
>
> From: Italo Busi <[email-masked]>
> Sent: 29 May 2020 08:56
>
> I support developing a separate module for the common types/groupings/...
>
> This approach has worked quite well within TEAS and CCAMP WG.
>
> I agree that there are some risks with this work: my suggestion is
> just be aware of the risks and be careful to avoid them.
>
> Working in parallel on L3NM, L2NM and the common modules would really
> help identifying what is really common and what it is not.
>
> The suggestion we have got in CCAMP WG was not to send to IESG the
> common module alone but to send it with at least one of the modules
> importing it.
>
> I would suggest to follow the same approach in OPSWG if a separate
> module for the common types/groupings/... is developed.
>
> <tp>
> I asked what the four documents were since AFAICT two are published
> RFC, and that has been confirmed.  So what is going to happen to those RFC?
>
> And as you will know from CCAMP, layer0 types has undergone several
> revolutions before getting to its current state.  These common
> identity etc are hard to get right in the IETF.
>
> Tom Petch
>
> Italo
>
> > From: Adrian Farrel [mailto:[email-masked]]
> > Sent: gioved? 28 maggio 2020 19:15
> > To: 'tom petch' <[email-masked]>; 'Joe Clarke (jclarke)'
> > <jclarke=[email-masked]>; 'Oscar Gonz?lez de Dios'
> > <[email-masked]>
> > Cc: 'opsawg' <[email-masked]>
> > Subject: Re: [OPSAWG] Minutes of L3NM/L2NM module discussions
> >
> > OK, thanks, that's clear.
> >
> > I *think* (I was on the call where this was discussed) that it was
> > exactly the worry about importing a whole module that led to the
> > suggestion of having a separate module just for common types. As I
> > understand it, there was a desire to have a common type used in
> > several modules, but some implementers felt that this would lead
> > them to have to import the whole module (not just the type).
> >
> > The idea of a separate module certainly has some risks associated:
> > not capturing the right things; including too much "stuff"; forcing
> > commonality where none exists.
> >
> > There is, as you suggest, an alternative that each module goes its
> > own way and there is no sharing. I *think* we received a strong
> > steer that sharing is a good idea.
> >
> > Best,
> > Adrian
> >
> > From: tom petch <[email-masked]>
> > Sent: 28 May 2020 17:26
> > To: 'Joe Clarke (jclarke)' <jclarke=[email-masked]>;
> > 'Oscar Gonz?lez de Dios' <[email-masked]>;
> > [email-masked]
> > Cc: 'opsawg' <[email-masked]>
> > Subject: Re: [OPSAWG] Minutes of L3NM/L2NM module discussions
> >
> > From: Adrian Farrel <[email-masked]>
> > Sent: 28 May 2020 14:29
> >
> > Hey Tom,
> >
> > Is there a typo in your email? You said...
> >
> > > So carving out the current types (etc) will likely lead to a bad
> > > outcome; it is a question of looking carefully across the range of
> > > documents to see what is, or is likely to be common.
> >
> > I wondered whether you intended a "not" in there somewhere.
> >
> > <tp>
> > Adrian,
> > no, no 'not' was intended.  The danger is taking e.g. the 50 or so
> > pages of identity, typedef, grouping in L2NM and assuming that they
> > form a good starting point or, worse still, making a logical OR of
> > the four documents under consideration and to create a monster
> > document and assuming that that is a good basis.
> >
> > Critical assessment is what is needed IMHO.  Sometimes it is better
> > to create your own version of vpn-id or ODUC than import a hundred
> > pages of someone else's in order to get them.
> >
> > Tom Petch
> >
> > If you wrote what you intended, could you explain a little further
> > what the danger is?
> >
> > Best,
> > Adrian
> >
> > From: OPSAWG <[email-masked]> On Behalf Of tom petch
> > Sent: 26 May 2020 17:05
> > To: Joe Clarke (jclarke) <jclarke=[email-masked]>; Oscar
> > Gonz?lez de Dios <[email-masked]>
> > Cc: opsawg <[email-masked]>
> > Subject: Re: [OPSAWG] Minutes of L3NM/L2NM module discussions
> >
> > From: OPSAWG <[email-masked]> on behalf of Joe Clarke
> > (jclarke) <jclarke=[email-masked]>
> > Sent: 21 May 2020 15:43
> >
> >
> >
> > 2. L3NM
> >     Revision of the three main issues:
> > Implementation Report by Cisco. It has two main issues
> > (https://github.com/IETF-OPSAWG-WG/l3nm/issues/110)
> > - Common module to have all the L3NM specific requirements.
> > Type-like module.
> > [Anton]: It makes implementation simpler. Does not generate
> > unnecessary dependencies
> > [Adrian]: It depends on if we need module for specific types, to
> > avoid unnecessary imports. Also don't you only need to import types,
> > not the entire module?
> > [Qin]: With L3SM we did not take an augmentation approach. If there
> > are common types defined in both models, then we may need to find
> > the common components. We should decouple of L3SM.
> > [Sriram]: Prefer to have a separate type-file for the specific parameters.
> > [Oscar]: Define a common type-file for the service models.
> > [Qin]: Is it possible to manage it as an independent draft?
> >
> > [Oscar in github issues]: After the discussions, it seems reasonable
> > to have a separate Yang module to contain the types. The suggestion
> > is to write the module to cover the four service models (client
> > service models, l3sm, l2sm and Network service models, l2nm, l3nm).
> > It seems reasonable to include this module in l3nm draft instead of
> > creating a new
> one to avoid dependencies.
> > Samier, Dan and Anton to collaborate for a first version of the
> > split
> >
> > As chair, I want to call this out since it sounds like the authors
> > made a decision here, and I want to make sure the whole WG has a
> > chance to weigh in.  In reading these minutes and issue #110, I can
> > see the value of a types module to avoid what may be confusing
> > imports, but I want to know if anyone on the WG has a different opinion.
> >
> > <tp>
> > Joe
> > The four documents are not spelled out but referred to in shorthand
> > and while I think I know which are intended, that IMHO needs spelling out.
> > In principle, a common types is a no-brainer provided it is done
> > early enough - before anything becomes an RFC! - and with limited enough scope.
> > NETMOD got it right but did have decades of SMI experience to go on,
> > RTGWG got it right, with TEAS it is less clear while layer0-types
> > has changed much over its short life - is it right now? May be.
> > So carving out the current types (etc) will likely lead to a bad
> > outcome; it is a question of looking carefully across the range of
> > documents to see what is, or is likely to be common.  The higher up
> > the stack you go the more likely items are to be common but equally
> > the more likely it is that someone has been there already.
> > And if you look at existing types modules, it took a while for the
> > penny to drop but they end up as separate I-D, better still with a
> > different author to the importing I-D; a no brainer really.
> >
> > Tom Petch
> >
> > Joe
> >
> >
> > =

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener informaci?n privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilizaci?n, divulgaci?n y/o copia sin autorizaci?n puede estar prohibida en virtud de la legislaci?n vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma v?a y proceda a su destrucci?n.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinat?rio, pode conter informa??o privilegiada ou confidencial e ? para uso exclusivo da pessoa ou entidade de destino. Se n?o ? vossa senhoria o destinat?rio indicado, fica notificado de que a leitura, utiliza??o, divulga??o e/ou c?pia sem autoriza??o pode estar proibida em virtude da legisla??o vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destrui??o

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener informaci?n privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilizaci?n, divulgaci?n y/o copia sin autorizaci?n puede estar prohibida en virtud de la legislaci?n vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma v?a y proceda a su destrucci?n.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinat?rio, pode conter informa??o privilegiada ou confidencial e ? para uso exclusivo da pessoa ou entidade de destino. Se n?o ? vossa senhoria o destinat?rio indicado, fica notificado de que a leitura, utiliza??o, divulga??o e/ou c?pia sem autoriza??o pode estar proibida em virtude da legisla??o vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destrui??o
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/opsawg/attachments/20200616/f1d7aa0d/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ietf-l3vpn-ntw-sg.tree
Type: application/octet-stream
Size: 26427 bytes
Desc: ietf-l3vpn-ntw-sg.tree
URL: <https://mailarchive.ietf.org/arch/browse/opsawg/attachments/20200616/f1d7aa0d/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ietf-l3vpn-ntw.tree
Type: application/octet-stream
Size: 26680 bytes
Desc: ietf-l3vpn-ntw.tree
URL: <https://mailarchive.ietf.org/arch/browse/opsawg/attachments/20200616/f1d7aa0d/attachment-0001.obj>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: diff.txt
URL: <https://mailarchive.ietf.org/arch/browse/opsawg/attachments/20200616/f1d7aa0d/attachment.txt>

------------------------------

Subject: Digest Footer

------------------------------

End of OPSAWG Digest, Vol 157, Issue 12
***************************************

---

From: "Peng Liu" <[email-masked]>
Date: Tue, 30 Jun 2020 10:26:31 +0800

Hi All,
I support adoption.Peng Liu

Peng Liu | 刘鹏
China Mobile | 移动研究院
mobile phone：13810146105
email:  [email-masked]

Thanks.

Joe

---

From: "Wubo (lana)" <[email-masked]>
Date: Tue, 30 Jun 2020 09:22:24 +0000

Hi,

I support the WG adoption of the draft.
I have read the draft, and believe it is a useful piece to L2VPN service management automation.

Best regards,
Bo

-----邮件原件-----
发件人: OPSAWG [mailto:[email-masked]] 代表 Joe Clarke (jclarke)
发送时间: 2020年6月16日 22:18
收件人: opsawg <[email-masked]>
主题: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

Thanks.

Joe