Subject: Re: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Wed, 1 Jul 2020 13:41:04 +0000

This concludes the call for adoption of this document.  Tom Petch expressed concern that the work on breaking out the common parts between this document and the L3NM (currently underway) might change the document that gets adopted.  This is a valid concern; however, the L3NM is already adopted and will be changing in a similar fashion.  I replied as much to Tom that as an individual, I’d like to see this work combined under the opsawg umbrella.

Given no other opposition and otherwise strong support for adoption, this document has been adopted by opsawg.  Authors, please rename this document to draft-ietf-opsawg-l2nm (I believe it was stated this was the desired name), upload it as such to data tracker with a -00 rev.  DO NOT change anything else in the document.

When uploading to DT, make sure you mark that this new document replaces draft-barguil-opsawg-l2sm-l2nm so that history is preserved.

Thanks.

Joe

> On Jun 16, 2020, at 10:17, Joe Clarke (jclarke) <jclarke=[email-masked]> wrote:
> 
> Hello, opsawg.  I hope everyone is doing well.
> 
> This starts a two-week poll for adoption of the L2 network module document.  There does seem to be interest in this work, and it is progressing nicely in GitHub with side meetings.  There appears to be questions on what will be broken out into commonality between this module and the L3NM (work which is also underway).  So while we anticipate changes to this draft, the chairs think it’s reached a point where we’d like to see if the WG wants to formally adopt the work.
> 
> Please reply on-list with your comments on the draft and whether or not you support its WG adoption.  We will conclude this call on June 30, 2020.
> 
> Thanks.
> 
> Joe
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Oscar González de Dios <[email-masked]>
Date: Thu, 2 Jul 2020 11:23:01 +0000

Hi Joe,

The document draft-ietf-opsawg-l2nm has been uploaded changing only the name and date and replacing draft-barguil-opsawg-l2sm-l2nm.

Best Regards and looking forward to keep progressing both l3nm and l2m!

Oscar

-----Mensaje original-----
De: OPSAWG <[email-masked]> En nombre de Joe Clarke (jclarke)
Enviado el: miércoles, 1 de julio de 2020 15:41
Para: Joe Clarke (jclarke) <jclarke=[email-masked]>
CC: opsawg <[email-masked]>
Asunto: Re: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

Thanks.

Joe

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 2 Jul 2020 14:46:59 +0000

> On Jul 2, 2020, at 07:23, Oscar González de Dios <[email-masked]> wrote:
> 
> Hi Joe,
> 

Thanks, Oscar.  Now that this is a WG document, please make sure you bring your GH/side meeting work to the list to get consensus and comments from the entire WG.  Tom’s concern over the common module break down is valid, and the WG needs to be able to weigh in on how that is shaping up.

Joe

---

From: Oscar González de Dios <[email-masked]>
Date: Fri, 3 Jul 2020 07:33:30 +0000

Thanks, Joe

Sure!

With regards to the L* modules split issue, given the feedback we received as a follow-up to the minutes sent to the list back in May https://mailarchive.ietf.org/arch/msg/opsawg/FQ5gJ1gN8aHWVpUQea6Of0_0elw/,  we worked on a common VPN module proposal.

The rationale for creating the common module is documented in the candidate -04 (https://github.com/IETF-OPSAWG-WG/l3nm/blob/master/I-D-L3NM/draft-ietf-opsawg-l3sm-l3nm-04.txt):

   The "ietf-vpn-common" module includes a set of identities, types, and  groupings that are meant to be reused by other VPN-related YANG modules independently of the layer (e.g., Layer 2, Layer 3) and the type of the module (e.g., network model, service model) including future revisions of existing models (e.g., [RFC8299] or [RFC8466]). The approach that was followed for building this common module is to  first extract nodes that are common for both L3NM and L3SM; these nodes are then filtered out against Layer 2 modules.  All the common grouping are called in the L3NM module defined in this document.

   In order to avoid data duplication and optionally to ease passing  data between layers (service layer to network layer and vice versa), early versions of the L3NM reused many of the data nodes that are defined in [RFC8299].  Nevertheless, that approach was abandoned in  favor of the "ietf-vpn-common" module because that design was interpreted as if the deployment of L3NM depends on L3SM, while this is not the case.  For example, a Service Provider may decide to use the L3NM to build its L3VPN services without exposing the L3SM.

The candidate Common Module, which we consider can be reviewed by the WG, is available in: https://github.com/IETF-OPSAWG-WG/l3nm/blob/master/yang/IETF-04/ietf-vpn-common.yang

Please, WG, look at the common yang proposal and let us know if this is the good direction and we can move forward in the direction of the ietf-vpn-common yang split.

Thank you and Best Regards,

Oscar

-----Mensaje original-----
De: Joe Clarke (jclarke) <[email-masked]>
Enviado el: jueves, 2 de julio de 2020 16:47
Para: Oscar González de Dios <[email-masked]>
CC: opsawg <[email-masked]>
Asunto: Re: [OPSAWG] CALL FOR ADOPTION: draft-barguil-opsawg-l2sm-l2nm

Joe