Subject: [OPSAWG] OSS SAIN Agent

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 28 Jul 2020 16:08:11 +0000

Korian, thank you for the presentation in OpsA today.  I have to say, this is the first I’ve seen the OSS SAIN Agent, and I like the work.  I agree with your assessment that, in general, the quality and quantity of rules is going to be key to success.  Even low-hanging fruit rules for things like running processes and interface errors will be helpful.  Of course, more complex service assurance rules like buffer availability, FIB integrity, etc. (like you showed with VPP huge pages) will add more value.

What changes, if any, did this work do to the SAIN YANG modules?

Joe

---

From: korian edeline <[email-masked]>
Date: Tue, 28 Jul 2020 18:44:06 +0200

Hello Joe,

> Korian, thank you for the presentation in OpsA today.  I have to say, this is the first I’ve seen the OSS SAIN Agent, and I like the work.  I agree with your assessment that, in general, the qualit…
thanks!
> What changes, if any, did this work do to the SAIN YANG modules?

We had a few discussions with Benoit and Eric, and I believe it lead to 
a few changes among them: introduction of symptom-history-start, the 
update on assurance-graph-timestamp, assurance-graph-version and 
label-change, minor inconsistencies in label/description [1], and the 
addition of section 3.10 in [2].

[1] 
https://www.ietf.org/rfcdiff?url2=draft-claise-opsawg-service-assurance-yang-05

[2] 
https://tools.ietf.org/rfcdiff?url2=draft-claise-opsawg-service-assurance-architecture-03.txt

Korian

-- 

Korian Edeline
Université de Liège (ULg)
Bât. B28  Algorithmique des Grands Systèmes
Quartier Polytech 1
Allée de la Découverte 10
4000 Liège
Phone: +32 4 366 56 05