Subject: [OPSEC] I-D Action: draft-ietf-opsec-v6-20.txt

From: [email-masked]
Date: Sat, 12 Oct 2019 00:33:11 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Operational Security Capabilities for IP Network Infrastructure WG of the IETF.

        Title           : Operational Security Considerations for IPv6 Networks
        Authors         : Eric Vyncke
                          Kiran K. Chittimaneni
                          Merike Kaeo
                          Enno Rey
	Filename        : draft-ietf-opsec-v6-20.txt
	Pages           : 52
	Date            : 2019-10-12

Abstract:
   Knowledge and experience on how to operate IPv4 securely is
   available: whether it is the Internet or an enterprise internal
   network.  However, IPv6 presents some new security challenges.  RFC
   4942 describes the security issues in the protocol but network
   managers also need a more practical, operations-minded document to
   enumerate advantages and/or disadvantages of certain choices.

   This document analyzes the operational security issues in several
   places of a network (enterprises, service providers and residential
   users) and proposes technical and procedural mitigations techniques.
   Some very specific places of a network such as the Internet of Things
   are not discussed in this document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-opsec-v6/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-opsec-v6-20
https://datatracker.ietf.org/doc/html/draft-ietf-opsec-v6-20

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 12 Oct 2019 07:40:52 +0000

As you will notice in https://www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20 this latest revision addresses a suggestion by Gyan Mishra issued during the Working Group Last Call. Other changes are mainly replacing the normative "MUST" and "SHOULD" as it is an informational document (so it is now "must" and "should") + removing an unused informational reference.

Jen and Ron, as the authors have addressed all comments received during the WGLC (actually by only one reviewer) and the extensive review by Jen, may I kindly request publication of this document?

Thank  you all

-éric -merike - kk -enno

On 12/10/2019, 09:34, "OPSEC on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    
    
    _______________________________________________
    OPSEC mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/opsec

---

From: Ron Bonica <[email-masked]>
Date: Mon, 14 Oct 2019 23:14:45 +0000

Jen,

I am ready to request publication. But before we do that, we need a document shepherd.

Eric,

Was there anyone who was close to the draft, but not a co-author. We can victimteer that person.

                                                      Ron

Juniper Business Use Only

-----Original Message-----
From: Eric Vyncke (evyncke) <[email-masked]> 
Sent: Saturday, October 12, 2019 3:41 AM
To: [email-masked]
Cc: Jen Linkova <[email-masked]>; Ron Bonica <[email-masked]>
Subject: Re: [OPSEC] I-D Action: draft-ietf-opsec-v6-20.txt

As you will notice in https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCfC0QrYg$  this latest revision addresses a suggestion by Gyan Mishra issued during the Working Group Last Call. Other changes are mainly replacing the normative "MUST" and "SHOULD" as it is an informational document (so it is now "must" and "should") + removing an unused informational reference.

Thank  you all

-éric -merike - kk -enno

    
    
    Abstract:

    The IETF datatracker status page for this draft is:
    https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-opsec-v6/__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCVgtmnGd$ 
    
    There are also htmlized versions available at:
    https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCQdAq-nG$ 
    https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCTaFWv3h$ 
    
    A diff from the previous version is available at:
    https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCfC0QrYg$ 

    Internet-Drafts are also available by anonymous FTP at:
    https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCXkuUebd$ 
    
    _______________________________________________
    OPSEC mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/opsec__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCVjA-7t2$

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 14 Oct 2019 19:54:33 -0400

Ron

I read the document thoroughly in its entirety and do have valuable real world experience in this space so I am volunteering.

Not sure what I am getting myself into.😀

Gyan

Sent from my iPhone

> On Oct 14, 2019, at 7:14 PM, Ron Bonica <rbonica=[email-masked]> wrote:
> 
> Jen,
>

---

From: Ron Bonica <[email-masked]>
Date: Tue, 15 Oct 2019 00:14:28 +0000

We have a victimteer! I will request publication......

                                  Ron

-----Original Message-----
From: Gyan Mishra <[email-masked]> 
Sent: Monday, October 14, 2019 7:55 PM
To: Ron Bonica <[email-masked]>
Cc: Eric Vyncke (evyncke) <[email-masked]>; [email-masked]
Subject: Re: [OPSEC] I-D Action: draft-ietf-opsec-v6-20.txt

Ron

Gyan

Sent from my iPhone

> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/opsec__;!8WoA6RjC81c!VnqIjb0Af5mFbeynR6Y3n3JSJLOihoseNIj6ePTntprga02MeYREnPIbCzduWAeD$

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 15 Oct 2019 06:12:29 +0000

Gyan,

Thank you very much for being 'victimteered' as the document shepherd [1] __

Thank you Jen and Ron for your support

Regards

-éric and the authors -kk -merike -enno

[1] see https://datatracker.ietf.org/doc/draft-ietf-opsec-v6/edit/shepherdwriteup/ (you need to create a free account on datatracker if not yet done), the mailing list archive should also be a source of information https://mailarchive.ietf.org/arch/browse/opsec/?q=draft-ietf-opsec-v6

On 15/10/2019, 01:54, "Gyan Mishra" <[email-masked]> wrote:

    Ron

    
    Gyan
    
    Sent from my iPhone

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 24 Oct 2019 14:35:44 -0400

Hi Eric 

I am completing the Shepards writeup in essay format. Plan to submit in the next few days.

As far as WG consensus and history on the document from its initial I-D state were there any nits other then what is public in the tracker or any WG consensus issues or topics discussed that I should be aware of to include in the write up.  I assume we finally reached WG consensus on all topics with no outstanding issues as we are now ready to publish.

Are there any IPRs disclosed or outstanding. 

Regards,

Gyan 

Sent from my iPhone

> On Oct 15, 2019, at 2:12 AM, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 
> Gyan,
>

---

From: KK Chittimaneni <[email-masked]>
Date: Fri, 25 Oct 2019 15:11:20 -0700

Hi Gyan,

No IPRs on my end.

Thanks,
KK

On Thu, Oct 24, 2019 at 11:36 AM Gyan Mishra <[email-masked]> wrote:

> As far as WG consensus and history on the document from its initial I-D
> state were there any nits other then what is public in the tracker or any
> WG consensus issues or topics discussed that I should be aware of to
> include in the write up.  I assume we finally reached WG consensus on all
> topics with no outstanding issues as we are now ready to publish.
>
> > [1] see
> https://datatracker.ietf.org/doc/draft-ietf-opsec-v6/edit/shepherdwriteup/
> (you need to create a free account on datatracker if not yet done), the
> mailing list archive should also be a source of information
> https://mailarchive.ietf.org/arch/browse/opsec/?q=draft-ietf-opsec-v6
> >
> >
> >    I read the document thoroughly in its entirety and do have valuable
> real world experience in this space so I am volunteering.
> >
> >> As you will notice in
> this latest revision addresses a suggestion by Gyan Mishra issued during
> the Working Group Last Call. Other changes are mainly replacing the
> normative "MUST" and "SHOULD" as it is an informational document (so it is
> now "must" and "should") + removing an unused informational reference.
> >>
> >> Jen and Ron, as the authors have addressed all comments received during
> the WGLC (actually by only one reviewer) and the extensive review by Jen,
> may I kindly request publication of this document?
> >>
> >> Thank  you all
> >>
> >> -éric -merike - kk -enno
> >>
> >>
> >> On 12/10/2019, 09:34, "OPSEC on behalf of [email-masked]" <
> [email-masked] on behalf of [email-masked]> wrote:
> >>
> >>
> >>   This draft is a work item of the Operational Security Capabilities
> for IP Network Infrastructure WG of the IETF.
> >>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sat, 26 Oct 2019 05:58:07 +0000

No IPR on my side.

-éric

From: Kiran Kumar Chittimaneni <[email-masked]>
Date: Saturday, 26 October 2019 at 00:11
To: Gyan Mishra <[email-masked]>
Cc: Eric Vyncke <[email-masked]>, Ron Bonica <rbonica=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [OPSEC] I-D Action: draft-ietf-opsec-v6-20.txt

Hi Gyan,

No IPRs on my end.

Thanks,
KK

On Thu, Oct 24, 2019 at 11:36 AM Gyan Mishra <[email-masked]<mailto:[email-masked]>> wrote:
Hi Eric

Regards,

Gyan

Sent from my iPhone

> On Oct 15, 2019, at 2:12 AM, Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>> wrote:
>
> Gyan,
>
> On 15/10/2019, 01:54, "Gyan Mishra" <[email-masked]<mailto:[email-masked]>> wrote:
>
>    Ron
>
>> On Oct 14, 2019, at 7:14 PM, Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Jen,
>>
>> From: Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>>
>> To: [email-masked]<mailto:[email-masked]>
>> Cc: Jen Linkova <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>
>> As you will notice in https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCfC0QrYg$<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCfC0QrYg$>  this latest revision addresses a suggestion by Gyan Mishra issued during the Working Group Last Call. Other changes are mainly replacing the normative "MUST" and "SHOULD" as it is an informational document (so it is now "must" and "should") + removing an unused informational reference.
>>
>> On 12/10/2019, 09:34, "OPSEC on behalf of [email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:
>>
>>
>>   https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-opsec-v6/__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCVgtmnGd$<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-opsec-v6/__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCVgtmnGd$>
>>
>>   https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCQdAq-nG$<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCQdAq-nG$>
>>   https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCTaFWv3h$<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCTaFWv3h$>
>>
>>   https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCfC0QrYg$<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-ietf-opsec-v6-20__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCfC0QrYg$>
>>
>>
>>   until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>>
>>   https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCXkuUebd$<https://urldefense.com/v3/__ftp:/ftp.ietf.org/internet-drafts/__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCXkuUebd$>
>>
>>   [email-masked]<mailto:[email-masked]>
>>   https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/opsec__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCVjA-7t2$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/opsec__;!8WoA6RjC81c!R2vH-_v3NugiwIfTcXccEC89zGAXYR4rIB7oMxgV_5Tl11Z9jXZgMMuVCVjA-7t2$>
>>
>> [email-masked]<mailto:[email-masked]>

_______________________________________________
OPSEC mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/opsec

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 28 Oct 2019 18:13:18 -0400

Thank you 

Gyan

Sent from my iPhone

> On Oct 26, 2019, at 1:58 AM, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 
> No IPR on my side.
>  
> -éric
>