Subject: RE: [Ospf-wireless-design] new material to review and discuss

From: "Henderson, Thomas R" <[email-masked]>
Date: Fri, 22 Oct 2004 11:01:02 -0700

> -----Original Message-----
> From: Joe Macker [mailto:[email-masked]] 
> Sent: Friday, October 22, 2004 10:41 AM
> To: Acee Lindem
> Cc: Henderson, Thomas R; [email-masked]
> Subject: Re: [Ospf-wireless-design] new material to review and discuss
> 
> 
> > If we can move past those items, the next topic I would like
> > to focus on is the flooding discussion-- in particular, the
> > issue of MPR vs. CDS that has never been resolved adequately
> > in my opinion.  Please read Section 3.2 carefully, as it has
> > been substantially rewritten, and let the list know of your
> > agreements and disagreements to what is written there.
> > 
> 
> Tom:
> 
> Sorry I'm jumping ahead here, but in preparation for 
> discussion of MPR 
> vs.CDS, I'd like to clarify a few issues, especially the terminology.
> 
> MPR is a heuristic algorithm that forms a "source specific" 
> CDS.  So it 
> is a CDS algorithm. So are we talking about "other" CDS 
> algorithms like 
> Wu and Li have proposed,etc. I just want to get the 
> terminology straight 
> so I know what we are talking about.  For example, are we 
> talking about 
> a shared tree CDS algorithms, different election heuristics for 
> forwarding sets, dynamic robustness issues, complexity tradeoffs...

Yes, I mean source-independent vs. source dependent.  Please
see the writeup in the draft that I circulated.

> 
> There are existing empirical and analytical studies that we 
> can look at 
> and discuss.
> 
Please point us to such studies that you are aware of.  I have
the paper by Wu and Li and can share it with anyone who
is interested.

Tom

_______________________________________________
Ospf-wireless-design mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf-wireless-design

---

From: Thomas Heide Clausen <[email-masked]>
Date: Sat, 23 Oct 2004 01:31:29 +0200

Ahh...Joe beat me to it ;) I didn't get Joe's mail to the list, so I only saw
Tom's reply. Sorry for being redundant.

--thomas

---

From: Joe Macker <[email-masked]>
Date: Fri, 22 Oct 2004 17:35:18 -0400

> see the writeup in the draft that I circulated.

Ok, I sent another message after I read it (sorry for the premature 
first message).

> the paper by Wu and Li and can share it with anyone who

FYI (I am not necessarily of the above, just pointing out there is work 
there)...many of the more optimal techniques can suffer under 
dynamic/mobile operation (often more signaling/maintenance 
required,etc)..in addition to overhead we need to consider this.

I have some analytical (random graphs) and empirical studies (with 
mobility) internally also on a few methods (not completely comprehensive 
but it may contribute).  I'll bring some to the IETF. I think we should 
strive for a good approach that is not overly complex (perhaps not optimal).