Subject: question about IP subnet overlap

From: Li Zhongjie <[email-masked]>
Date: Thu, 5 Sep 2002 21:36:59 +0800

Hi everybody,

I am interested in IP subnet overlap when assigning subnets to router interfaces.
As an example, see the figure below. Router A connects to B via a point-to-point
link which is assigned a subnet 192.168.1.240/28. A also has an broadcast interface
whose subnet is 192.168.1.240/28. These two subnet overlap.
Is this configuration scenario common, or rare, or wrong in practice?

Another question is: there may be multiple p2p links between two routers, in this 
case, anybody knows that whether there exists some rules governing the assignment
of subnets and metrics to these multiple links? I just lack experiences of running
real networks.

If anybody could recommend some literature or website or something else, thanks a lot. 
     ----------
         |
         | 192.168.1.240/28
         |
       ******192.168.1.248/29   *******
       * A  *-------------------*  B  *
       ******                   *******
---
Best Regards,

Zhongjie Li

********************************************************************
*    Zhongjie Li                                                   *
*    Ph.D candidate, Department of Computer Science & Technology   *
*    Tsinghua University, Beijing, 100084, P.R.China               *
*    Tel: +86+10-62788109     Fax:  +86+10-62788109                *
*    Email: [email-masked]                          *
********************************************************************

---

From: Chaoping Wu <[email-masked]>
Date: Fri, 6 Sep 2002 17:31:01 -0400

Hi Gentlemen,

I'd like to make a short comment on the following statement so that
everybody sees the whole picture.

>In practice, the IP address on router interfaces must be
>configured with uniqueness.

This statement is very true in traditional routers. However, in routers
supporting VPNs, particularly VPNs using virtual router architecture,
overlapping IP addresses in physical router interfaces are very common.

In VR environment, IP address on any virtual router interfaces in one VPN
must be unique.

If you go to IETF draft sites, and search for virtual router, you should
see a number of drafts available on virtual router based VPNs.

Best Regards,
Chaoping Wu

---

From: "Cheng, Dean" <[email-masked]>
Date: Fri, 6 Sep 2002 18:56:47 -0700

Got more comments inline...

> -----Original Message-----
> From: Li Zhongjie [mailto:[email-masked]]
> Sent: Thursday, September 05, 2002 6:43 PM
> To: [email-masked]
> Subject: Re: question about IP subnet overlap
>
>
> Thanks for Dean, see comments inline ...
>
> ----- Original Message -----
> From: "Cheng, Dean" <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, September 06, 2002 1:22 AM
> Subject: Re: question about IP subnet overlap
>
>
> > Mr. Li,
> >
> >      Comments inline...
> >
> > Dean
> >
> > > -----Original Message-----
> > > From: Li Zhongjie [mailto:[email-masked]]
> > > Sent: Thursday, September 05, 2002 6:37 AM
> > > To: [email-masked]
> > > Subject: question about IP subnet overlap
> > >
> > >
> > > Hi everybody,
> > >
> > First of all, the address/mask in your text is not consistent
> > with that in the picture, i.e., it is /28 in one place and
> > /29 in another.
> >
> yes, a mistake, should be 192.168.1.240/28 and 192.168.1.248/29.

Also, on a point-to-point link, the network mask is usually not
defined, or the two IP addresses can be independently defined
if you prefer numbered links.

> > configured with uniqueness. So the scenario as shown is a
> > wrong configuration. Many routers upon initialization or
> > configuration, do check on the uniqueness on their interfaces'
> > IP addresses.
> >
> I cann't precisely understand what you mean. The ip addresses of
> each router interface are unique does not exclude that their
> belonging subnets overlap.

Assume you replace the p2p link to an Ethernet (see comment above),
and choose to configure as such,there will be two separate
subnets advertised, i.e., 192.168.1.240/28 and 192.168.1.248/29.

Packets sent to the associated IP addresses may be forwared to
either subnet, depending on the result of the longest matching
rule. The destinations better be on the right subnet otherwise
may become unreachable.

> > In addition to the "uniqueness", there is not much rule.
> > On the other hand, users prefer to have no IP addresses
> > assigned on p2p links for reasons including saving address
> > space, reduce IP routing table size, eliminate the
> > configuration efforts, etc. If a p2p link has no IP
> > address assigned, it is called unnumbered links, and
> > it is supported by OSPF, refer to RFC 2328 OSPF v2.
>
> I think you should guarantee that the configurations of both
> ends are consistent. Inconsistent configurations may include:
> 1. numbered vs. unnumbered
> 2. different subnets assigned
> 3. ...
> Also, in the assignment of metrics, perhaps we relate them to
> our routing purpose: equal metrics to share load, different
> metrics to backup.
>
> So I wonder if there are some literature talking about this issue.
>
> >
> > >
> > > *    Zhongjie Li
>          *