Subject: OSPF multiple process

From: Javed Syed <[email-masked]>
Date: Tue, 3 Sep 2002 06:16:24 -0400

Hi,

I would like to know if anybody have seen or aware of any good document explaining why it is not recommended to run multiple OSPF processor in the same router.
I have seens many emails regarding this issue.
I have seen people running two processor only if it is absolute necessary and to make each node acting as a multiple node for load balancing.
Any comments will be appreciated.

JS

---

From: Acee Lindem <[email-masked]>
Date: Tue, 3 Sep 2002 10:58:34 -0400

> Any comments will be appreciated.

JS,

I think the fear of multiple OSPF process dates back to days of routers
with less than 100 MHz processors and only a couple megs of memory. At
that time, many thought that the scaling/scheduling/debuging issues
associated with multiple link state protocol instances were intractable.
I doubt you'll encouter the same trepidation today.

--
Acee

---

From: Andrew Lange <[email-masked]>
Date: Tue, 3 Sep 2002 11:48:32 -0700

In fact, the Exodus network has used multiple OSPF processes for a number
of years.  It has worked just fine.

Andrew

On Tue, Sep 03, 2002 at 10:58:34AM -0400, Acee Lindem wrote:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020508
>             Netscape6/6.2.3
> X-Accept-Language: en-us
> Date:         Tue, 3 Sep 2002 10:58:34 -0400
> Reply-To: Mailing List <[email-masked]>
> From: Acee Lindem <[email-masked]>
> Subject: Re: OSPF multiple process
> To: [email-masked]
> Precedence: list
> X-OriginalArrivalTime: 03 Sep 2002 15:03:11.0482 (UTC) FILETIME=[053D2DA0:01C2535B]
>
> Javed Syed wrote:
>
> > Hi,
> >

---

From: Erblichs <[email-masked]>
Date: Wed, 4 Sep 2002 09:49:06 -0700

Group,

        And I know of a a a well known company implimentation   that I believe
has used at least a three process
        OSPF implimentation for 7+ years : main, hello, and a scanner.

        Mitchell Erblich
        PS: Someone said that we should keep discussions company
            neutral..
        Staff Kernel / IP Routing Protocol Engineer
        ==============================================

---

From: Acee Lindem <[email-masked]>
Date: Wed, 4 Sep 2002 12:52:02 -0400

>         OSPF implimentation for 7+ years : main, hello, and a scanner.

Michell,

I think you're confusing internal OSPF implementation with supporting
mulitple OSPF instances (at least one vendor calls these routing processes).

--
Acee

---

From: Erblichs <[email-masked]>
Date: Thu, 5 Sep 2002 01:06:28 -0700

Acee,

        I am pretty sure that I am correct.

        I remember that they achieved these
        additional processes via their internal
        fork system calls that returns twice.

        Yes, once for the parent and once for the
        child. You do this two times and you
        have a three process OSPF.

        And don't you think it is wise to do this
        type of OSPF implimentation?

        Mitchell Erblich
        Staff Kernel / IP Routing Protocol Engineer
        ===============================================

---

From: Acee Lindem <[email-masked]>
Date: Thu, 5 Sep 2002 09:30:37 -0400

>         I am pretty sure that I am correct.

Hello Michell,

You may be correct about this particular implementation.
However, I believe the original question was whether a someone
setting up an OSPF network should use multiple instances
of OSPF in a single router as opposed to whether one should
implement OSPF with more than one process. About 8 or 9
years back, the former was discouraged.

--
Acee