Subject: Re: question about IP subnet overlap

From: "Cheng, Dean" <[email-masked]>
Date: Thu, 5 Sep 2002 10:22:54 -0700

Mr. Li,

     Comments inline...

Dean

> -----Original Message-----
> From: Li Zhongjie [mailto:[email-masked]]
> Sent: Thursday, September 05, 2002 6:37 AM
> To: [email-masked]
> Subject: question about IP subnet overlap
>
>
> Hi everybody,
>
> I am interested in IP subnet overlap when assigning subnets
> to router interfaces.
> As an example, see the figure below. Router A connects to B
> via a point-to-point
> link which is assigned a subnet 192.168.1.240/28. A also has
> an broadcast interface
> whose subnet is 192.168.1.240/28. These two subnet overlap.
> Is this configuration scenario common, or rare, or wrong in practice?

First of all, the address/mask in your text is not consistent
with that in the picture, i.e., it is /28 in one place and
/29 in another.

In practice, the IP address on router interfaces must be
configured with uniqueness. So the scenario as shown is a
wrong configuration. Many routers upon initialization or
configuration, do check on the uniqueness on their interfaces'
IP addresses.

>
> Another question is: there may be multiple p2p links between
> two routers, in this
> case, anybody knows that whether there exists some rules
> governing the assignment
> of subnets and metrics to these multiple links? I just lack
> experiences of running
> real networks.

In addition to the "uniqueness", there is not much rule.
On the other hand, users prefer to have no IP addresses
assigned on p2p links for reasons including saving address
space, reduce IP routing table size, eliminate the
configuration efforts, etc. If a p2p link has no IP
address assigned, it is called unnumbered links, and
it is supported by OSPF, refer to RFC 2328 OSPF v2.

>
> If anybody could recommend some literature or website or
> something else, thanks a lot.
>      ----------
>          |
>          | 192.168.1.240/28
>          |
>        ******192.168.1.248/29   *******
>        * A  *-------------------*  B  *
>        ******                   *******
> ---
> Best Regards,
>
> Zhongjie Li
>
> ********************************************************************
> *    Zhongjie Li                                                   *
> *    Ph.D candidate, Department of Computer Science & Technology   *
> *    Tsinghua University, Beijing, 100084, P.R.China               *
> *    Tel: +86+10-62788109     Fax:  +86+10-62788109                *
> *    Email: [email-masked]                          *
> ********************************************************************
>

---

From: Li Zhongjie <[email-masked]>
Date: Fri, 6 Sep 2002 09:43:14 +0800

Thanks for Dean, see comments inline ...

----- Original Message ----- 
From: "Cheng, Dean" <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 06, 2002 1:22 AM
Subject: Re: question about IP subnet overlap

> with that in the picture, i.e., it is /28 in one place and
yes, a mistake, should be 192.168.1.240/28 and 192.168.1.248/29.

> configuration, do check on the uniqueness on their interfaces'
I cann't precisely understand what you mean. The ip addresses of 
each router interface are unique does not exclude that their 
belonging subnets overlap.

> it is supported by OSPF, refer to RFC 2328 OSPF v2.

I think you should guarantee that the configurations of both
ends are consistent. Inconsistent configurations may include:
1. numbered vs. unnumbered
2. different subnets assigned
3. ...
Also, in the assignment of metrics, perhaps we relate them to
our routing purpose: equal metrics to share load, different
metrics to backup. 

So I wonder if there are some literature talking about this issue.