Subject: Re: Paper comparing OSPF and ISIS

From: "Naidu, Venkata" <[email-masked]>
Date: Mon, 23 Sep 2002 20:46:20 -0400

All,

  The sentence may be fundamentally incorrect as per the
  deployed base of both protocols (DV routing is deployed
  at the second level in the hierarchy. Moreover, the
  hierarchy level is also not grown).

  But theoretically what is said is possible. Alex tried
  MLOSPF (I think, ISIS can also be done in similar way).

  Interested folks may want to look at below threads:

http://discuss.microsoft.com/SCRIPTS/WA-MSD.EXE?A2=ind9908&L=OSPF&P=R2439&I=
-3

http://discuss.microsoft.com/SCRIPTS/WA-MSD.EXE?A2=ind0108&L=OSPF&P=R1078&I=
-3

  (Un)fortunately, Alex's web page is not working :)

  One more point, it is not required that all multi-level
  hierarchy protocols must follow DV routing at the higher
  levels. *Theoretically* one can do hierarchical routing
  with DV algorithms also.

--
Venkata

-> This sentence is also fundamentally incorrect.
->
->    If I said that, "OSPF uses a distance vector
->    algorithm for inter-area routes and a link-state protocol
->    for intra-area routes vs IS-IS using link-state protocols
->    for both",  wouldn't this be the key / most important
->    design difference?
->

---

From: Erblichs <[email-masked]>
Date: Tue, 24 Sep 2002 10:41:32 -0700

Venkata,

        I am just a little lost..

        Are you suggesting that IS-IS L2 only routers
        do not run a SPF algorithm?

        If you think that then read the Cisco's
        Reference IS-IS chapter
        since you guys don't belive me ...

        My understading is that a IS-IS L1, or L2, or
        L1/L2 routers will build level specific
        link state databases. AND OSPF uses
        "See Cisco's Routing TCP/IP p.475" says it
        uses a distance vector algoritm. Assuming
        that you don't believe me..

        Mitchell Erblich
        ==========================

---

From: Dave Katz <[email-masked]>
Date: Tue, 24 Sep 2002 10:52:05 -0700

The DV-ness of these protocols is subtle but there, and the two
protocols work essentially the same way in this respect.

The keystone of a LS algorithm is having a map, and calculating routes
based on the map.  The heart of a DV algorithm is knowing the
destination, a distance to the destination, and a direction to the
destination, but not knowing the paths to get there.

Both protocols use a hybrid in interarea routing; each area advertises
its destinations in some level of detail (from a full route list to a
single summary) but include only the distance, not the path (since the
whole point of areas is to suppress the path information for brevity.)
The nearest ABR/L1L2 router is reached via a LS SPF calculation, but
everything beyond the area boundary is effectively DV, albeit without
some of the failings of classic DV protocols (no holddown or count-to-
infinity, for example.)

   Venkata,

           Mitchell Erblich