Subject: Multiple Interfaces to a Link

From: Darshan Purohit <[email-masked]>
Date: Thu, 5 Sep 2002 14:26:44 -0400

Hi All,
I had a question about multiple interfaces on the same link. The setup
is:

      __
     |  | --1--|
E1---|R1| --2--|
     |__| --3--|
               |   __
               |_1|  |
                  |R2|
                  |__|

As mentioned in 2740, section 3.9, R1 uses only interface 1 (say), for
control traffic and setting up adjacency with R2. However,
R1 originates a router LSA for each interface 1,2 and 3  ,
and it generates a separate Link LSA for each interface. Now, for a
route
through R1, how is R2 supposed to pick the nexthop link local address.
Will it be I1 - the interface which is being used for control traffic,
OR any one of the routers Link LSA , OR all three of them.

In the setup above, will the passive interfaces of R1 be used just as
backups in case the primary fails, or will they really play a role when
R2 (or any other Router in the area) does its routing table
calculation.

Thanks.
Darshan

---

From: "Manral, Vishwas" <[email-masked]>
Date: Sun, 15 Sep 2002 08:20:00 -0400

Hi Darshan,

As all the interfaces are advertized in LSA's all will be considered during
routing table calculations, so will play a role in other routers routing
table calculations.

As each interface has its own cost the interface with the lowest cost would
be preferred.  However if all three interfaces have the same cost I guess we
will have all three as next-hops in the routing table.

Thanks,
Vishwas

-----Original Message-----
From: Darshan Purohit [mailto:[email-masked]]
Sent: Thursday, September 05, 2002 11:57 PM
To: [email-masked]
Subject: Multiple Interfaces to a Link

Hi All,

      __
     |  | --1--|
E1---|R1| --2--|
     |__| --3--|
               |   __
               |_1|  |
                  |R2|
                  |__|

Thanks.
Darshan

---

From: "Manral, Vishwas" <[email-masked]>
Date: Mon, 23 Sep 2002 01:22:40 -0400

Hi Darshan/Yasu,

> When R2 has a route with nexthop R1, would the costs of interfaces
> I1, I2, I3 matter for R2. It seems to me that R2 would do the same
> thing no matter what the costs of I1, I2, I3 are.
Yes the costs would not matter.

>            __       N
>           |  | --I1-|
> R3--///---|R1| --I2-|
>           |__| --I3-|

> Section 3.8.1.1 in 2740 ( Next hop calculation ) says
> "Calculating router assigns the next hop IPv6 address to be the
> link-local interface address contained in Router X's link-lsa for the
> link"

>--In this case R1 has three such link-LSAs. How should they be treated?
As Yasu put it, it would be nice to state the below instead for section
3.8.1.1 with minor corrections to Yasu's text

"Calculating router assigns the next hop IPv6 addresses to be the
collection of the link-local interface address contained in Router X's
Link-LSAs advertised from each of Router X's interface on the link"

Would this help?

Thanks,
Vishwas

>        __       N
>       |  | --I1-|
>  R3---|R1| --I2-|
>       |__| --I3-|

---

From: Darshan Purohit <[email-masked]>
Date: Mon, 23 Sep 2002 02:36:06 -0400

Hi Vishwas / Yasu,
Thanks a lot for the valuable feedback. It looks clear now how the LSAs
will be treated when a router has more than one interfaces on the link.
Thanks.
Darshan