Subject: What is a MIB-II IfIndex like

From: Li Zhongjie <[email-masked]>
Date: Sat, 7 Sep 2002 20:18:50 +0800

I am not familiar with MIBs. A question is what a MIB-II IfIndex looks like.
Could it be distinguished from IP address? An example is better.
---
Best Regards,

Zhongjie Li

********************************************************************
*    Zhongjie Li                                                   *
*    Ph.D candidate, Department of Computer Science & Technology   *
*    Tsinghua University, Beijing, 100084, P.R.China               *
*    Tel: +86+10-62788109     Fax:  +86+10-62788109                *
*    Email: [email-masked]                          *
********************************************************************

---

From: Santhosh Ram <[email-masked]>
Date: Sat, 7 Sep 2002 19:27:27 +0530

Zhongjie Li,

Here is the ifIndex definition from RFC 1213 which defines MIB II...

          ifIndex OBJECT-TYPE
              SYNTAX  INTEGER
              ACCESS  read-only
              STATUS  mandatory

              DESCRIPTION
                      "A unique value for each interface.  Its value
                      ranges between 1 and the value of ifNumber.  The
                      value for each interface must remain constant at
                      least from one re-initialization of the entity's
                      network management system to the next re-
                      initialization."
              ::= { ifEntry 1 }

HTH,

cheers,
Santhosh.

---

From: Li Zhongjie <[email-masked]>
Date: Tue, 10 Sep 2002 21:50:27 +0800

Then, in a router-LSA, how can I tell an IP address representation of "link id" from the IfIndex representation?

---

From: Acee Lindem <[email-masked]>
Date: Tue, 10 Sep 2002 10:48:09 -0400

Zhongjie Li,

There are ways you could be ascertain with a high degree of
success whether or not a particular router LSA link is unnumbered.
However, you really don't need to know for the SPF computation. Why
do you think it matters?

--
Acee

---

From: Li Zhongjie <[email-masked]>
Date: Wed, 11 Sep 2002 13:56:26 +0800

Hi Acee,
     yes, it matters in one of my researches. I have to determine the interface type just by its router LSAs.
    Would you suggest some means to achieve this?