Subject: NSSA - type 7 LSA

From: Subhasree Mandal <[email-masked]>
Date: Fri, 6 Sep 2002 14:29:11 -0700

Hi,

I have a question about type-7 LSA origination and route calculation.
Let us consider the following configuration

                      N1
       R1-----------cost 10------------------R2
        |                                     |
        |                                     |
        |--cost 10-------R3--------cost 10----|
             N2                      N3

Lets consider that all these routers are in an NSSA area nd R3 is an ASBR
advertising an external
route to network Nx.  If we want that route to be translated to type 5 by
some ABR in this NSSA area, we must set the forwarding address to a non-zero
value (page 6, RFC 1587).  According to page 7 of
the same RFC
         "...if the intervening network is not advertised
         into OSPF as an internal OSPF route, the forwarding
         address should be any one of the router's active OSPF
         interface addresses."

So my type-7 LSA for Nx can have forwarding address as the interface address
of R3 on network N3.
When R1 computes route to Nx, it would actually use the next-hop for N3 as
the next-hop for Nx since
the forwarding address is in N3.  So if R1 chooses to reach N3 through R2
(equally possible as through
R3), the packets from R1 would reach R3 (to go out of the AS) via R2.  In
other words it is adding
an extra hop to the route to Nx.

How do we address this issue?

Thanks,
Subhasree

---

From: Acee Lindem <[email-masked]>
Date: Sun, 8 Sep 2002 21:16:21 -0400

Subhasree Mandal wrote:

> Lets consider that all these routers are in an NSSA area nd R3 is an
> ASBR advertising an external
> route to network Nx.  If we want that route to be translated to type 5
> by some ABR in this NSSA area, we must set the forwarding address to a
> non-zero value (page 6, RFC 1587).  According to page 7 of
>
> the same RFC
> So my type-7 LSA for Nx can have forwarding address as the interface
> address of R3 on network N3.
> When R1 computes route to Nx, it would actually use the next-hop for N3
> as the next-hop for Nx since
> the forwarding address is in N3.  So if R1 chooses to reach N3 through
> R2 (equally possible as through
> R3), the packets from R1 would reach R3 (to go out of the AS) via R2.
> In other words it is adding

Hello Subhasree,

It looks like an ECMP route will be computed. However, I see your point.

> How do we address this issue?

By configuring a loopback address on R3 and making it part of the NSSA area.

I believe draft-ietf-ospf-nssa-update-11.txt (soon to obsolete 1587) stipulates
that loopback addresses should be preferred over non-loopback when selecting
an NSSA interface address to use as a forwarding address. Besides avoiding
the issue you mention, selecting a loopback address offers better stability
(since you're less likely to have to re-originate all your NSSA type 7 LSAs
due to the forwarding address interface going down).

Thanks,
Acee

--
Acee