Subject: Re: Opaque LSA for OSPFv3

From: "Manral, Vishwas" <[email-masked]>
Date: Wed, 11 Sep 2002 01:05:46 -0400

Hi Keqin Li,

In OSPFv3 we do not drop LSA's if the type is unknown they are still
processed and flooded according to the flooding scope, if U-bit is set to 1.
This mechanism makes all unrecognized LSA's as if they are opaque LSA's.

For running OSPFv3 we do not use the ships in the night approach(ie the same
stack running OSPFv3/OSPFv2), instead we use a different stack for it. Hence
overlapping types between OSPFv2 and OSPFv3 would not cause a problem.
Besides the LS-type of Intra-Area-Prefix-LSA is 0x2009. Check section A.4.2.
1 RFC2740.

Please let me know if it clears ur doubt.

Thanks,
Vishwas

-----Original Message-----
From: Li, Ke Qin (Peter) [mailto:[email-masked]]
Sent: Wednesday, September 11, 2002 7:22 AM
To: [email-masked]
Subject: Opaque LSA for OSPFv3

Hi all,

Is there any RFC or Internet Draft about Opaque LSA for OSPFv3? In OSPFv3,
type 9 LSA is intra-area-prefix-LSA, so the opaque LSAs defined in RFC2370
can not be used with OSPFv3.

Thank you.

Keqin Li
Bell Labs Research China
Tel: 86-010-68748088-8438

---

From: "Li, Ke Qin (Peter)" <[email-masked]>
Date: Wed, 11 Sep 2002 13:18:00 +0800

Thank you very much!

Keqin Li

> From: Manral, Vishwas [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 1:06 PM
> Subject: Re: Opaque LSA for OSPFv3
>
>
> Hi Keqin Li,
>