Subject: rfc 2370 doubt

From: Rohit Gupta <[email-masked]>
Date: Fri, 13 Sep 2002 02:45:33 -0700

Hi,
RFC 2370 in its abstract says that "This memo defines
enhancements to the OSPF protocol to support a new ..
application-specific information.  The information
field may be used directly by OSPF or by other
applications"

My doubt is that how can OSPF use Opaque LSAs for its
own purposes as it doesnt run SPF over these LSAs?

I can understand their use for TE/MPLS/GMPLS but their
use with OSPF is not clear.

Thanks in advance

-- Rohit

__________________________________________________
Do you Yahoo!?
Yahoo! News - Today's headlines
http://news.yahoo.com

---

From: Acee Lindem <[email-masked]>
Date: Fri, 13 Sep 2002 10:28:27 -0400

> own purposes as it doesnt run SPF over these LSAs?

Rohit,

You can lay your doubts to rest. RFC 2370 describes the generic
handling of opaque LSAs. An OSPF opaque LSA application may
not require examination of these LSAs during the SPF computation.
For example, OSPF hitless restart does not. There is nothing
precluding a new OSPF opaque LSA application from requiring
reachability to the originating router as determined by the
SPF computation.

Hope this helps,
Acee

--
Acee