Subject: NSSA Question

From: Mani Devarajan <[email-masked]>
Date: Mon, 16 Sep 2002 17:36:30 -0700

Hi all,
 I have basic doubts in NSSA, which i guess  might
 have been discussed in this mailing list before. It would
 be great if someone could explain me or direct me to the
 previous discussion.

                                   ASBR
      -----     -----     -----    -----     -----
     |     |   |     |   |     |  |     |   |     |
     | R1  |   | R2  |   |  R3 |  |  R4 |   | R5  |
     |     |   |     |   |     |  |     |   |     |
      -----     -----     -----    -----     -----
          |     |   |      |  |     |  |     |
           -----     ------    -----    -----
           AREA1     AREA 0    AREA2    RIP Network
                                NSSA

    * In the above setup, Does R3(NSSA ABR) must be advertised
      as ASBR(type 4 LSA), as it is the orginator of type-5 LSA
      for the OSPF domain.
      Otherwise the routes for the RIP External network
      will not be configured on R1.

      In this case the type-4 LSA for the NSSA ASBR(R4) will
      not needed in R1 as it doesnt recieve the type-7 LSAs
      generated by R4.

Thanks in advance,
Mani

---

From: Acee Lindem <[email-masked]>
Date: Tue, 17 Sep 2002 08:47:44 -0400

>  be great if someone could explain me or direct me to the

Mani,

R3 will set it's E bit in it's area 0 router LSA and
R2 will advertise a type 4 summary LSA into area 1 for R3.

Thanks,
Acee

--
Acee

---

From: Mani Devarajan <[email-masked]>
Date: Tue, 17 Sep 2002 12:16:44 -0700

> R2 will advertise a type 4 summary LSA into area 1 for R3.

Acee,
 Thanks for your information.

 I read one of the mails sent by Pat, saying that type-4 LSAs
 are not generated for NSSA ASBR. But in one of the implemenatation
 I am testing, I can see the type-4 Summary LSA for the NSSA ASBR
 in the Area1. But the routes for the external destination are not
 configured reporting that no route to Adv. router ASBR. But Actually
 I am able to reach ASBR from R1. Is this behaviour correct ?

 And if I configure R3 with some redistribution commands, type 4 LSA
 are generated for R3 and as you said, the summary LSA get relayed
 into Area1 by R2 and then routes are programmed for External
destination
 on R1.

 My question is, if R1 in Area1 recieves type-4 Summary LSA for
 NSSA ASBR and able to reach the ASBR through inter-area path,
 the external destination must be reachable without advertising
 type-4 LSA for R3 into area1. Is my understanding correct ....

Thanks in advance,
Mani

---

From: Acee Lindem <[email-masked]>
Date: Tue, 17 Sep 2002 15:38:11 -0400

Mani,

See responses below.

Mani Devarajan wrote:

>  are not generated for NSSA ASBR.

This is true. But, an ABR translating for an NSSA is an ASBR in the
non-NSSA areas (since that is where the router is flooding type 5 LSAs).

> But in one of the implemenatation
>  in the Area1.

You should.

> But the routes for the external destination are not
>  configured reporting that no route to Adv. router ASBR.

I don't understand this statement.

> But Actually

Yes.

>  type-4 LSA for R3 into area1. Is my understanding correct ....

No. The type 4 summary that is suppressed for NSSAs is the one for R4
that would be originated if area 2 were a regular area.

--
Acee