Subject: Re: Paper comparing OSPF and ISIS

From: "Manral, Vishwas" <[email-masked]>
Date: Wed, 4 Sep 2002 06:26:47 -0400

Hi Manav/Others,

A few of us have been working to form a group for the same, I have a list of
topics that we would probably want to discuss which contains a list of
topics besides the mentioned, which I will be willing to pass along in
private to anyone. Manav or anyone else who would want to help in in the
effort please mail me, I will add you to the list which I intend to make.

I intend to send a similar mail to the ISIS group too.

Thanks,
Vishwas

-----Original Message-----
From: Manav Bhatia [mailto:[email-masked]]
Sent: Wednesday, September 04, 2002 3:43 PM
To: [email-masked]
Subject: Paper comparing OSPF and ISIS

Hi,
The question of OSPF vis-a-vis IS-IS has been raised more than once in the
mailing lists (both OSPF and ISIS) and elsewhere and there seems to be no
apparent paper which clearly differentiates between the two. I started with
IS-IS and moved to OSPF some time back, and in my quest stumbled upon Dave
Katz presentation on the same. In my course of transitioning to OSPF I had
written a lot of notes and ideas (borrowed from Dave presentation and some
helpful cues which i took from Radia Perlman's "Interconnections") on the
key differences between these 2 link state routing protocols.

I have assimilated all of those in this document which i am hereby
attaching with this mail of mine. I would like to hear from other people
their views/thoughts/experiences with these protocols and i intended to
capture all that in the updated document which can then be used as a
reference in understanding as to how/what/where the two link state routing
protocols differ.

Manav

---

From: Naiming Shen <[email-masked]>
Date: Fri, 6 Sep 2002 12:15:04 -0700

Once Russ told me he was going to write a book on this subject:
"The differences between OSPF and ISIS", and he said there were only
three sentences in that book. Here is the electronic version of that
interesting book if I remember it correctly:

  ISIS is simple.

  OSPF is complicated.

  Otherwise they are the same.

thanks.
(hopefully i didn't violate his publisher's copyright issues)

 ] It is outside the scope
 ] of this workgroup for sure and on top, I am not entirely sure anything
 ] really new comes out of it.
 ] Dave K.'s presentation pretty well covered the issues IMHO.
 ]
 ]     -- tony przygienda

- Naiming

---

From: "Manral, Vishwas" <[email-masked]>
Date: Fri, 6 Sep 2002 15:19:33 -0400

Naiming,

We intend to delve into the topic in a little more detail. ;-)

Thanks,
Vishwas

-----Original Message-----
From: Naiming Shen [mailto:[email-masked]]
Sent: Saturday, September 07, 2002 12:45 AM
To: [email-masked]
Subject: Re: [Isis-wg] Paper comparing OSPF and ISIS

  ISIS is simple.

  OSPF is complicated.

thanks.

- Naiming

---

From: "Naidu, Venkata" <[email-masked]>
Date: Tue, 24 Sep 2002 09:52:55 -0400

->   hierarchy protocols must follow DV routing at the higher

Er, that is, "link-state."

---

From: "Naidu, Venkata" <[email-masked]>
Date: Tue, 24 Sep 2002 15:04:48 -0400

Mitchell,

->         Are you suggesting that IS-IS L2 only routers
->         do not run a SPF algorithm?

No.

->         If you think that then read the Cisco's
->         Reference IS-IS chapter since you guys don't
->         belive me ...

There is nothing called believing or not believing :)

->         My understading is that a IS-IS L1, or L2, or
->         L1/L2 routers will build level specific
->         link state databases. AND OSPF uses
->         "See Cisco's Routing TCP/IP p.475" says it
->         uses a distance vector algoritm. Assuming
->         that you don't believe me..

I didn't read Cisco's manuals but the answer is in your
response. I can't say that Cisco's manuals are incorrect,
but I can say that the *interpretation* is incorrect.

Yes! L1, L2 or L1/L2 (view it as two logical L1 & L2)
routers build *level specific* link-state database.
The word *level specific* is very important. L1 routers
build its respective LSDB and L2 routers builds its
respective LSDB. But crossing L1's or L2<->L1 routers
(i.e crossing area boundaries) is DV based (or a kind
of DV as Dave pointed out).

-> albeit without some of the failings of classic DV
-> protocols (no holddown or count-to-infinity,
-> for example.)

Those failings of classic DV protocols are solved by
both protocols (OSPF and ISIS) using some *restrictions*
on how to build the hierarchy (like, backbone area must
not be disconnected, split horizon etc etc)

Again, please don't think that we don't believe you.

--
Venkata.