Subject: Question on NSSA ABRs

From: Mani Devarajan <[email-masked]>
Date: Fri, 20 Sep 2002 15:06:45 -0700

Hi all,

                                   ASBR
      -----     ------     -----    -------     -----
     |     |   |      |   |     |  |       |   |     |
     | R1  |   | R2   |   |  R3 |  |  R5   |   | R6  |
     |     |   |      |   |     |  |       |   |     |
      -----     ------     -----    -------     -----
          |I1 I2|  | |I4  I5|  |I6 I9| |  |I11  |
           -----   |  ------    -----  |   -----
           AREA1   |  AREA 0    AREA2  |    RIP Network
                   |I3                 |I10
                   |      -----        |
                   |   I7|     |I8     |
                    -----|  R4 |-------
                   AREA0 |     | AREA2
                          -----

     * R4 is configured with higher router id than R3.
     * AREA2 is NSSA.

  So on configuring the R5 for redistributing routes,R5 generates
  type7 LSAs for the external destination with I10 as forwarding
  address. R4 becomes a translator and injects the type-5 LSAs
  in to Area0. So now R2 reaches Rip network through R4.

  When I bring down the R4,R3 will become the translator, and
  translates the type-5 from type7 LSAs(with forwarind address I9)
  for the Rip network and so that R2 reaches R6 through R3.

  When I bring up R4 again, R3 does premature aging for the type5
  LSAs it generated and R4 translates the type7 in to type5 for the
  Rip network.  And now R2 reaches the R6 through R4.

  I can understand R3 becomes a translator, when R4 goes down. But
  I cant understand why R3 does premature aging when R4 comes up,
  in this case the forwarding interface I9 is still alive.

Thanks,
Mani

---

From: Acee Lindem <[email-masked]>
Date: Fri, 20 Sep 2002 18:27:15 -0400

--
Acee

---

From: Acee Lindem <[email-masked]>
Date: Fri, 20 Sep 2002 18:29:26 -0400

Sorry for the premature transmission - see answer below.

>>                                    ASBR

Because R3 loses the translator election to R4 and discontinues
translation.

--
Acee

---

From: Mani Devarajan <[email-masked]>
Date: Fri, 20 Sep 2002 16:06:36 -0700

> Because R3 loses the translator election to R4 and discontinues

Acee,
  Is translator election performed whenever a new ABR is configured
  in NSSA.

  And also If we had stayed with R3, we could have reduced
  the routing updates from R3 (premature aging for the LSAs
  it generated) and R4 translating the type-7 into type-5 LSA
  for the same external destination for which R3 has already
  done it. Is my understanding correct.

Thanks,
Mani

---

From: Acee Lindem <[email-masked]>
Date: Fri, 20 Sep 2002 21:41:11 -0400

>   Is translator election performed whenever a new ABR is configured

Hi Mani,

I do it as part of NSSA area SPF calculation (so only consider reachable
ABRs are considered in the NSSA election process). I don't think the
RFC specifies exactly when the election is done.

>   done it. Is my understanding correct.

Yes. It might have been possible for the translator to
retain that role as long as it is connected to the NSSA. However,
it wasn't done this way.

--
Acee

---

From: Acee Lindem <[email-masked]>
Date: Sat, 21 Sep 2002 06:08:11 -0400

Mani,

There is one detail that is neglected here. It is R5 that is
selecting the forwarding address - not the translator.
R5 probably changes the forwarding address due to I10 going
down when R4 is taken down (perhaps you are using
cross-connected fast ethernet).

Thanks,
Acee

--
Acee