Subject: Re: Question about choosing NSSA ABR

From: "Manral, Vishwas" <[email-masked]>
Date: Sun, 22 Sep 2002 05:04:29 -0400

Hi Mani,

Besides what Acee said, you may want to check the section F.4 in the new
NSSA draft. I think sub-optimal routing is a smaller issue in this case, I
think making the translator deterministic is a bigger issue.

The new draft does close a bug in the translator election, which may result
by choosing just a router with the largest Router-id(it may happen for the
shortest route too though, we still use the highest router-id). The problem
is if one or more areas looses connectivity to the Area-0, we will still
have just one router translating. Besides translators are now configureable,
so as to make translators more deterministic.

Thanks,
Vishwas

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Thursday, September 19, 2002 3:05 AM
To: [email-masked]
Subject: Re: Question about choosing NSSA ABR

Mani Devarajan wrote:

> Acee Lindem wrote:
>
>>Mani Devarajan wrote:
>>
>>
>>>Hi all,
>>>
>>>RFC 1587:
>>> If this router has the highest router ID, it will be the
>>> one translating type-7 LSAs into type-5 LSAs for the NSSA, otherwise
>>> the translation algorithm should not be performed.
>>>
>>>
>>>Why do we choose the NSSA ABR with the highest router ID to do
>>>type-7 to type-5 LSA translation.
>>>
>>>Why cant we choose a NSSA ABR which has the best cost path to
>>>NSSA ASBR to do the type-7 to type-5 translation.
>>>
>>Mani,
>>
>>The translated type 5 advertisements alway contain a forwarding
>>addresses. Hence, the cost from the translating ABR to the NSSA
>>ASBR is not important.
>>
>
>  Acee,
>   I understand that it makes no difference when the forwarding
>   address is set in the type-5 LSA translated from type-7 LSA.
>
>   If I assume that all NSSA ABRs have same address-range configuration,
>   and the NSSA ABR with the highest routerid will do
>   type7 to type5 translation and external network comes
>   with in configured address range, it will set the forwarding
>   address to 0.0.0.0 .  If the forwarding
>   is 0.0.0.0, all the traffic for NSSA ASBR will be passing
>   thorugh the NSSA ABR which did the type-7 to type-5 translation.
>   In this case choosing the NSSA ABR with best cost path to the NSSA
> ASBR
>   will be a better option. Is my understanding correct?

In general, any time you aggregate routing information you have
the potential for a suboptimal routing. I don't necessarily view
introducing a corner case to handle this one as a better option.
You always have the choice of not configuring an NSSA address
range.

> Thanks,
> Mani
>>Thanks,
>>---
>>Acee

--
Acee

---

From: "Pat Murphy - (650)329-4044" <[email-masked]>
Date: Mon, 23 Sep 2002 18:27:56 -0700

Mani,

>If the forwarding is 0.0.0.0, all the traffic for NSSA ASBR
>will be passing thorugh the NSSA ABR which did the type-7
>to type-5 translation. In this case choosing the NSSA ABR
>with best cost path to the NSSA ASBR will be a better
>option. Is my understanding correct?

The latest NSSA draft (soon to be an RFC) allows the network
implementor to configure multiple NSSA ABRs to be
translators regardless of their router ID. Properly
configured the presense of multiple NSSA translators can
cause the best cost path to be chosen. Indeed this was one
of the motivations for this adding this new feature.

Pat