Subject: OSPF protocol stacks

From: Piotr Galecki <[email-masked]>
Date: Mon, 14 Nov 2005 11:45:22 -0500

I'm looking into possible options for the 3rd party OSPF stack.
The requirement is that it should seamlessly integrate with Linux IP
stack.
It should also provide quality and robust implementation.

Does anyone have experience with OSPF implantations from:
- IP Infusion
- Zebra group
- Quagga group
- John Moy's OSPF (www.ospf.org?
I would love to hear your honest opinion about those implantations.

Are there other options you would recommend?

Regards,
Piotr

---

From: Rohit Dube <[email-masked]>
Date: Tue, 15 Nov 2005 12:11:59 -0800

Piotr,

I would suggest putting this question to the vendors directly - DCL,
Nexthop, IpInfusion, Futuresoft, Netplane etc. Or even to one of the zebra
or gated mailing lists.

Regards,
--rohit.

On 11/14/05, Piotr Galecki <[email-masked]> wrote:
> - John Moy's OSPF (www.ospf.org <http://www.ospf.org>?

---

From: Paul Jakma <[email-masked]>
Date: Tue, 15 Nov 2005 21:48:58 +0000

> Nexthop, IpInfusion, Futuresoft, Netplane etc. Or even to one of the zebra

Or the Quagga list for Quagga, obviously ;). See 
http://lists.quagga.net. FWIW, there are other OSPF implementations 
running on Linux and other Unix platforms, see:

 	XORP: http://www.xorp.org/
 	Bird: http://bird.network.cz/

The OSPF implementation in XORP is derived from Moy's implementation, 
IIRC/TTBOMK/etc.

Not quite Linux, but the OpenBSD people are working on their own OSPF 
implementation, OpenOSPFd - no formal release yet. See:

 	http://www.openbsd.org/cgi-bin/cvsweb/src/usr.sbin/ospfd/

>> - John Moy's OSPF (www.ospf.org <http://www.ospf.org>?

regards,
-- 
Paul Jakma	[email-masked]	[email-masked]	Key ID: 64A2FF6A
Fortune:
Lonesome?

Like a change?
Like a new job?
Like excitement?
Like to meet new and interesting people?

JUST SCREW-UP ONE MORE TIME!!!!!!!

---

From: Atanu Ghosh <[email-masked]>
Date: Thu, 17 Nov 2005 14:32:53 -0800

Paul> XORP: http://www.xorp.org/
    Paul> Bird: http://bird.network.cz/

    Paul> The OSPF implementation in XORP is derived from Moy's implementation,
    Paul> IIRC/TTBOMK/etc.

To clarify the current OSPF implementation in XORP was written by us, we
were previously using Moy's.

      Atanu.