Subject: Re: Update to OSPF Hello procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

From: Vishwas Manral <[email-masked]>
Date: Thu, 29 Dec 2005 02:29:17 -0800

Hi,

Why should this not happen for every change in the neighbor status when received in a hello message? 

Whenever the contents of the hello message change we could send the message immediately. Is there a Minimum interval between which if we get consecutive hello's we do not process them, just like LSA's?

Thanks,
Vishwas
________________________________________
From: Mailing List [mailto:[email-masked]] On Behalf Of Kouzengjie
Sent: Thursday, December 29, 2005 7:51 AM
To: [email-masked]
Subject: Update to OSPF Hello procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

A New Internet-Draft is available from the on-line Internet-Drafts directories.
The draft can be found here:
http://www.ietf.org/internet-drafts/draft-kou-ospf-immediately-replying-hello-00.txt
 
 This memo documents an extension of the OSPF protocol to reach 
   "ExStart" state more quickly. Currently, the OSPF behavior requires 
   the Hello Packet to be sent between the neighbors every 
   HelloInterval. This document proposes to generalize the use of 
   Immediately Replying Hello which could reduce the time required to 
   reach the OSPF "ExStart" state and  expedite the routing table 
   convergence.

---

From: sujay <[email-masked]>
Date: Thu, 29 Dec 2005 17:09:47 +0530

Hi Vishwas,
For all state changes detected upon reception of a hello message, is
there
a need to send the hello immediately ? Does it expedite any information?
What is needed immediately perhaps a nbr state change and other actions.
Regards,
Sujay

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of
Vishwas Manral
Sent: Thursday, December 29, 2005 3:59 PM
To: [email-masked]
Subject: Re: Update to OSPF Hello
procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

Hi,

Why should this not happen for every change in the neighbor status when
received in a hello message? 

Whenever the contents of the hello message change we could send the
message immediately. Is there a Minimum interval between which if we get
consecutive hello's we do not process them, just like LSA's?

Thanks,
Vishwas
________________________________________
From: Mailing List [mailto:[email-masked]] On Behalf Of
Kouzengjie
Sent: Thursday, December 29, 2005 7:51 AM
To: [email-masked]
Subject: Update to OSPF Hello
procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

A New Internet-Draft is available from the on-line Internet-Drafts
directories. The draft can be found here:
http://www.ietf.org/internet-drafts/draft-kou-ospf-immediately-replying-
hello-00.txt

---

From: Zengjie Kou <[email-masked]>
Date: Fri, 30 Dec 2005 10:06:01 +0800

hi,Vishwas
    
    The Immediately Hello only reduces the time to reach the "ExStart" state. It is unnecessary to use it when the state is more than "ExStart". 

----- Original Message ----- 
From: "Vishwas Manral" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, December 29, 2005 6:29 PM
Subject: Re: Update to OSPF Hello procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

Hi,

Thanks,
Vishwas