Subject: Re: Update to OSPF Hello procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

From: Vishwas Manral <[email-masked]>
Date: Thu, 29 Dec 2005 03:47:28 -0800

Hi Sujay,

What I mean is whenever you receive any information which leads to a change in the hello we can send the hello immediately.

Of course rate limiting could be done, so that we are not overwhelming the network with too many hellos.

Thanks,
Vishwas
-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of sujay
Sent: Thursday, December 29, 2005 5:10 PM
To: [email-masked]
Subject: Re: Update to OSPF Hello procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

Hi Vishwas,
For all state changes detected upon reception of a hello message, is
there
a need to send the hello immediately ? Does it expedite any information?
What is needed immediately perhaps a nbr state change and other actions.
Regards,
Sujay

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of
Vishwas Manral
Sent: Thursday, December 29, 2005 3:59 PM
To: [email-masked]
Subject: Re: Update to OSPF Hello
procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

Hi,

Why should this not happen for every change in the neighbor status when
received in a hello message? 

Whenever the contents of the hello message change we could send the
message immediately. Is there a Minimum interval between which if we get
consecutive hello's we do not process them, just like LSA's?

Thanks,
Vishwas
________________________________________
From: Mailing List [mailto:[email-masked]] On Behalf Of
Kouzengjie
Sent: Thursday, December 29, 2005 7:51 AM
To: [email-masked]
Subject: Update to OSPF Hello
procedure[draft-kou-ospf-immediately-replying-hello-00.txt]

A New Internet-Draft is available from the on-line Internet-Drafts
directories. The draft can be found here:
http://www.ietf.org/internet-drafts/draft-kou-ospf-immediately-replying-
hello-00.txt
 
 This memo documents an extension of the OSPF protocol to reach 
   "ExStart" state more quickly. Currently, the OSPF behavior requires 
   the Hello Packet to be sent between the neighbors every 
   HelloInterval. This document proposes to generalize the use of 
   Immediately Replying Hello which could reduce the time required to 
   reach the OSPF "ExStart" state and  expedite the routing table 
   convergence.

---

From: Vishwas Manral <[email-masked]>
Date: Thu, 29 Dec 2005 21:50:10 -0800

Hi Zengjie,

Why isn't it good enough to send a hello if the hello interval value is
changed? I think you can find many-many other cases.

I think to put the draft generally, whenever the content of the hello
message changes we could send the hello immediately and then reset the
hello timer to expire "Hello interval" seconds later.

Another thing is about "Rate limiting Hello's" to prevent overwhelming
of the network by hellos being sent. I think it is an essential feature.

Thanks,
Vishwas
-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of
Zengjie Kou
Sent: Friday, December 30, 2005 7:36 AM
To: [email-masked]
Subject: Re: Update to OSPF Hello procedure
[draft-kou-ospf-immediately-replying-hello-00.txt]

hi,Vishwas
    
    The Immediately Hello only reduces the time to reach the "ExStart"
state. It is unnecessary to use it when the state is more than
"ExStart". 

----- Original Message ----- 
From: "Vishwas Manral" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, December 29, 2005 6:29 PM
Subject: Re: Update to OSPF Hello

Hi,

Thanks,
Vishwas

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
The draft can be found here:
http://www.ietf.org/internet-drafts/draft-kou-ospf-immediately-replying-
hello-00.txt