Subject: [OSPF] AD Review of draft-ietf-ospf-cap

From: Bill Fenner <[email-masked]>
Date: Thu, 19 Oct 2006 14:32:39 +0200

I'm sorry for taking so long on this review.

My major comment is that I think that the bit order in
the RI TLV is confusing.  (Partly because the IETF-standard
packet picture is confusing!)

Check this combination:

       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |             Informational Capabilities                        |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

      Bit       Capabilities

      1         OSPF graceful restart capable [GRACE]
..

>From the picture, this could mean 0x40000000, while I think it intends
0x00000001.  This may be more confusing when (if) the 33rd bit is
assigned.  I'd recommend a description of the bit numbering, along
the lines of

Bits in the Informational Capabilities field are numbered beginning at
1, starting at the low-order bit of the first 32-bit word.  If further
32-bit words are used, the low-order bit of the second one is numbered
33, the next one is 65, etc.

(That's just off the top of my head and may not make complete sense).
Alternately, you could represent the bits as hex values, e.g.
0x1, 0x2, 0x4, 0x8, 0x10 instead of 1,2,3,4,5.

The other item is the IANA considerations.  Normally we don't say
that a WG is the expert, since the WG may not live forever; we say
that the IESG designates an expert, and the IESG designates the
current WG chairs while the WG exists.

  Bill

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Thu, 19 Oct 2006 18:56:21 -0400

Hi Bill,

> packet picture is confusing!)
Actually we did mean to start with the most significant bit in the 32 
bit field
consistent with IETF standard numbering. However, the document has 
changed over its
lifetime and it looks like we've missed bit 0. Since this TLV is for 
informational
purposes I think it would make sense to reclaim bit 0. I'll also claify 
the numbering
and contact someone regarding update of one of the existing 
implementations.

> current WG chairs while the WG exists.
I'll replace "subject to review by the OSPF WG" with "subject to review 
by an expert
designated by the IESG".

Thanks,
Acee

---

From: Acee Lindem <[email-masked]>
Date: Fri, 20 Oct 2006 19:05:04 -0400

Bill,
Assuming the Internet Draft editor;s automated response system doesn't 
reject my
submission due to Monday's deadline, I went ahead and made the changes
in the new 09 version of the draft.
Thanks,
Acee
Acee Lindem wrote:
> purposes I think it would make sense to reclaim bit 0. I'll also 
> claify the numbering
> I'll replace "subject to review by the OSPF WG" with "subject to 
> review by an expert
> designated by the IESG".
>
> Thanks,
> Acee
>
>>   Bill
>>

---

From: Bill Fenner <[email-masked]>
Date: Sat, 21 Oct 2006 23:08:48 +0200

>I went ahead and made the changes in the new 09 version of the draft.

Excellent.  When it comes out, I'll start an IETF Last Call.

  Bill

---

From: Bill Fenner <[email-masked]>
Date: Mon, 23 Oct 2006 10:43:51 -0700

>Since this TLV is for informational
>the numbering and contact someone regarding update of one of the existing 
>implementations.

After thinking about this a little more, if it makes more sense
to keep some of the bits where they were before due to implementations,
it's reasonable to leave a hole (either at zero, or somewhere else)
and allow that to be assigned by IANA/Expert later.

  Bill