Subject: [OSPF] OSPF GR query

From: "Khan Amir-G20247" <[email-masked]>
Date: Thu, 5 Oct 2006 21:07:36 +0800

Hi 

I have query related to OSPF Graceful Restart. 

Consider this scenario: 

- Three Routers R1, R2 and R3 connected via Broadcast networks. 

- Where R1 is a DR on both the segments, where as R2 and R3 are in
DR-other
- Now R1 wants to perform GR, R2 and R3 agrees to be its Helpers. 
- Now after restart R1 will try to form adjacency with both R2 and R3. 
- Lets say R1 and R2 had become FULL, while R1 and R3 had reached
Exstart state.   Now at this time R2 receives an LSA (any type 1-5 and
7, from some other router existing in the same area, not pictured here)
which he needs to flood to R1. 
- This will force R2 to quit Helper Status, while R1 and R3 are still in
process of forming adjacency. 

Considering above scenario, my doubts are: 

- How will R1 come to know that its Helper R2 has quit? 
- Will the adjacency between R1 and R2 needs to go down, as R2 quits
helper mode? 
- Will this effect the adjacency formation of R1 and R3?

Regards 
Aamir 

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Thu, 05 Oct 2006 10:30:04 -0400

Hello Amir,

> process of forming adjacency. 
Since he has reached FULL state, he is no longer a helper router.
> - How will R1 come to know that its Helper R2 has quit? 
Since he has reached FULL state, he is no longer a helper router.
> - Will the adjacency between R1 and R2 needs to go down, as R2 quits
No
> - Will this effect the adjacency formation of R1 and R3?
No. R3 MAY exit helper status and re-originate a new router LSA if he 
receives the new
LSA before reaching FULL state with R1 AND he is has strict-LSA-checking 
configured.

Hope this helps,
Acee
>  
>
> Regards 
> Aamir 
>
>  
>
>
>   
> ------------------------------------------------------------------------
>

---

From: "Khan Amir-G20247" <[email-masked]>
Date: Thu, 5 Oct 2006 22:55:23 +0800

Hi Ace 

But reaching to a FULL state is not one of the conditions for Helper to
quit Helper mode, I guess a Helper who has reached 
to FULL state with its restarting router will wait for Grace LSAs to be
flushed or GR timeout to happen for exiting Helper mode.

Regards
Aamir

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]] 
Sent: Thursday, October 05, 2006 8:00 PM
To: Khan Amir-G20247
Cc: [email-masked]
Subject: Re: [OSPF] OSPF GR query

Hello Amir,

> 7, from some other router existing in the same area, not pictured 
> here) which he needs to flood to R1.
> - This will force R2 to quit Helper Status, while R1 and R3 are still 
> in process of forming adjacency.
>   
No
No. R3 MAY exit helper status and re-originate a new router LSA if he
receives the new LSA before reaching FULL state with R1 AND he is has
strict-LSA-checking configured.

Hope this helps,
Acee

---

From: Acee Lindem <[email-masked]>
Date: Thu, 05 Oct 2006 11:10:33 -0400

> flushed or GR timeout to happen for exiting Helper mode.
No - The presumption is when you reach FULL state you don't need to "quit"
helping - you have "finished" helping. Over the years, there have been a
few situations that could have been better documented - however, this never
caused any confusion in the past.

Thanks,
Acee

---

From: "sujay gupta" <[email-masked]>
Date: Thu, 26 Oct 2006 13:11:06 +0530

Hi Acee,
A late mail on this thread.

given the scenario if R3-R1 is a stub area
and the incoming LSA is a type-5, even with strict LSA
checking enabled will not exit Helper mode.

It can be a nice idea to give some explicit notification
by R2 to R1 about exiting helper mode.

As rightly pointed by you the above conditions and more
has been causing some confusion for some time.
Our proposal ;
http://tools.ietf.org/wg/ospf/draft-holla-ospf-update-graceful-restart-02.txt
hopefully resolves this.
Could we add this as an addendum/reference to RFC3623?, purely an
add-on.
Best Regards.
Sujay