Subject: [OSPF] Question on SNMP for ospfv3

From: "Sunil Patro" <[email-masked]>
Date: Thu, 26 Oct 2006 14:53:57 -0700

Hi,

I have a quick question regarding the index of the neighbor table. 

Here is the SMI object definition from the draft.

ospfv3NbrTable OBJECT-TYPE 
            SYNTAX          SEQUENCE OF Ospfv3NbrEntry 
            MAX-ACCESS      not-accessible 
            STATUS          current 
            DESCRIPTION 
                "A table of non-virtual neighbor information." 
            REFERENCE 
                "OSPF Version 2, Section 10 The Neighbor Data 
                Structure" 
            ::= { ospfv3Objects 9 } 
 
    ospfv3NbrEntry OBJECT-TYPE 
            SYNTAX          Ospfv3NbrEntry 
            MAX-ACCESS      not-accessible 
            STATUS          current 
            DESCRIPTION 
                "The information regarding a single neighbor." 
            REFERENCE 
                "OSPF Version 2, Section 10 The Neighbor Data 
                Structure" 
            INDEX           { ospfv3NbrIfIndex, 
                              ospfv3NbrIfInstId, 
                              ospfv3NbrRtrId } 
            ::= { ospfv3NbrTable 1 } 

    ospfv3NbrIfIndex OBJECT-TYPE 
            SYNTAX          InterfaceIndex 
            MAX-ACCESS      not-accessible 
            STATUS          current 
            DESCRIPTION 
                "The local link ID of the link over which the 
                 neighbor can be reached." 
            ::= { ospfv3NbrEntry 1 } 
 
    ospfv3NbrIfInstId OBJECT-TYPE 
            SYNTAX          Ospfv3IfInstIdTc 
            MAX-ACCESS      not-accessible 
            STATUS          current 
            DESCRIPTION 
                "Interface instance over which the neighbor 
                can be reached. This ID has local link 
                significance only." 
            ::= { ospfv3NbrEntry 2 } 
 
    ospfv3NbrRtrId OBJECT-TYPE 
            SYNTAX          Ospfv3RouterIdTc 
            MAX-ACCESS      not-accessible 
            STATUS          current 
            DESCRIPTION 
               "A 32-bit integer uniquely identifying the neighboring 
               router in the Autonomous System." 
            ::= { ospfv3NbrEntry 3 }

The Index is {ospfv3NbrIfIndex,
			   ospfv3NbrIfInstId, 
                     ospfv3NbrRtrId}

1. ospfv3NbrIfInstId  - Does anyone have an idea about what the
interface instance ID's value can be?

Is the instance in the context apply to the routing instance the
interface is part of or something else?

Thanks,
Sunil

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Sunil Patro" <[email-masked]>
Date: Tue, 31 Oct 2006 10:57:04 -0800

Resending this as I got no response.

Thanks,
Sunil

> -----Original Message-----
> From: Sunil Patro
> Sent: Thursday, October 26, 2006 2:54 PM
> To: [email-masked]
> Subject: [OSPF] Question on SNMP for ospfv3
> 
> Hi,
>