Subject: [OSPF] Doubt in external path preference

From: vpraveen <[email-masked]>
Date: Thu, 06 Sep 2007 20:08:34 +0530

Hi All,

I have a doubt in "External path preferences" section (16.4.1) of RFC2328

Please consider the following topology:

RTB is the ASBR; there are two paths to RTB from RTA - one via area 0 and
the other through area 1.

ASBR path to RTB will be installed in area 0 and area 1 (after examining E
bit in router LSAs during SPF)

Now, while examining type 5 LSAs originated by RTB (assuming
RFC1583Compatiblity is disabled), 

only the non-backbone path (i.e. area 1) will be selected for external route
installation, since non-backbone paths 

are preferred over backbone paths when RFC1583Compatibility is disabled.

So effectively, this section gives the rules to select paths for external
route calculation among exisiting ASBR paths

and not for ASBR path calculation itself (i.e. on RTA, ASBR paths to RTB
will exist in both areas, irrespective of 

the cost to the ASBR) . 

Please let me know if my understanding is correct.

Regards

Praveen

****************************************************************************
****************************************************************************
****************************************************************************
**

 This e-mail and attachments contain confidential information from HUAWEI,
which is intended only for the person or entity whose address is listed
above. Any use of the information contained herein in any way (including,
but not limited to, total or partial disclosure, reproduction, or
dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it! 

****************************************************************************
****************************************************************************
****************************************************************************
**

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: sengottuvelan srirangan <[email-masked]>
Date: Thu, 6 Sep 2007 09:40:27 -0700 (PDT)

Hi Praveen,
   
  I hope the below section clarifies the doubt.
   
  RFC 2328 Sec, 11
   
          There are four possible types of paths used to route traffic to
        the destination, listed here in decreasing order of preference:
        intra-area, inter-area, type 1 external or type 2 external.
        Intra-area paths indicate destinations belonging to one of the
        router's attached areas.  Inter-area paths are paths to
        destinations in other OSPF areas.  These are discovered through
        the examination of received summary-LSAs.  AS external paths are
        paths to destinations external to the AS.  These are detected
        through the examination of received AS-external-LSAs.

  Regards
  Sengottuvelan

vpraveen <[email-masked]> wrote:
                Hi All,
  I have a doubt in “External path preferences” section (16.4.1) of RFC2328
  Please consider the following topology:

  RTB is the ASBR; there are two paths to RTB from RTA - one via area 0 and the other through area 1.
  ASBR path to RTB will be installed in area 0 and area 1 (after examining E bit in router LSAs during SPF)
  Now, while examining type 5 LSAs originated by RTB (assuming RFC1583Compatiblity is disabled), 
  only the non-backbone path (i.e. area 1) will be selected for external route installation, since non-backbone paths 
  are preferred over backbone paths when RFC1583Compatibility is disabled.
   
  So effectively, this section gives the rules to select paths for external route calculation among exisiting ASBR paths
  and not for ASBR path calculation itself (i.e. on RTA, ASBR paths to RTB will exist in both areas, irrespective of 
  the cost to the ASBR) . 
  Please let me know if my understanding is correct.
   
  Regards
  Praveen

  **************************************************************************************************************************************************************************************************************************************
   
   This e-mail and attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient's) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it! 
   
  **************************************************************************************************************************************************************************************************************************************

       
---------------------------------
Be a better Heartthrob. Get better relationship answers from someone who knows.
Yahoo! Answers - Check it out.

---

From: "V.PraveenKumar 70795" <[email-masked]>
Date: Fri, 07 Sep 2007 07:23:37 +0500

Hi Sengottuvelan,

For the topology specified before, should RTA have an ASBR path to RTB in area 0 (when RFC1583Comp is disabled)

Thanks & Regards
Praveen

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

----- Original Message -----
From: sengottuvelan srirangan <[email-masked]>
Date: Thursday, September 6, 2007 10:10 pm
Subject: Re: [OSPF] Doubt in external path preference

>        the destination, listed here in decreasing order of 
> preference:        intra-area, inter-area, type 1 external or type 
> 2 external.
>        destinations in other OSPF areas.  These are discovered 
> through        the examination of received summary-LSAs.  AS 
> external paths are
>  I have a doubt in ?External path preferences? section (16.4.1) 
> of RFC2328
>  ASBR path to RTB will be installed in area 0 and area 1 (after 
> examining E bit in router LSAs during SPF)
>  only the non-backbone path (i.e. area 1) will be selected for 
> external route installation, since non-backbone paths 
>  So effectively, this section gives the rules to select paths for 
> external route calculation among exisiting ASBR paths
>  and not for ASBR path calculation itself (i.e. on RTA, ASBR 
> paths to RTB will exist in both areas, irrespective of 
>  the cost to the ASBR) . 
>   This e-mail and attachments contain confidential information 
> from HUAWEI, which is intended only for the person or entity whose 
> address is listed above. Any use of the information contained 
> herein in any way (including, but not limited to, total or partial 
> disclosure, reproduction, or dissemination) by persons other than 
> the intended recipient's) is prohibited. If you receive this e-
> mail in error, please notify the sender by phone or email 
> immediately and delete it! 
>   
>