Subject: [OSPF] duplcate entries in retransmission list ?

From: ajay thakur <[email-masked]>
Date: Tue, 4 Sep 2007 15:35:48 +0100 (BST)

HI all, 
Is it possible that router tries to add same LSA entry in the neighbor retransmission list multiple times? 

 Given the fact that only {adv-rtr, LS-Id, lsa-type} are used to identify LSA. 

What is {adv-rtr,ls-id,lsa-type} is same for both the routers but ls-seq, age, checksum different for both the lsa?

Can somebody clear my doubt.

Thanks
Ajay

---------------------------------
 Once upon a time there was 1 GB storage in your inbox. Click here for happy ending.

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Matthew Thomas" <[email-masked]>
Date: Tue, 4 Sep 2007 16:56:59 +0100

Hi Ajay,

I believe these conditions have been selected to make sure this doesnt happen:

(excerpt from 2328)

    13.1.  Determining which LSA is newer

        When a router encounters two instances of an LSA, it must
        determine which is more recent.  This occurred above when
        comparing a received LSA to its database copy.  This comparison
        must also be done during the Database Exchange procedure which
        occurs during adjacency bring-up.

        An LSA is identified by its LS type, Link State ID and
        Advertising Router.  For two instances of the same LSA, the LS
        sequence number, LS age, and LS checksum fields are used to
        determine which instance is more recent:

        o   The LSA having the newer LS sequence number is more recent.
            See Section 12.1.6 for an explanation of the LS sequence
            number space.  If both instances have the same LS sequence
            number, then:

        o   If the two instances have different LS checksums, then the
            instance having the larger LS checksum (when considered as a
            16-bit unsigned integer) is considered more recent.

        o   Else, if only one of the instances has its LS age field set
            to MaxAge, the instance of age MaxAge is considered to be
            more recent.

        o   Else, if the LS age fields of the two instances differ by
            more than MaxAgeDiff, the instance having the smaller
            (younger) LS age is considered to be more recent.

        o   Else, the two instances are considered to be identical.

Matthew R Thomas
07940 585456
  ----- Original Message ----- 
  From: ajay thakur 
  To: [email-masked] 
  Sent: Tuesday, September 04, 2007 3:35 PM
  Subject: [OSPF] duplcate entries in retransmission list ?

  HI all, 

  Thanks
  Ajay

------------------------------------------------------------------------------
  Once upon a time there was 1 GB storage in your inbox. Click here for happy ending.

------------------------------------------------------------------------------

---

From: ajay thakur <[email-masked]>
Date: Tue, 4 Sep 2007 17:30:26 +0100 (BST)

You mean to say whenever we add LSA in retransmission list we should 
 remove old LSA & add new LSA in the list. ?

 Thanks
 Ajay

Matthew Thomas <[email-masked]> wrote:       Hi Ajay,

 (excerpt from 2328)

  

  

  
 Matthew R Thomas
 07940 585456
    ----- Original Message ----- 
   From:    ajay thakur 
   To: [email-masked] 
   Sent: Tuesday, September 04, 2007 3:35    PM
   Subject: [OSPF] duplcate entries in    retransmission list ?

HI all, 

Thanks
Ajay

    

---------------------------------
 5, 50, 500, 5000 - Store N number of mails in your inbox. Click here.

---

From: "Thomas, Matthew R" <[email-masked]>
Date: Tue, 4 Sep 2007 17:49:42 +0100

I believe so Ajay.
 
Matthew R Thomas
07940 585456

________________________________

From: ajay thakur [mailto:[email-masked]]
Sent: Tue 04/09/2007 17:30
To: Matthew Thomas
Cc: [email-masked]
Subject: Re: [OSPF] duplcate entries in retransmission list ?

Thanks
Ajay

Matthew Thomas <[email-masked]> wrote: 

	Hi Ajay,

	(excerpt from 2328)

	 

	 

	 
	Matthew R Thomas
	07940 585456

		----- Original Message ----- 
		From: ajay thakur <mailto:[email-masked]>  
		To: [email-masked] 
		Sent: Tuesday, September 04, 2007 3:35 PM
		Subject: [OSPF] duplcate entries in retransmission list ?

		HI all, 

		
		Thanks
		Ajay
		
________________________________

		Once upon a time there was 1 GB storage in your inbox. Click here for happy ending. <http://in.rd.yahoo.com/tagline_mail_3/*http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html/>  
________________________________

________________________________

5, 50, 500, 5000 - Store N number of mails in your inbox. Click here. <http://in.rd.yahoo.com/tagline_mail_4/*http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html/>

---

From: sengottuvelan srirangan <[email-masked]>
Date: Tue, 4 Sep 2007 10:01:00 -0700 (PDT)

Hi Ajay,
   
  No need to add duplicate copy of a LSA instead check the latest copy of a LSA based on Seqnumber, CheckSum and LSA age for given the fact (adv-rtr, ls-id, lsa-type) & Old LSA should be replaced by a new LSA in the list.
   
  Regards
  Sengottuvelan

ajay thakur <[email-masked]> wrote:
  HI all, 
Is it possible that router tries to add same LSA entry in the neighbor retransmission list multiple times? 

Thanks
Ajay
    
---------------------------------
  Once upon a time there was 1 GB storage in your inbox. Click here for happy ending._______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---------------------------------
Be a better Heartthrob. Get better relationship answers from someone who knows.
Yahoo! Answers - Check it out.