Subject: [OSPF] 1-Way event handling

From: Vikram Pendharkar <[email-masked]>
Date: Tue, 9 Nov 2010 09:39:10 -0500

Hi,

Would there be any issues if as part of 1-Way event handling we
additionally send out a hello to the neighbor immediately rather than
wait for hello timer to expire. This should speed up adjacency
formation.

Thanks,
Vikram

---

From: Dave Katz <[email-masked]>
Date: Tue, 9 Nov 2010 09:20:37 -0700

All of the implementations I'm familiar with do exactly that.  One has to be careful with the logic so as to not accidentally get into a Hello war with the neighbor, of course.

--Dave

On Nov 9, 2010, at 7:39 AM, Vikram Pendharkar wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Vikram Pendharkar <[email-masked]>
Date: Tue, 9 Nov 2010 11:50:08 -0500

That's good to know. In which case, would it make sense to update the
RFC for the same as well?

Vikram

---

From: Acee Lindem <[email-masked]>
Date: Thu, 11 Nov 2010 04:03:05 -0500

Vikram, 
We don't need a new draft for this. If you search the mailing list archives you'll find that someone else already suggested a draft on this subject and no one believed it was necessary given that 1) it is not required for interoperable protocol operation and 2) the optimization was in almost every implementation. 
Thanks,
Acee