Subject: [OSPF] OSPF::aggregating huge number 'summary LSA" originated AT PE ..

From: "Keshava.Ayanur" <[email-masked]>
Date: Tue, 16 Nov 2010 16:03:29 +0530

Hi,

Any thoughts about aggregating the "Summary LSA's' originated in PE which
was redistributed from BGP .

Regards,

Keshava.A.K.

---

From: Peter Psenak <[email-masked]>
Date: Tue, 16 Nov 2010 12:15:42 +0100

Keshava,

it's up to the implementation how it handles the aggregation of the BGP 
redistributed prefixes on PE. The most obvious choice is to treat it the 
same way as regular redistribution in which case an external LSA is 
generated for the summary itself.

RFC4577 only specifies the behavior when no aggregation is done on PE:

    In the following, we specify what is reported, in OSPF LSAs, by the
    PE to the CE, assuming that the PE is not configured to do any
    further summarization or filtering of the routing information before
    reporting it to the CE."

thanks,
Peter

On 16.11.2010 11:33, Keshava.Ayanur wrote:
> Hi,
>
> Any thoughts about aggregating the “Summary LSA’s’ originated in PE
> which was redistributed from BGP .
>
> Regards,
>
> Keshava.A.K.
>
>
>
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Rajesh Shetty <[email-masked]>
Date: Wed, 17 Nov 2010 10:37:40 +0530

Peter,

When PE report the route as Type3 LSA to CE (redistributed, might be huge in
number), In this scenario is there a good mechanism to aggregate Type3 LSAs
at PE before sending to CE.

For such kind of Type3 Aggregation should we use backbone area range since
PE router is considered as integral part of OSPF backbone?

Thanks
Rajesh

This e-mail and attachments contain confidential information from HUAWEI,
which is intended only for the person or entity whose address is listed
above. Any use of the information contained herein in any way (including,
but not limited to, total or partial disclosure, reproduction, or
dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Peter Psenak
Sent: Tuesday, November 16, 2010 4:46 PM
To: Keshava.Ayanur
Cc: [email-masked]
Subject: Re: [OSPF] OSPF::aggregating huge number 'summary LSA" originated
AT PE ..

Keshava,

thanks,
Peter

On 16.11.2010 11:33, Keshava.Ayanur wrote:
> Hi,
>
> Any thoughts about aggregating the "Summary LSA's' originated in PE

---

From: "Keshava.Ayanur" <[email-masked]>
Date: Wed, 17 Nov 2010 12:16:17 +0530

Peter,

Instead of leaving this to implementation, it is better to define the exact
behavior/rules how to be handled.

Else there may be many possibilities like 
	a)aggregation based on backbone area range, 
	b)on area-id map, corresponding area range ..

Keshava

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Rajesh Shetty
Sent: Wednesday, November 17, 2010 10:38 AM
To: 'Peter Psenak'
Cc: [email-masked]
Subject: Re: [OSPF] OSPF::aggregating huge number 'summary LSA" originated
AT PE ..

Peter,

Thanks
Rajesh

-----Original Message-----

Keshava,

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Wed, 17 Nov 2010 11:19:37 +0100

Keshava,

I do not see a reason why this needs to be standardized, as this 
represents a local behavior of the PE and does not pose any 
interoperability issues.

thanks,
Peter

---

From: Acee Lindem <[email-masked]>
Date: Wed, 17 Nov 2010 10:06:43 -0500

Hi Peter, Keshava, 
I agree wholeheartedly with Peter. We've never standardized redistribution policy in the past and there is no reason to do it now. 
Thanks,
Acee