Subject: [OSPF] [Editorial Errata Reported] RFC2328 (2632)

From: RFC Errata System <[email-masked]>
Date: Sat, 13 Nov 2010 13:33:56 -0800 (PST)

The following errata report has been submitted for RFC2328,
"OSPF Version 2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=2328&eid=2632

--------------------------------------
Type: Editorial
Reported by: Dave Cowley <[email-masked]>

Section: 11.

Original Text
-------------
    Cost
        The link state cost of the path to the destination.  For all
        paths except type 2 external paths this describes the entire
        path's cost.  For Type 2 external paths, this field describes
        the cost of the portion of the path internal to the AS. 

Corrected Text
--------------
    Cost
        The link state cost of the path to the destination.  For all
        paths except type 2 external paths this describes the entire
        path's cost.  For Type 1 external paths, this field describes
        the cost of the portion of the path both internal and external
        to the AS.  

Notes
-----
'Type 2 cost' is listed in the subsequent 'field' description for section 11 (The Routing Table Structure).

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2328 (no draft string recorded)
--------------------------------------
Title               : OSPF Version 2
Publication Date    : April 1998
Author(s)           : J. Moy
Category            : STANDARD
Source              : Open Shortest Path First IGP
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Dave Katz <[email-masked]>
Date: Sat, 13 Nov 2010 18:49:49 -0800

Um, there's nothing wrong with the original text.  This erratum is erroneous.

The "Cost" field described is the intra-AS cost of the path;  for all but type-2 externals, the internal cost *is* the total path cost.  For type-2 externals, the internal cost is...the internal cost, and is ultimately discarded.

--Dave

On Nov 13, 2010, at 1:33 PM, RFC Errata System wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Acee Lindem <[email-masked]>
Date: Sun, 14 Nov 2010 18:05:37 -0500

This errata is incorrect and should not be applied. The description of cost is correct the way it is and this change would only confuse the distinction between "Cost" and "Type 2 Cost". 

Thanks,
Acee