Subject: [OSPF] removing Controlled Convergence TLV from draft-ietf-ospf-mrt

From: Chris Bowers <[email-masked]>
Date: Mon, 17 Oct 2016 15:54:12 +0000

OSPF WG,

The authors of draft-ietf-ospf-mrt are planning to remove the Controlled Convergence TLV from that draft,
and instead use an equivalent extension being defined in:

https://tools.ietf.org/html/draft-bryant-rtgwg-param-sync-00

Since the Controlled Convergence TLV communicates information that may be useful for
applications other that MRT, it makes sense to have it in a separate document to allow it to be
better vetted in the context of those other applications.

I don't think that anyone has implemented the Controlled Convergence TLV in draft-ietf-ospf-mrt.
But if this is not the case, or anyone has another objection to removing it from draft-ietf-ospf-mrt-02, please
raise that objection in the next week or so.

Thanks,
Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 20 Oct 2016 17:37:15 +0000

Hi Chris, Alia, Stewart,
Since the OSPF RI LSA already provides for generic advertisement of router specific OSPF and non-OSPF parameters, I see no value in defining a generic network wide TLV. Just define a TLV for Convergence Time and the associated behavior. In your generic mechanism, many of the elements of the mechanism are deferred to the specific parameter and I don’t see any value here in adding this level of classification.
Thanks,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of Chris Bowers <[email-masked]<mailto:[email-masked]>>
Date: Monday, October 17, 2016 at 11:54 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] removing Controlled Convergence TLV from draft-ietf-ospf-mrt

OSPF WG,

I don’t think that anyone has implemented the Controlled Convergence TLV in draft-ietf-ospf-mrt.
But if this is not the case, or anyone has another objection to removing it from draft-ietf-ospf-mrt-02, please
raise that objection in the next week or so.

Thanks,
Chris